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Introduction
This document describes the Cisco TelePresence Management Suite Analytics Extension (Cisco TMSAE).

Cisco TMSAE is an online analytical processing (OLAP) system for Cisco TelePresence Management Suite 
(Cisco TMS) that provides advanced reporting functionality for your video network.

The extension is installed on an existing Cisco TelePresence Management Suite server and creates and 
maintains new information stores. These new information stores enhance the type of data available for Cisco 
TMS customers, and provide a standardized, supported way of accessing reporting data.

Cisco TMSAE uses Microsoft's SQL Server Analysis Services to provide business knowledge, customized 
reporting, and integration with Business Intelligence applications, enabling standardized, OLAP-compatible 
clients such as Microsoft Excel to access a known and supported list of information about the usage of your 
visual communications network without disrupting ongoing operations.

The data types and API used by this application are described in a separate document, Cisco TelePresence 
Management Suite Analytics Extension Reference Guide.
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Technical overview
This section aims to  assist administrators in understanding system dependencies by providing explanations 
of how Cisco TMSAE components are created and used in ongoing operations.

 

Cisco TMSAE components and roles
The following  illustration and table explain the various elements involved with Cisco TMSAE and how they 
relate to each other.
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Component/role Description

Cisco TMS Web Server The Windows installation that hosts the TMS web application. The TMS Web 
Server also requires a TMS SQL Server, which may or may not be the same 
Windows Server.

TMS SQL Server The Microsoft SQL Server hosting the TMS Database. In smaller installations, this 
server is typically hosted on the same physical server that the TMS Web Server is 
hosted on. In advanced installations, these tasks are usually different physical 
Windows Servers.

TMS Database The main database used by TMS itself. This database is hosted by the TMS SQL 
server role and the default name of the database is tmsng.

TMS SQL Login The SQL Login used by the TMS Web Server to access the tmsng database. By 
default, this is the sa account of the TMS SQL server, but can be customized 
during TMS installation.

Data Warehouse Server The Microsoft SQL Server that will be hosting the Analytics Databases and SQL 
Server Analysis Services. This server can be the same SQL server as the TMS 
SQL Server, but is recommended to be a separate SQL server. This Server 
installation must be operational before attempting to install the Analytics 
Extension.
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Component/role Description

Data Warehouse Database A new database created by Cisco TMSAE which serves as the long-term data 
repository for the Analytics Extension. This database is hosted by the Data 
Warehouse Server

Data Warehouse cube A new specialized multi-dimensional database created by the Analytics Extension 
which contains the pre-computed data created by the Analytics Extension. This 
database is hosted by the SQL Server Analysis Services Instance running on the 
Data Warehouse Server.

DWH Service User A Windows domain user account used by the Analytics Extension to log into the 
data warehouse Server for ongoing operations. This account will be given the 
necessary permissions by the Cisco TMSAE installer.

DWH TMS Service User A SQL Login for the TMS SQL server used by the Analytics Extension to read data 
from the TMS Database. This account is a SQL Login, not a Windows Account and 
must have at least the db_datareader role.

Data warehouse server
Cisco TMSAE comprises two major elements: the data warehouse database and the data warehouse cube.

Data warehouse database

The data warehouse (DWH) database is used for analysis and data mining, and contains information from the 
Cisco TMS database combined with data computations and analysis.

This database is created in an SQL server instance of the data warehouse server using credentials specified 
by the installing user. 

The default database name is tmsng_dwh. 

Database users

Ordinary users of the Analytics Extension API do not connect to this database.

The DWH service user is defined as the owner of the database, and this service account is used by Cisco 
TMSAE to log into the database for ongoing operations.

The data warehouse database accesses the Cisco TMS database through a linked server that is 
automatically created on the data warehouse server during installation, using the Cisco TMS database 
location and DWH TMS service user credentials supplied during installation.

The DWH TMS service user is an SQL login for the Cisco TMS SQL server. This account only needs db_
datareader permissions to access the Cisco TMS database, and can reuse any existing login with sufficient 
SQL access permissions.

Data warehouse cube

The data warehouse cube is a specialized type of database used in analysis and data mining. Its main 
advantage is its ability to hold pre-computed aggregates of data across many different dimensions, allowing 
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fast manipulation of queries. The data warehouse cube is created during installation in the Analysis Services 
instance on the data warehouse server. 

The data warehouse cube holds different data defined as facts, each of which has different defined 
dimensions, which can be used to manipulate the information stored in the different fact tables. 

Cisco TMSAE provides sets of facts and dimensions that can be used by programmers and analytics users. 
For a detailed overview of these fact tables and dimensions, see Cisco TelePresence Management Suite 
Analytics Extension Reference Guide.

The default name for the database is tmsng_dwhAsDb (the name format is    <database>AsDb).

Cube users

Ordinary users of the Cisco TMSAE API connect to this cube using an OLAP client, such as Microsoft 
Excel, and their Windows Domain accounts (with reader role permissions).

The DWH service user is configured as the owner of the cube. These credentials are used by Analytics 
Extension to connect to the cube for ongoing operations.

Data warehouse updates

Data mining and long term analysis of information on data warehouse contents are performed using historical 
data rather than real-time data as in the traditional reporting information viewed via TMS. 

The DWH data is refreshed daily by the Windows Service installed on the TMS web server by Cisco 
TMSAE, which initiates two updates: the ETL job and the cube refresh.

ETL job

The ETL job is initiated by the Windows service at a scheduled time using the supplied DWH service user 
credentials. The job extracts all data recorded since it was last run from the TMS database, and updates 
values and computations stored in the data warehouse database. 

Because only new information is processed, the ETL task is extremely efficient. It executes on the data 
warehouse server and uses the defined linked server to read information from the TMS database, placing no 
significant extra load placed on the TMS web server. 

In addition to the scheduled task, an administrator may also initiate the ETL job to run on demand using the 
web interface.

Cube refresh

The cube refresh is performed daily after the data warehouse database has been updated by the ETL task. 
The Windows service connects to the Analytics Service on the data warehouse server using the DWH 
service user credentials and tells the cube to refresh. The cube uses the connection properties defined in the 
cube's Data Source definition to connect to the data warehouse database.

Service account permissions and uses
Note that if the account password is changed for either of the below users, the installation must be 
reconfigured. See the section Reconfiguring Cisco TMSAE [p.20]  for more information.
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Data warehouse service user

The data warehouse service user account is used by Cisco TMSAE to log into the data warehouse database 
and data warehouse cube. This user account must be a valid Windows domain account. It does not need any 
pre-existing permissions. It is also used by the data warehouse cube to connect to the data warehouse 
database in the Database Engine instance.

DWH TMS service user

The TMS service user account is used by the data warehouse server to pull data from the Cisco TMS 
database. This account must have an SQL Login capable of connecting to the TMS database tmsng. It only 
needs SQL login access to the TMS and the db_datareader role on the TMS database.
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Using the Web interface
The Analytics Extension web interface is accessed via your existing Cisco TMS installation. This section 
provides further  information about the interface.

Note that if the server name or address used in the URL to access Cisco TMS and the address in the 
Analytics Extension URL configured in Administrative Tools are different, you may be prompted with a 
username/password dialog when accessing Cisco TMSAE.

The Analytics Extension web interface

Reading the Log ETL jobs panel
The ETL job extracts information from the source TMS database and updates the data warehouse server 
databases. This panel shows the status and log details for past runs of the ETL job and can be used to verify 
the job is running, or help diagnose why the data warehouse databases are not updating.

Note that the page does not automatically refresh. Click the Refresh button to refresh the list with the latest 
information.

 n Job Status – Shows a checkmark if the job was complete, a red X if it failed, or a gear icon if it is currently 
in progress.
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 n Start Time – The start time of the job, in TMS Server time.
 n Batch Duration – How long the job has been running for or how long the job took to complete.
 n Batch Errors – If a job fails, diagnostic information is listed here. Click on the entry to expand the box and 

see more information.
 n Run ETL Job Now – Click to manually initiate an immediate ETL job. Note that this task may take a 

significant amount of time to complete. 
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Adding and managing users
Cisco TMSAE has two classes of users:

 n Analytics users who are consumers of the data output.
 n Administrators who have access to diagnostic information and settings.

SSAS authentication
SQL Server Analysis Services (SSAS) uses a strict security model and only Windows authentication is 
supported. Any user or client must have a valid Windows Domain account trusted by the SSAS instance. 

Note that while some software clients allow a user to specify which account they will use to authenticate to 
SSAS, others only support Integrated Authentication where the credentials of your current user identity are 
used.

Adding and removing Analytics users
Users who wish to read data from Cisco TMSAE must have access and reader permissions to the data 
warehouse cube hosted by SSAS.

Adding a user
To ease configuration, the data warehouse cube has a custom reader role defined during installation. Users 
who have this role will have access to read, but not modify any information in the data warehouse cube. 
Grant access to the information made available via Cisco TMSAE  by adding users to this reader role.

To add a new user to the reader role:

 1. Open SQL Server Management Studio, and connect to the relevant SSAS instance.
 2. Locate Databases > tmsng_dwhAsDb > Roles.
 3. Right-click Reader and select Properties.
 4. Go to the Membership subpage. Click Add… to enter users or groups. To grant read access to domain 

members, use the Everyone group. Use the Authenticated Users group to exclude guest accounts and 
anonymous users.
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Removing a user
To remove a user from the reader role:

 1. Open Management Studio, and connect to the relevant SSAS instance.
 2. Locate Databases > tmsng_dwhAsDb > Roles.
 3. Right-click Reader and select Properties.
 4. Go to the Membership subpage. Select the user to remove and click Remove. 

Administrator roles

Cisco TMSAE administrators
To manage group membership and permissions in Cisco TMS, go to Administrative Tools > User 
Administration.

 n To view the web interface, you must be a member of a user group in Cisco TMS that has the 
Configuration > Read permission. 
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 n To run the ETL job, the user must be a member of a user group in TMS that has the Configuration > 
Update permission.

Adding Analysis services server administrators
Access to the data warehouse cube and data exposed by Cisco TMSAE is controlled via the SSAS 
administrator role. Administrative privileges for the Analysis Services instance are controlled by the server 
role in the Analysis Services server instance.

By default, local administrators of the Windows Server are members of the server role and have full access 
to all features and data in the server instance. Other users can be added to the server role to grant them 
administrator rights. To add another user to the server role:

 1. In SQL Server Management Studio, connect to the instance of Analysis Services.
 2. Right-click the instance name in Object Explorer and then click Properties.
 3. In the Select a Page pane, click Security.
 4. Click Add to add one or more Windows users or groups to the server role.
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Setting up the cube connection to Microsoft 
Excel 
Microsoft Excel is a widely deployed tool capable of reading the cube. The following section describes how to 
connect to the cube using Excel. 

Before connecting, make sure that:

 n The client is in the same domain as the data warehouse server.
 n The data warehouse server Windows Firewall is not blocking connections to Analysis Services.

Sample Excel files
Open the Analytics Extension web interface (figure below), locate the Download Excel Sample Files panel 
and click the Download all samples link. This will download a .zip archive containing five sample files.

Depending on your local security settings, the tables in the sample files may appear to be empty. If so, a 
security warning will appear above the sheet:

 1. Click the Options… button on the notification bar.
 2. In the dialog that appears, select Enable this content and click OK to enable data connections. 
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Setting up connections in Excel 2007 and 2010
The instructions below have been tested in Excel 2007 and 2010.

 1. Open Microsoft Excel, and go to the Insert ribbon. 
 2. Click the drop-down arrow on the PivotTable button and select either PivotTable or PivotChart. Note that 

a cell (any cell) must be selected for this menu option to be active.

 3. Select Use an External data source and click Choose Connection.
 4. In the Existing Connections window, click Browse for more….
 5. In the Select Data Source window, click New Source… to open the Data Connection Wizard.
 6. Select Microsoft SQL Server Analysis Services. Click Next.
 7. You will now be prompted for a server name, which must be the data warehouse server.
 8. Add an instance name if applicable. Click Next.
 9. Accept the default values and click Finish.
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 10. The pivot table/chart is now ready to use. 

Setting up connections in Excel 2003

Microsoft SQL Server Analysis Services OLE DB Provider
For Excel 2003 users, Microsoft SQL Server Analysis Services OLE DB Provider must be installed on the 
client computer before trying to connect. This component exists in two versions, one for SQL Server 2005 
and one for SQL Server 2008. These can be downloaded from Microsoft from the following locations:

 n Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider
 n Microsoft SQL Server 2008 Analysis Services 10.0 OLE DB Provider

Connecting to the cube
The following steps describe how to connect to the cube after the OLE DB provider is installed.

 1. Open Microsoft Excel, and go to Data > Import External Data > Import Data…. 
 2. In the Select Data Source window, click New Source… to open the Data Connection Wizard.
 3. Select Microsoft SQL Server OLAP Services. Click Next.
 4. You will now be prompted for a server name. This must be the data warehouse server. Add an instance 

name if applicable.     Select Use Windows Authentication to avoid potential authentication issues with 

http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en


Setting up the cube connection to Microsoft Excel

Cisco TMSAE Administrator Guide (1.2) Page 18 of 32

Excel.

The Data Connection Wizard

 5. Select the database that contains the cube. The default database name is "tmsng_dwhAsDb". This 
database will contain a single cube, called "TMS_cube_1_0". Select this cube, and click Finish.         

 6. Back in the Select Data Source window, select the source you just created, and click Open.
 7. Using the Pivot Table and PivotChart Wizard, accept the default values and click Finish.
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 8. The pivot table is now ready to use.         



Reconfiguring Cisco TMSAE

Cisco TMSAE Administrator Guide (1.2) Page 20 of 32

Reconfiguring Cisco TMSAE
Cisco TMSAE provides a reconfiguration wizard. Common causes for reconfiguration are updates to a server 
address, an expired password, changes to other account information, or server configuration or network 
changes.

The wizard allows you to update:

 n Destination database server name or IP address .
 n Username and password for the data warehouse service account.
 n Source TMS database server name or IP address .

When to use the reconfiguration wizard
While the reconfiguration wizard lets you to update the server addresses used by the installation, it cannot 
move any databases or create new accounts. The wizard can only be used to update your installation with 
external changes. If you need to change which servers host the TMS or data warehouse databases, those 
changes must be made by the SQL Administrator manually before the reconfiguration wizard can be used to 
update the software.

We recommend that the reconfiguration wizard not be used to replace the source database with an entirely 
different Cisco TMS database. The reconfiguration wizard is useful in cases where the underlying data is 
either the same, or a logical continuation of the current database (such as the current database with more 
data).

Running the reconfiguration wizard
Reconfiguring Cisco TMSAE will temporarily halt other web services on the same IIS, as the World Wide 
Web Publishing Service will be stopped and restarted by the wizard. The expected downtime is a few 
seconds.

The reconfiguration wizard will summarize your proposed changes and wait for confirmation before making 
any changes.

 1. Open the Start menu and select Cisco > Reconfigure Cisco TMSAE.
 2. Click Next to start.
 3. On the Change, repair, or remove installation screen, click Reconfigure.
 4. Select the authentication mode and enter credentials to use for the reconfiguration.                 

There are two supported methods of authentication, both of which require the user to have the sysadmin 
role on the selected SQL server and administrative access to Analysis Services:                 
 l Current User Context—Use the Windows user account you are currently signed in as to complete  the 

installation.
 l Windows Authentication—Provide the username and password for an alternate user account to use for 

the installation steps.
Click Next.

 5. Specify the remaining connection details for the data warehouse server:
 a. Enter the server name or IP address for the server.
 b. Enter the username and password of the data warehouse database account, taking care to enter them 
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in the correct case should the SQL server be configured for case sensitivity.
 c. Click Next.

 6. Specify the connection details for the Cisco TMS database:
 a. Enter the server name or IP address.
 b. Enter the SQL username and password for an account with read access to the Cisco TMS database, 

normally called tmsng.
 c. Verify that the database name is correct or modify as appropriate.
 d. Click Next.

 7. The next dialog screen provides an overview of the settings and servers that will be used during 
reconfiguration. Click Reconfigure to initiate the reconfiguration process.

 8. Click Finish to close the reconfiguration wizard.
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Troubleshooting

Logs
If you experience difficulties with Cisco TMSAE, technical support may ask you to supply log files along with 
a description of your issue. For information on installer logs, see Cisco TelePresence Management Suite 
Analytics Extension Installation Guide.

Application Logs
Problems with the Analytics Extension web interface or the Windows Service that initiates the update jobs 
are logged in files located on the web server where the Analytics Extension was installed. Logged events 
from the Analytics Extension web interface and the Analytics Extension Service are stored in the following 
locations:

 n <installation directory>\Cisco\TMSAE\ReportingService\Logs
 n <installation directory>\Cisco\TMSAE\AdminWeb\App_Data\Logs

These files are plain text but are low level and intended for debugging purposes by support personnel.

Database Logs
The data warehouse itself also keeps logs useful for troubleshooting; these entries are stored in the database 
itself in the following tables:

 n orc.ExecutionEventLog
 n orc.ErrorEventLog
 n dwh.AppliedPatch
 n dwh.InstallerEventLog

The logs may be browsed using any SQL tool. To save all the entries in these logs to a file:

 1. Open Management Studio and connect to the database engine instance
 2. Expand Databases, find your data warehouse database (tmsng_dwh by default)
 3. Right-click on the database and select "New Query".
 4. Set the Results to save to a file. Right click in the Query Menu, and select Results to > Results to File.
 5. In the query window, type in the following four commands:     

 l SELECT * FROM orc.ExecutionEventLog;
 l SELECT * FROM orc.ErrorEventLog;
 l SELECT * FROM dwh.AppliedPatch;
 l SELECT * FROM dwh.InstallerEventLog;

 6. Click the Execute button to run the query. You will be prompted for a file name to save the results to. This 
will be a CSV file of the output you can share with technical support if requested.
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Data quality issues

Repeating or inaccurate data
When using Microsoft Excel to connect to the Cisco TMSAE cube, if the values you get are obviously 
inaccurate or repeating (as in the figure below, where there seem to be 139 systems in each folder), you may 
be trying to use a dimension on a measure that the dimension is not applicable to.

Repeating/inaccurate data

Dimensions whose names beginning with "Source" or "Destination" may only be used on Fact Call. For all 
other fact tables,  use dimensions without the "Source" and "Destination" prefixes.

For example, when using the System Count measure, applying Source Folder will give you meaningless 
results. To get correct data, use Folder instead.

As a general rule when working with pivot tables in Excel, always use the Show field related to: drop down 
at the top of the pivot table field list. If you, for example, set this drop down to System, Excel will only display 
dimensions that can be applied to this fact table.

Misleading Fact MCU Utilization data 
Specific conditions may cause misleading Fact MCU Utilization data, such as Peak Actual Used Video 
Ports or Peak Audio Port Utilization, as detailed below.

For example, if you have two MCUs in your video deployment, each with 40 video ports, getting a Peak 
Actual Used Video Ports count of 86 is obviously incorrect. An incorrect Port figure will also slightly skew 
Utilization calculations.

CDR generation in Cisco TMS 13.0 and 13.1

Prior to Cisco TMS 13.0 and Cisco TelePresence MCU 4.2, call detail records were generated in Cisco TMS 
based on feedback from the MCU. To improve data quality, CDRs are now generated by and collected from 
the MCU.
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In Cisco TMS version 13.1, duplicate CDR generation may occur, affecting MCU statistics in Cisco TMS 
and by extension Fact MCU Utilization statistics in Cisco TMSAE.

This issue is addressed in Cisco TMS 13.1.2 and later with Cisco TelePresence MCU version 4.2 and later. 
Note that the fix will not purge previously created duplicate CDRs.

Reconnected MCU port

In some scenarios, if participants in a multipoint conference lose connection to an MCU and reconnect, the 
new connection may use a different port on the MCU. If the initial port has not yet been released, the 
participant can occupy two ports. This results in the MCU reporting a misleading participant count to Cisco 
TMS.

Port usage imprecision

Depending on port availability, participants may have their connection downgraded (video to audio) or 
upgraded (audio to video) during a conference.

Any participant that has used a video port at any point during a conference, will be reported as a video 
participant when the conference ends. This means, for example, that a conference may be reported as 
having 0 audio participants although multiple audio ports were in use during the conference, skewing video 
and audio port usage statistics.

Calls appearing in Cisco TMS are missing from the Analytics Extension 
cube
The Endpoint CDR reporting functionality in Cisco TMS relies on CDRs collected directly from the 
endpoints.

This is different from Cisco TMSAE, which relies on data collected from Cisco VCS. If Cisco TMS receives 
feedback from the endpoint but not from the Cisco VCS that the endpoint is registered to, calls involving this 
endpoint will be displayed in the Cisco TMS reporting pages but not in the Cisco TMSAE cube.

To verify that the Cisco VCS is sending feedback to Cisco TMS:

 1. Locate the VCS in the System Navigator in TMS
 2. Click the Logs tab, and go to the Call Log. 

All calls shown in the call log will be included in the Cisco TMSAE cube the next time the ETL job runs.

If the call log is empty, correct its external manager address:

On the Cisco VCS:

 1. Go to System Configuration > External Manager.
 2. Make sure the Address field contains the IP address or host name of the Cisco TMS server.

In Cisco TMS:

 1. Go to Administrative Tools > Configuration > Network Settings. 
 2. Make sure that all fields in the Advanced Network Settings for Systems on Internal LAN section 

show the correct IP addresses and host name for your Cisco TMS.
 3. Locate the Cisco VCS in Systems > Navigator.
 4. Go to Settings > Edit Settings, and click the Enforce Management Settings button.
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Using an SSH client

 1. Log in to the Cisco VCS as the admin user. 
 2. Type xstatus. You now see the full configuration of the Cisco VCS, including attributes not visible in the 

Cisco TMS web interface. 
 3. Locate the output starting with "Feedback 3". 
 4. If the "URL:" value contains either the IP address or host name of Cisco TMS, and the "Status:" value is 

On, the Cisco VCS is correctly set up to send feedback to Cisco TMS.

Sample Feedback 3 values from running the "xstatus" command on the Cisco VCS.

Web site issues

User does not have sufficient permissions in TMS to view this module
A bug in SQL server can produce this error even when permissions are set correctly. A failed login attempt 
results in the following message in the web application log file log-AdminWeb.txt:

"System.Data.SqlClient.SqlException: Login failed for user '<domain/account>'. Reason: Server is in script 
upgrade mode. Only administrator can connect at this time."

This can occur after a fresh installation of Microsoft SQL Server or after installing a SQL server service pack. 
Rebooting the server resolves this issue.

An error has occurred!
This generic error message asks you to look in the Logs [p.22] for further information.

The most common cause is SQL connectivity problems. Look for a SQL Network Interfaces: Error 
Locating Server/Instance Specified message in log-AdminWeb.txt.

See Cisco TelePresence Management Suite Analytics Extension Installation Guide for information on 
troubleshooting connection errors.
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The generic "An error has occurred" message

ETL job failure

Multiple "Error: Internal error: The operation terminated unsuccessfully."
Getting multiple "Error: Internal error: The operation terminated unsuccessfully." messages in the same ETL 
job indicates that there have been major changes in the TMS database since you last ran the job, and that the 
Analytics Extension is unable to extract data because of schema changes or changes in constraints.

These errors can occur if you have used the reconfiguration tool to replace the source database with an 
entirely different TMS database. As described in  the sectionReconfiguring Cisco TMSAE [p.20], the wizard 
tool should not be used for such changes. To fix the problem, use the reconfiguration tool again to return the 
source database to the original Cisco TMS database.

Client Connectivity Issues

Encryption not supported on the client
Client unable to establish connection; 08001; Encryption not supported on the client.; 08001

If the ETL job log shows multiple "Internal error: The operation terminated unsuccessfully" errors and a 
"Client unable to establish connection; 08001; Encryption not supported on the client.; 08001" error, your 
SQL Server Analysis Services instance is unable to connect to the data warehouse SQL relational database.

To correct the issue, reinstall the SQL Native Client on the data warehouse server. The safest way of 
reinstalling the SQL Native Client is by upgrading your SQL Server instance to the latest service pack. If you 
already have the latest service pack and still encounter this issue, download the Microsoft SQL Server 2008 
Service Pack 2 Feature Pack or the Feature Pack for Microsoft SQL Server 2005, uninstall the current SQL 
Native Client, and reinstall the SQL Native Client from the downloaded feature pack.

We recommend upgrading the SQL Server instance to the latest service pack rather than reinstalling the SQL 
Native Client module. If you get a version mismatch between the SQL Native Client and the other SQL 
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Server components, this can cause issues for other applications relying on the SQL Server. Installing the 
latest SQL Server service pack is the recommended procedure whenever possible.

Microsoft Excel and Windows Authentication
Initialization of the data source failed

When connecting to a data warehouse cube in environments where Integrated Authentication is not available 
or fails, Excel may run into authentication problems. The user will not be warned about this when creating the 
connection to Analysis Services and the connection will apparently be created properly. However, later when 
the user tries to use the connection in a Pivot Table or Pivot Chart, the user will get an Initialization of the 
data source failed error.

A workaround to the problem is appending the connection string manually:

 1. In Excel, go to Data > Existing Connection. 
 2. Select the relevant connection, and click Open.
 3. In the Import Data window that follows, click Properties… 
 4. Go to the "Definition" tab. 
 5. Append the text string in the "connection string" field with ";password=<your password>". Note the 

semicolon in front.
Example: If the user account is named "peter.jones", the connection string might look like this:

Provider=MSOLAP.3;Persist Security Info=True;User ID=REPORTING\peter.jones;Initial 
Catalog=tmsng_dwhAsDb;Data Source=analytics.reporting.tms.lab;MDX Compatibility=1;Safety 
Options=2;MDX Missing Member Mode=Error

If the password of the account is "ENGLAND66", the modified string should look like this:

Provider=MSOLAP.3;Persist Security Info=True;User ID=REPORTING\peter.jones;Initial 
Catalog=tmsng_dwhAsDb;Data Source=analytics.reporting.tms.lab;MDX Compatibility=1;Safety 
Options=2;MDX Missing Member Mode=Error;password=ENGLAND66

Checking the "Save password" box will make the changes to the connection string persistent. However, note 
that the connection string is stored unencrypted in an XML file on the local disk.
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Manually appending the connection string

The LocaleIdentifier property
XML for Analysis parser: The LocaleIdentifier property is not overwritable and cannot be assigned a 
new value

After creating a connection, the error message XML for Analysis parser: The 
LocaleIdentifier property is not overwritable and cannot be assigned a new 
value may appear when you try to utilize the connection in a pivot table or chart. This issue only applies to 
certain combinations of old versions of Excel and SSAS. The following Microsoft Connect page describes a 
workaround: Error when creating an Excel Pivot Table from a SSAS project.

 1. Right click the connection in the Select Data Source window and select Open with Notepad to edit the 
connection file as described in the Microsoft Connect page.         
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Opening the connection for editing

 2. Locate the <odc:ConnectionString> element, and append ";Locale Identifier=1033" (note 
the semicolon) to the end of the element's content.) Click Save.

 3. The connection is now updated and ready for use.

Finding TCP port numbers with SQL Server Analysis 
Services
The default TCP port for SQL Analysis Services is 2383. Named instances will by default use a dynamic 
TCP port number. The server can be setup to listen on a specific static port by editing the server property 
<Port> via SQL Management Studio or the msmdsrv.ini file of the instance.

There are two ways of finding the dynamic TCP port number currently in use by an Analysis Services 
instance, described below.
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Solution 1: Using the command prompt
 1. Start Task Manager on the Server.
 2. Ensure the PID (Process Identifier) column is visible (View Menu > Select Columns…).
 3. Locate the process named msmdsrv.exe and find its PID.
 4. Start a command prompt, and run the command netstat /aon.
 5. Find the line with the PID matching your process and the port number will be displayed in the Local 

Address field.

Solution 2: Viewing the Application Log
The server will write an informational message to the Windows Application event log during service startup 
noting how the instance is listening on the network.

 1. Start Task Manager on the Server.
 2. Open the Application Log in the Event Viewer.

The information will be in an event of type Information with a source of MSSQL$<INSTANCENAME>. It will 
have a description like in the example below, where the port number is 1072:

Server is listening on ['any' <ipv4> 1072].
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