Newer Design Guide Available

Cisco Smart Business Architecture has become part of the Cisco Validated Designs program. For up-to-date guidance on the designs described in this guide, see http://cvddocs.com/fw/Aug13-415

For information about the Cisco Validated Design program, go to http://www.cisco.com/go/cvd
Preface

Who Should Read This Guide

This Cisco® Smart Business Architecture (SBA) guide is for people who fill a variety of roles:

- Systems engineers who need standard procedures for implementing solutions
- Project managers who create statements of work for Cisco SBA implementations
- Sales partners who sell new technology or who create implementation documentation
- Trainers who need material for classroom instruction or on-the-job training

In general, you can also use Cisco SBA guides to improve consistency among engineers and deployments, as well as to improve scoping and costing of deployment jobs.

Release Series

Cisco strives to update and enhance SBA guides on a regular basis. As we develop a series of SBA guides, we test them together, as a complete system. To ensure the mutual compatibility of designs in Cisco SBA guides, you should use guides that belong to the same series.

The Release Notes for a series provides a summary of additions and changes made in the series.

All Cisco SBA guides include the series name on the cover and at the bottom left of each page. We name the series for the month and year that we release them, as follows:

month year Series

For example, the series of guides that we released in February 2013 is the “February Series”.

You can find the most recent series of SBA guides at the following sites:

Customer access: http://www.cisco.com/go/sba
Partner access: http://www.cisco.com/go/sbachannel

How to Read Commands

Many Cisco SBA guides provide specific details about how to configure Cisco network devices that run Cisco IOS, Cisco NX-OS, or other operating systems that you configure at a command-line interface (CLI). This section describes the conventions used to specify commands that you must enter.

Commands to enter at a CLI appear as follows:

configure terminal

Commands that specify a value for a variable appear as follows:

ntp server 10.10.48.17

Commands with variables that you must define appear as follows:

class-map [highest class name]

Commands shown in an interactive example, such as a script or when the command prompt is included, appear as follows:

Router# enable

Long commands that line wrap are underlined. Enter them as one command:

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100

Noteworthy parts of system output or device configuration files appear highlighted, as follows:

interface Vlan64
  ip address 10.5.204.5 255.255.255.0

Comments and Questions

If you would like to comment on a guide or ask questions, please use the SBA feedback form.

If you would like to be notified when new comments are posted, an RSS feed is available from the SBA customer and partner pages.
# Table of Contents

## What's In This SBA Guide
- Cisco SBA Collaboration ......................................................... 1
- Route to Success ......................................................................... 1
- About This Guide ....................................................................... 1

## Introduction .............................................................................. 2
- Business Overview ...................................................................... 2
- Technical Overview ..................................................................... 2

## Deployment Details ................................................................. 5
- Preparing the Platform for Unified CCX ...................................... 5
- Installing Cisco Unified CCX ......................................................... 8
- Configuring the Help Desk ......................................................... 16
- Configuring the Client Desktop Software ..................................... 27

## Appendix A: Product List .......................................................... 34

## Appendix B: Changes ............................................................... 36
Cisco SBA Collaboration

Cisco SBA helps you design and quickly deploy a full-service business network. A Cisco SBA deployment is prescriptive, out-of-the-box, scalable, and flexible.

Cisco SBA incorporates LAN, WAN, wireless, security, data center, application optimization, and unified communication technologies—tested together as a complete system. This component-level approach simplifies system integration of multiple technologies, allowing you to select solutions that solve your organization’s problems—without worrying about the technical complexity.

Cisco SBA Collaboration is a design incorporating unified communications, video collaboration, and web conferencing. By building upon the hierarchical model of network foundation, network services, and user services, Cisco SBA Collaboration provides dependable delivery of business applications and services.

Route to Success

To ensure your success when implementing the designs in this guide, you should first read any guides that this guide depends upon—shown to the left of this guide on the route below. As you read this guide, specific prerequisites are cited where they are applicable.

About This Guide

This deployment guide contains one or more deployment chapters, which each include the following sections:

- **Business Overview**—Describes the business use case for the design. Business decision makers may find this section especially useful.
- **Technology Overview**—Describes the technical design for the business use case, including an introduction to the Cisco products that make up the design. Technical decision makers can use this section to understand how the design works.
- **Deployment Details**—Provides step-by-step instructions for deploying and configuring the design. Systems engineers can use this section to get the design up and running quickly and reliably.

You can find the most recent series of Cisco SBA guides at the following sites:

Partner access: [http://www.cisco.com/go/sbachannel](http://www.cisco.com/go/sbachannel)
Introduction

Business Overview

The ability to easily add functionality into the telephony environment for corporate help desks has been challenging. Organizations use help desks in their Human Resources departments to answer personnel questions, in IT departments to help employees with their computer problems, and in their facilities departments to maintain and manage their buildings. A help desk minimizes the time it takes to answer employees’ questions and maximizes the available internal resources.

Traditional contact center solutions are difficult to implement because of the additional hardware components and the complexity of the software needed to implement them. The work is normally done by highly trained engineers who spend the majority of their time working with contact centers. The complexity makes the implementation a long process and the additional expertise makes the installation and maintenance expensive. Agents are required to work at the location of the contact center equipment because the inherent limitations of the hardware prevent them from working remotely. It is very difficult to integrate the overall system with the corporate data because common interfaces are not readily available.

Technical Overview

The next-generation IP help desk takes advantage of a company’s internal network by making use of the IP private branch exchange (PBX) and other IP-based applications to create a better experience for the callers. Calls are routed to available agents who have the expertise to answer the questions, regardless of their physical location in the company. Agents can view information about the caller through integration with corporate databases; and historical data is saved and viewed in easily readable reports that help improve the day-to-day workings of the help desk. These are just a few of the benefits offered by a fully integrated IP help desk.

Cisco Unified Contact Center Express (Unified CCX) is the IP-based help desk solution offered by Cisco Systems. It is tightly integrated with other Cisco Unified Communications platforms. Design and testing is performed on the suite of Unified Communications products as part of a complete solution. Configuration of Unified CCX is easier than traditional systems because the components talk to each other over the internal IP network, which helps streamline the procedures. For example, when a phone number is created on Unified CCX to reach a help desk application, no additional configuration is needed in the Cisco Unified Communications Manager (Unified CM). The configuration is sent over the network to Unified CM and the directory number is created. Unified CM is automatically configured to pass calls for the directory number to Unified CCX for further processing.

When a call is placed to the help desk, it is first processed by Cisco Unified CM, which recognizes that the number is destined for the Cisco Unified CCX application server. Unified CCX receives the incoming call and identifies which application script is needed to handle the request based on the extension number that was dialed. The script plays prompts and collects digits as dictated by the steps in the script and, if necessary, uses the information from the caller to select an appropriate agent. If an appropriate agent is not available, the call is put in queue and music is streamed to the caller. As soon as an agent is available, Unified CCX instructs Unified CM to ring the agent’s phone. When the agent picks up, information about the caller is populated into the agent’s desktop application and the conversation begins.

Cisco Unified CCX has the features of a large contact center packaged into a single- or dual-server deployment. The system scales up to 400 concurrent agents, 42 supervisors, 150 agent groups, and 150 skill groups. It includes email, outbound calling, inbound calling, workforce optimization, and reporting.
Figure 1 - Typical Cisco Unified CCX deployment in the foundation architecture
The Cisco Unified CCX features are listed in more detail below:

- **Automatic call distributor (ACD)**—Unified CCX routes calls by using skills or resource groups. Skills-based routing distributes the call based on the skill level of the agent for a particular topic. It is the method most often used. Resource-group routing distributes calls to agents based on the resource group to which the agents are assigned.

- **Interactive voice response (IVR)**—IVR controls the interaction between the caller, prompts, and menus. Depending on the options the caller enters into the system, IVR uses an application script to determine how to handle the call. IVR can read or write corporate database information, play information such as tracking numbers to callers, and collect information from the caller through digits or speech recognition.

- **Agent Email**—Agent Email allows customers to contact the help desk by email. Agents are assigned skills, and email is distributed to agents based on their skills. Email agents can use preset templates in their replies to avoid writing repetitive emails.

- **Agent Desktop**—Cisco Agent Desktop is an application that resides on the agent’s computer. Agents use the application to log in at the beginning of their shifts, indicate whether they are in a ready state or on a break, and log out at the end of the day. When an agent is logged in and ready, calls are sent to Agent Desktop, which presents information about the incoming call. The application has an integrated browser to access a customer database or browse the Internet to help answer a question. Agent Desktop is a great tool for agents because everything they need to do their job is in one place, which allows them to focus on answering the caller’s question.

- **Supervisor Desktop**—Cisco Supervisor Desktop helps supervisors keep track of real-time statistics such as how many calls are in queue, the number of agents available, and the average time a caller is spending in queue. Supervisors can also use Supervisor Desktop to coach agents by silently monitoring calls, chatting with agents, joining a call, and pushing a webpage down to an Agent Desktop. Supervisor Desktop helps supervisors ensure that calls are being handled on a timely basis and agents are not giving callers incorrect information. If there is an issue, Supervisor Desktop allows them to quickly address the problem.

- **Reporting**—Cisco Unified CCX saves statistics in an internal database that can be accessed by the historical reporting client application to create reports. Reports can be scheduled on a recurring basis or created as needed. Reports can be general, such as information about the entire help desk over a year, or specific, such as information about a particular agent for one day. Historical reports allow managers to get a big picture of their help desk and to make changes to address issues.

- **Workforce Management**—Workforce Management is a tool that uses a sophisticated algorithm to look through historical data and create a schedule that will have the right number of agents on staff at the right times during the day. This tool helps ensure that more agents are on staff at busy times and agents have scheduled breaks during slow times.

- **Quality Manager**—Quality Manager is a tool that records calls. Quality Manager randomly selects calls throughout the day to be recorded, or you can select specific calls to record. This tool also creates standardized score sheets to help determine how well the agent handled the call. Quality Manager is a great coaching tool designed to make the help-desk experience more satisfying for the caller.

Cisco Unified CCX is a powerful application. Through its strong scripting engine, easy-to-use desktops, extensive reporting tools, and sophisticated workforce optimization, it can successfully operate even the most complicated corporate help desks. The next several sections of this document will guide you through the process of installing and configuring Cisco Unified CCX in a Unified CM environment.
Cisco Unified CCX runs on the same Linux operating systems as several other Unified Communications platforms from Cisco. You install the operating system with the application by using the standard installation DVD.

**Deployment Details**

**Preparing the Platform for Unified CCX**

1. Configure platform connectivity to the LAN
2. Prepare the server for Unified CCX

**Process**

For a quick and easy installation experience, it is essential to know up front what information you will need. For Cisco Unified CCX, make sure you have completed the following steps before you start:

- If you are installing Cisco Unified CCX on a new virtual machine (VM), download the Open Virtualization Archive (OVA) file from the Cisco website:
  

- Determine if there is a patch for your version of Cisco Unified CCX by checking the Cisco website:
  

The Cisco Unified Contact Center Express server can be connected to a Cisco Nexus switch in the data center or a Cisco Catalyst switch in the server room. In both cases, QoS policies are added to the ports to maintain voice quality during the setup and completion of calls. Please choose the option that is appropriate for your environment.

**Option 1. Connect Cisco Unified CCX to a Nexus 2248UP**

**Step 1:** Login to the Nexus switch with a username that has the ability to make configuration changes.

**Step 2:** If there is a previous configuration on the switch port where the Unified CCX is connected, remove the individual commands by issuing a `no` in front of each one to bring the port back to its default state.

**Step 3:** Configure the port as an access port and apply the QoS policy.

```plaintext
interface Ethernet107/1/18
  description Unified Contact Center Express
  switchport access vlan 148
  spanning-tree port type edge
  service-policy type qos input DC-FCOE+1P4Q_INTERFACE-DSCP-QOS
```

**Tech Tip**

When deploying a dual-homed Cisco Nexus 2248, you must apply this configuration to both Nexus 5548s.
Option 2. Connect Cisco Unified CCX to a Catalyst 3750-X

To ensure that signaling traffic is prioritized appropriately, you must configure the Cisco Catalyst access switch port where Cisco Unified CCX is connected to trust the Differentiated Services Code Point (DSCP) markings. The easiest way to do this is to clear the interface of any previous configuration and then apply the egress QoS macro that was defined in the access-switch platform configuration of the Cisco SBA—Borderless Networks LAN Deployment Guide.

Step 1: Login to the Catalyst switch with a username that has the privileges to make configuration changes.

Step 2: Clear the interface’s configuration on the switch port where the Unified CCX is connected.

```plaintext
default interface GigabitEthernet1/0/18
```

Step 3: Configure the port as an access port and apply the Egress QoS policy.

```plaintext
interface GigabitEthernet1/0/18
  description Unified Contact Center Express
  switchport access vlan 148
  switchport host
  macro apply EgressQoS
```

Procedure 2 Prepare the server for Unified CCX

You must choose one of the following options, depending upon how you plan to deploy the server:

- If you are installing a virtual machine, follow the steps in Option 1, “Prepare a virtual machine for Cisco Unified CCX.”
- If you are installing a standalone server, locate the Cisco Unified CCX DVD that shipped with your order, and then follow the steps in Option 2 “Prepare a server for Cisco Unified CCX.”

The following tables describe the scaling options for Cisco Unified CCX:

### Table 1 - Cisco Unified CCX virtual machine scaling options

<table>
<thead>
<tr>
<th></th>
<th>100 agents</th>
<th>300 agents</th>
<th>400 agents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual CPUs</td>
<td>2</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>CPU speed</td>
<td>900 MHz</td>
<td>900 MHz</td>
<td>900 MHz</td>
</tr>
<tr>
<td>RAM</td>
<td>4</td>
<td>4</td>
<td>8</td>
</tr>
<tr>
<td>Hard disk</td>
<td>146 GB (1)</td>
<td>146 GB (2)</td>
<td>146 GB (2)</td>
</tr>
<tr>
<td>VMware ESXi</td>
<td>4.0, 4.1.5.0</td>
<td>4.0, 4.1.5.0</td>
<td>4.0, 4.1.5.0</td>
</tr>
<tr>
<td>OS support</td>
<td>RHE Linux 5 (32-bit)</td>
<td>RHE Linux 5 (32-bit)</td>
<td>RHE Linux 5 (32-bit)</td>
</tr>
<tr>
<td>Total agents</td>
<td>100 or fewer</td>
<td>100 to 300</td>
<td>300 to 400</td>
</tr>
</tbody>
</table>

### Table 2 - Cisco Unified CCX standalone server scaling options

<table>
<thead>
<tr>
<th></th>
<th>100 agents</th>
<th>400 agents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco MCS equivalent</td>
<td>7835</td>
<td>7845</td>
</tr>
<tr>
<td>CPU Type</td>
<td>E5504 quad-core</td>
<td>E5540 quad-core</td>
</tr>
<tr>
<td>CPU speed</td>
<td>2.0 GHz</td>
<td>2.53 GHz</td>
</tr>
<tr>
<td>RAM</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td>Hard disk</td>
<td>300 GB (2)</td>
<td>300 GB (4)</td>
</tr>
<tr>
<td>OS support</td>
<td>RHE Linux 5 (32-bit)</td>
<td>RHE Linux 5 (32-bit)</td>
</tr>
<tr>
<td>Total agents</td>
<td>100 or fewer</td>
<td>100 to 400</td>
</tr>
</tbody>
</table>

Option 1. Prepare a virtual machine for Cisco Unified CCX

When you install Cisco Unified CCX on VMware, follow the steps below to deploy an OVA file to define the virtual machine requirements. You use the Open Virtualization Format (OVF) support of VMware to import and deploy the OVA file.

Step 1: In the VMware vSphere client, choose File > Deploy OVF Template.

Step 2: Click the Browse button next to the Deploy from a file or URL box, find the location of the OVA file that you downloaded from Cisco, and then click Next.
Step 3: Verify the information on the OVF Template Details page, and then click Next.

Step 4: Read the End User License Agreement, click Accept, and then click Next.

Step 5: Enter the following information in the Deploy OVF Template wizard, and then click Finish.
   • On the Name and Location page, in the Name box, enter the virtual machine name CCX1, and then click Next.
   • On the Deployment Configuration page, choose the Configuration type from the pull-down menu, and then click Next.
   • On the Storage page, choose the location to store the VM files, and then click Next.
   • On the Disk Format page, choose Thick Provision Eager Zeroed, and then click Next.
   • On the Ready to Complete page, verify the settings, and then click Finish. In the message window, click Close.

Step 6: After the virtual machine is created, click the server name: CCX1, navigate to the Getting Started tab, and then choose Edit virtual machine settings.

Step 7: On the Hardware tab, click CD/DVD Drive 1, and then select the Connect at power on check box.

Step 8: Select Datastore ISO File, click Browse, and then navigate to the location of the Cisco Unified CCX bootable installation file. After selecting the correct ISO image, click OK.

Step 9: On the Getting Started tab, choose Power on the virtual machine.

Step 10: Click the Console tab and then watch the server boot.
The virtual machine is prepared for installation.
Option 2. Prepare a standalone server for Unified CCX

Step 1: Physically install the server and attach the monitor, keyboard, and network cable.

Step 2: Insert the DVD with Cisco Unified CCX into the DVD drive, and then power up the server.

The standalone server is prepared for installation.

Process

Installing Cisco Unified CCX

1. Install the Unified CCX platform
2. Set up application administration

The process is the same whether you are installing in a virtual environment or on a standalone server.

Make sure you have the following information:

- Time zone for the server
- Host name, IP address, network mask, and default gateway
- Domain Name System (DNS) server IP addresses
- Administrator ID and password
- Organization and unit
- Location, state, and country
- Network Time Protocol (NTP) server IP addresses
- Security password
- Application username and password

Complete the tasks listed below before you start the installation:

- In DNS, configure the Cisco Unified CCX host name: CCX1
- Obtain license files from the Cisco licensing system.

Procedure 1 Install the Unified CCX platform

After the ISO/DVD loads, continue the installation on the server console.

Step 1: On the DVD Found page, perform a media check by selecting Yes.

Step 2: If the media check is successful, choose OK.

If the media check does not pass, contact Cisco Technical Assistance Center or your local representative to replace the media, and then repeat Step 1.

Step 3: On the Product Deployment Selection page, verify the product is Cisco Unified Contact Center Express, and then choose OK.

Step 4: On the Proceed with Install page, verify that the version is correct, and then choose Yes.

Step 5: On the Platform Installation Wizard page, choose Proceed.

Step 6: If no upgrade patch exists for the version you are installing, on the Apply Patch page, choose No.

If an upgrade patch does exist, on the Apply Patch page, choose Yes, and then follow the instructions to complete the process.

Step 7: On the Basic Install page, choose Continue.
Step 8: On the Timezone Configuration page, select the correct time zone for the server location, and then choose OK.

Choose the correct timezone from the following list:
- America/Jamaica
- America/Juneau
- America/Kentucky/Louisville
- America/Kentucky/Monticello
- America/La_Paz
- America/Lima
- America/Los_Angeles

Step 9: On the Auto Negotiation Configuration page, choose Continue.

Step 10: On the MTU Configuration page, choose No.

Step 11: On the Static Network Configuration page, enter the following information, and then choose OK.
- Host Name—CCX1
- IP Address—10.4.48.126
- IP Mask—255.255.255.0
- GW Address—10.4.48.1
Step 12: On the DNS Client Configuration page, enter the following information, and then choose OK.
- Primary DNS—10.4.48.10
- Domain—cisco.local

Step 13: On the Administrator Login Configuration page, enter the following information, and then choose OK.
- Administrator ID—Admin
- Password—[password]
- Confirm Password—[password]
Step 14: On the **Certificate Information** page, enter the information that will be used to generate security certificates, and then choose **OK**.

- **Organization**—Cisco Systems, Inc.
- **Unit**—Unified Communications Group
- **Location**—San Jose
- **State**—California
- **Country**—United States

**Tech Tip**

These fields must match the information submitted to Cisco, or the licenses will not be valid.

Step 15: On the **First Node Configuration** page, choose **Yes**.

Step 16: On the **Network Time Protocol Client Configuration** page, enter the following information, and then choose **OK**.

- **NTP server 1**—10.4.48.17
Step 17: On the Security Configuration page, enter the password for server-to-server communication, and then choose OK.

**Tech Tip**

These passwords must match the information submitted to Cisco, or the licenses will not be valid.

Step 18: On the SMTP Host Configuration page, choose No.

**Tech Tip**

These values are used to initially access the Cisco Unified CCX Administration page and must match the license information submitted to Cisco. When specific users are given administrative rights during the application setup procedure, the initial user-name and password entered above will no longer work.

Step 19: On the Application User Configuration page, enter the following information, and then choose OK.

- Application User Username—CCXAdmin
- Password—[password]
- Confirm Password—[password]
Step 20: On the Platform Configuration Confirmation page, choose OK.

The system will go through the rest of the installation process without user input. The system will reboot a few times during installation. The process can take 60 minutes or more, depending on your hardware.

After the software has finished installing, the login prompt appears on the console.

Step 21: If you deployed your server from a virtual template, return to the VMware vSphere client to disable the CD/DVD drive.

If you deployed a standalone server, skip to the next procedure.

Step 22: From the vSphere client, navigate to the virtual machine’s Getting Started tab, and choose Edit virtual machine settings.

Step 23: On the Hardware tab, choose CD/DVD Drive 1.

Step 24: Clear Connect at power on, and then click OK.

Procedure 2 Set up application administration

After the software is installed, you use the web interface in order to complete the rest of the procedures.

Step 1: With your web browser, access the IP address or hostname of the Cisco Unified CCX server and in the center of the page, click Cisco Unified Contact Center Express.

If you receive a warning about the website’s security certificate, ignore it and continue to the page.

Step 2: Enter the name and password you entered on the Application User Configuration page in Step 19 of the “Install the Unified CCX platform” procedure, and then click Login.

Step 3: On the Cisco Unified CCX Administrator Setup page, choose Fresh Install, and then click Next.

Step 4: On the Cisco Unified CM Configuration - Service Provider Configuration page, enter the following information, and then click Next.

- Unified CM server IP address—10.4.48.110 (publisher)
- AXL Admin UserName—CUCMAdmin
- Password—[password] (must match the password on Cisco Unified CM)

Step 5: On the License Information page, click Browse, locate the Unified CCX license file received from Cisco, click Open, and then click Next.

Step 6: After the license validation is completed, click Next.

Step 7: After all of the components are successfully activated, click Next.
Step 8: On the Publisher Activation page, click Next.

Step 9: On the Cisco Unified CM Configuration page, in the AXL Service Provider Configuration section, under Selected AXL Service Providers, select the Unified CM server 10.4.48.110 (publisher), and then click the right-facing arrow to remove it from the list.

Step 10: Under Available AXL Service Providers, select the Unified CM servers 10.4.48.111 (subscriber 1) and 10.4.48.112 (subscriber 2), and then click the left-facing arrow to move them under Selected AXL Service Providers.

Step 11: In the Cluster Wide Parameters section, enter the following information:
- User Name—CUCMAdmin
- Password—[password]

Step 12: In the Unified CM Telephony Subsystem - Unified CM Telephony Provider Configuration section, under Available CTI Managers, select the Unified CM servers 10.4.48.111 (subscriber 1) and 10.4.48.112 (subscriber 2), and then click the left-facing arrow to move them under Selected CTI Managers.

Step 13: In the Cluster Wide Parameters section, enter the following information:
- User Prefix—CCX_jtapi
- Password—[password]
- Confirm Password—[password]

Step 14: In the RmCm Subsystem - RmCm Provider Configuration section, under Available CTI Managers, select the Unified CM servers 10.4.48.111 (subscriber 1) and 10.4.48.112 (subscriber 2), and then click the left-facing arrow to move them under Selected CTI Managers.
Step 15: In the Cluster Wide Parameters section, enter the following information, and then click Next.

- User Id—CCX_rmjta pi
- Password—[password]
- Confirm Password—[password]

Unified CCX sends the user information to the Unified CM server, and the application users are created automatically.

For historical reporting of the number of HR sessions, use the maximum number of supervisors or administrators who will be running Unified CCX reports at the same time. For the Recording Count, enter the maximum number of concurrent ad-hoc recording sessions.

The G.711 codec choice requires one of the following choices for calls that do not originate from the same region and location as the Unified CCX server:

1. Transcoders must be configured in Unified CM and added to the media resource group list at the Unified CCX site to allow contact center calls to and from the remote sites
2. The regions must allow 64 kbps as the maximum audio bit rate between their site and the Unified CCX site for the contact center calls

If one of these two options is not completed, contact center calls from remote sites will experience a fast-busy tone when calling the main pilot number for Unified CCX.

Step 16: On the System Parameters Configuration page, enter the following information, and then click Next:

- Number of HR sessions—4
- Recording Count—25
- Number of Outbound seats—100
- Codec—G.711

Step 17: On the Language Configuration page, enter the language that will be used for default IVR prompts, the Cisco Agent Desktop, and the Cisco Supervisor Desktop, and then click Next.

Step 18: On the Desktop Client Configuration Tool message, click OK.
**Step 19:** On the User Configuration page, select the Cisco Unified CM users who need administrative rights, click the left-facing arrow to move them to the Cisco Unified CCX Administrator section, and then click Finish.

The initial application administration setup is now complete. Please close your web browser.

---

**Process**

**Configuring the Help Desk**

1. Create the call control group
2. Create skills
3. Assign skills to contact service queues
4. Associate a phone to an agent user ID
5. Associate user ID to a phone or profile
6. Assign skills to resources
7. Create the supervisors and teams
8. Create scripts and applications
9. Add a trigger
10. Associate Unified CCX application user
11. Create and upload the prompts
12. Verify Unified CCX Engine status

After you configure the application administration for the first time, the next task is to configure the help desk to allow the system to begin taking calls from end users.

**Procedure 1  Create the call control group**

A call control group creates a group of computer telephony integration (CTI) ports on Cisco Unified CM that are used to send calls to Unified CCX for IVR treatment and queuing. The call stays on the CTI port until it is sent to an agent.
Step 1: Access the IP address or hostname of the Cisco Unified CCX server by using your web browser and then, in the center of the page, click Cisco Unified Contact Center Express.

**Tech Tip**
The account created during the installation of the server will no longer work for administering the application.

Step 2: Enter the username and password of one of the users you assigned administrative rights in Step 19 of the previous procedure, and then click Login.

Step 3: Navigate to Subsystems > Cisco Unified CM Telephony > Call Control Group, and then click Add New.

Step 4: Enter the following information, and then click Add:
- Description—Unified CM Telephony Group
- Number of CTI ports—4
- Media Termination Support—No
- Group Type—Inbound
- Device Name Prefix—CTIP
- Starting Directory Number—8009950
- Device Pool—DP_HQ1_1 (default for headquarters location)
- DN Calling Search Space—CSS_Base
- Location—Hub_None
- Partition—PAR_Base

Leave the rest of the fields at their default settings.

---

**Procedure 2 Create skills**

Create skills for each different type of call you expect to receive in the call center.

**Step 1:** Navigate to Subsystems > RmCm > Skills and click Add New.
**Step 2:** On the Skill Configuration page, enter IT, and then click Save.

**Step 3:** On the Skills search page, click Add New.

**Step 4:** On the Skill Configuration page, enter HR, and then click Save.

**Step 5:** To create additional skills, repeat Step 3 and Step 4.

---

**Procedure 3 Assign skills to contact service queues**

Create contact service queues for each skill entered in the previous procedure.

**Tech Tip**
The Contact Service Queue (CSQ) names created here must exactly match the queue names referenced in the application scripts which are described later in this document. The example script uses the CSQ names of IT and HR. Be sure to add these queues to the server.

**Step 1:** Navigate to Subsystems > RmCm > Contact Service Queues and click Add New.
Step 2: On the first Contact Service Queue Configuration page, enter the following information, and then click Next:
- Contact Service Queue Name—IT
- Contact Service Queue Type—Voice
- Automatic Work—Disabled
- Wrap-up Time—Disabled
- Resource Pool Selection Model—Resource Skills
- Service Level—5 (seconds)
- Service Level Percentage—70
- Prompt—No Selection

Step 3: On the second Contact Service Queue Configuration page, enter the following information, and then click Add:
- Resource Selection Criteria—Longest Available
- Select Required Skills—IT (and then next to the window, click Add)
- Minimum Competence—5

Step 4: For each additional skill, click Add New, and then repeat Step 2 and Step 3 using the appropriate information.

---

**Procedure 4  Associate a phone to an agent user ID**

There are two ways to associate agents and supervisors with a phone. You can use extension mobility to allow agents to log in to a Cisco IP phone or you can associate an agent’s Cisco Unified CM user ID directly with a phone. Both options can be used for the same Cisco Unified CCX installation. Choose extension mobility if your agents move around from day to day or if you have more than one shift and the same phone will be used by multiple agents. Choose the phone association method if the agents work from the same phone every day.

Step 1: Use your web browser to access the IP address or hostname of the Cisco Unified CM publisher and then, in the center of the page, click Cisco Unified CM Administration.
Step 2: Enter the application administrator username and password for Cisco Unified CM, and then click Login.

Perform the next several steps only if you are planning to associate agents directly to a phone. If you will use extension mobility exclusively with your agents, you can skip to the next procedure.

Step 3: Navigate to Device > Phone, click Find, and then click the name of the agent’s phone.

Step 4: On the Phone Configuration page, click line [1]. This adds the Cisco Unified CCX information for the specific line on the phone.

Step 5: Scroll down to the bottom of the page, and then click Associate End Users.

Step 6: On the Find and List Users page, click Find, and then choose the agent for this line by selecting the check box next to their name.

Step 7: Click Add Selected. You return to the previous page.

Step 8: Repeat Step 3 through Step 7 for each additional agent and supervisor phone using each agent’s and supervisor’s specific information.

Option 1. Phone association

Step 1: Navigate to User Management > End User, and then click Find.

Step 2: Select the agent or supervisor from the previous procedure, and then click the user ID.

Step 3: On the End User Configuration page, scroll down to the Device Information section, and then click Device Association.

Step 4: On the User Device Association page, click Find.

Step 5: Select the check box next to the agent’s phone, and then click Save Selected/Changes.

Step 6: In the upper-right corner of the page, in the Related Links list, choose Back to User, and then click Go.

Procedure 5  Associate user ID to a phone or profile

In this procedure, you associate the agent and supervisor user ID to a phone or extension mobility profile. Please choose one or both of the following options:
- If you are associating agents with phones, follow the steps in Option 1 “Phone association.”
- If your agents will use extension mobility to login to their phones, follow the steps in Option 2 “Extension mobility association.”
**Step 7:** On the End User Configuration page, scroll down to the Extension Mobility section, and then confirm that the Allow Control of Device from CTI check box is selected.

**Step 8:** Scroll down to the Directory Number Associations section, set the IPCC Extension to the phone’s directory number from the previous procedure, and then click Save.

**Step 9:** For each additional agent or supervisor using phone association, repeat Step 1 through Step 8 using their specific information.

**Option 2. Extension mobility association**

**Step 1:** Navigate to User Management > End User, and then click Find.

**Step 2:** Select the agent or supervisor, and then click the user ID.

**Step 3:** On the End User Configuration page, scroll down to the Device Information section, select the agents profile from the Available Profiles: jbooth_Profile, and then click the Down-Arrow icon to move it into the CTI Controlled Device Profiles.

**Step 4:** Scroll down to the Extension Mobility section, and then confirm the Allow Control of Device from CTI check box is selected.

**Step 5:** Scroll down to the Directory Number Associations section, set the IPCC Extension to the agent’s extension mobility number, and then click Save.

**Step 6:** For each additional agent or supervisor using extension mobility association, repeat Step 1 through Step 5 using their specific information.
**Procedure 6** Assign skills to resources

Cisco Unified CM users associated with IPCC extensions show up automatically as resources in Cisco Unified CCX. Using the resource list on the Cisco Unified CCX Administration page, you assign skills to resources, making them available to answer calls in particular Contact Service Queues (CSQs).

**Step 1:** Use your web browser to access the IP address or hostname of the Cisco Unified CCX server and then, in the center of the page, click **Cisco Unified Contact Center Express**.

**Step 2:** Enter the name and password of a user with administrative rights to Cisco Unified CCX, and then click **Login**.

**Step 3:** Navigate to **Subsystems > RmCm > Resources**. On the Resources search page, click a user under the **Resource Name**.

**Step 4:** On the **Resource Configuration** page, in the Unassigned Skills field, select the skill that you want to assign, and then click the left-facing arrow to move it to Assigned Skills.

**Step 5:** Select the Competence Level for the resource, and then click **Update**.

**Step 6:** For each additional resource, repeat Step 3 through Step 5, using the appropriate information for each agent.

**Procedure 7** Create the supervisors and teams

The first step in building a team is to create a supervisor. A supervisor has a full view of a team’s performance and can monitor the agents by using the Cisco Supervisor Desktop.

**Step 1:** Navigate to **Tools > User Management > Supervisor Capability View**.

**Step 2:** On the User Configuration page, in the Available Users field, select the users you want to designate as supervisors, click the left-facing arrow, and then click **Update**.

**Step 3:** Navigate to **Subsystems > RmCm > Teams** and click **Add New**.
Step 4: On the Team Configuration page, enter the following information, and then click Save.

- Team Name—IT
- Primary Supervisor—[Supervisor]
- Assigned Resources—[Agent or supervisor]
- Assigned CSQs—IT

Step 5: For each additional team, repeat Step 3 and Step 4, using the appropriate information.

### Procedure 8 Create scripts and applications

In this procedure, an externally created script is uploaded to the server to demonstrate how to upload your script and create your site specific application.

#### Reader Tip

This guide uses the example script and prompts from a zip file that is included with the document. The script can be used as a template for your help desk application. The zip file can be found under the COL Guides tab at [http://www.cisco.com/go/sba/](http://www.cisco.com/go/sba/). Please use the example script as a template for your scripts.

Step 1: Navigate to Applications > Script Management, and then click Upload Scripts.

Step 2: Click Browse, find the location of the script (scripts have the file extension .aef), and then click Upload.

Step 3: After the script is successfully uploaded, click Return to Script Management.

Step 4: Navigate to Applications > Application Management and click Add New.

Step 5: On the Add A New Application page, select Cisco Script Application, and then click Next.
Step 6: On the Cisco Script Application page, enter the following information, and then click Add.

- Name—Help Desk
- ID—[automatic setting] (do not change this value)
- Maximum Number of Sessions—4
- Script—SCRIPT[SBAHelpdesk.aef]
- Description—Help desk for IT and HR
- Enabled—Yes
- Default Script—System Default

Step 3: On the Cisco Unified CM Telephony Trigger Configuration page, enter the following information:

- Directory Number—8009940 (CTI Route Point that will be automatically created in Unified CM to direct calls to this application)
- Language—English (United States) [en_US]
- Device Name—InternalHelp
- Description—Trigger for Internal Help Desk
- Call Control Group—Unified CM Telephony Group(1)

Procedure 9  Add a trigger

The trigger for an application is the phone number the users will dial when they want to speak with someone in the help desk.

Step 1: In the upper-left of the Cisco Script Application page, click Add New Trigger.

Step 2: In the Trigger Type drop-down list, choose Unified CM Telephony Trigger, and then click Next.
Step 4: Click Show More, enter the following information, and then click Add:

- Enabled—Yes
- Maximum Number of Sessions—Default
- Idle Timeout (in ms)—5000
- Override Media Termination—No
- Alerting Name ASCII—Help Desk Pilot
- Device Pool—DP_HQ1_1 (headquarters default)
- Location—Hub_None (headquarters default)
- Partition—PAR_Base (phone default)
- Voice Mail Profile—None
- Calling Search Space—CSS_Base

Leave the rest of the fields at their default settings.

Procedure 10  Associate Unified CCX application user

The next set of steps associates the Cisco Unified CCX application user with the phones, extension mobility profiles, CTI Route Point, and CTI Ports in Unified CM. Please choose one or both of the following options:

- If you are associating agents and supervisors directly to phones, follow the steps in option 1 “Phone association.”
- If your agents and supervisors are using extension mobility on their phones, follow the steps in option 2 “Extension mobility association.”

Step 1: From a new browser window, access the IP address or hostname of the Cisco Unified CM publisher and then, in the center of the page, click Cisco Unified CM Administration.

Step 2: Enter the administrator username and password for Cisco Unified CM, and then click Login.

Step 3: Navigate to User Management > Application User.

Step 4: On the Application User search page, click Find, and then click CCX_rmjtapi.

Step 5: On the Application User Configuration page, in the Device Information section under Available Devices, select the Unified CCX CTI ports and the Unified CCX CTI route point, and then click the down-facing arrow.
Option 1. Phone association

Step 6: On the Application User Configuration page, in the Device Information section under Available Devices, select the agent and supervisor phones, and then click the down-facing arrow.

Step 7: After all the phones have been moved into the Controlled Devices section, click Save.

Option 2. Extension mobility association

Step 6: On the Application User Configuration page, in the Device Information section under Available Profiles, select the agent and supervisor profiles, and then click the down-facing arrow.

Step 7: After all the profiles have been moved into the CTI Controlled Device Profiles section, click Save.

Procedure 11 Create and upload the prompts

In this procedure, externally created prompts are uploaded to the server to demonstrate how to upload your prompts.

Reader Tip

This guide uses the example script and prompts from a zip file that is included with the document. The zip file can be found under the COL tab at the following: http://www.cisco.com/go/sba/.

Please use the example prompts as templates for your recordings.

Prompts are played to the callers when they are in the application. You must record the prompts as .wav files and save them in a location reachable by the PC accessing the Cisco Unified CCX Administration page.

Step 1: Return to the Cisco Unified CCX Administration main page.

Step 2: Navigate to Applications > Prompt Management, and then click the en_US folder.

Step 3: After the folder opens, click Upload Prompts.

Step 4: From the Upload Prompt page, click Browse, locate the prompt WAV file, select it, and then click Upload.

Step 5: For each of the prompts repeat Step 4, and then click Return to Prompt Management.
Step 6: Navigate to Applications > Application Management, and click the application that you created in Procedure 8, “Create scripts and applications.”

Step 7: To change the default SBA prompts, select the check box next to each one, click Show Prompts, and then choose the appropriate file from the list of your own uploaded prompts. After they are all chosen, click Update.

**Tech Tip**

Custom prompts must have the following WAV format when uploading them to the server:

- Bit Rate: 64 kbps
- Audio sample size: 8 bit
- Channels: 1 (mono)
- Audio sample rate: 8 kHz
- Audio format: CCITT u-Law

Note that the new prompt names must match the variable values listed in the script application or they will not play.

---

**Procedure 12 Verify Unified CCX Engine status**

Check the status of the Cisco Unified CCX engine in order to ensure the integration with CUCM is working properly and is ready to receive calls.

**Step 1:** Using the Navigation drop down menu in the top right of the page, select Cisco Unified CCX Serviceability, and then click Go.

**Step 2:** Navigate to Tools > Control Center-Network Services.

**Step 3:** On the Cisco Unified CCX Engine line, the Status should read In Service; if this is the case, the configuration of the server is complete and you can skip ahead to Configuring the Client Desktop Software. If the Status is Partial Service, continue to the next step to attempt to fix the problem.

**Step 4:** Using the Navigation drop down menu in the top right select Cisco Unified CCX Administration and click Go.

**Step 5:** Navigate to Subsystems > Cisco Unified CM Telephony > Data Synchronization.

**Step 6:** Select Call Control Group(s), Trigger(s), and CM Telephony User(s) and click Data Resync.

**Step 7:** Repeat Step 1 thru Step 3 to recheck if Unified CCX Engine has come into service.
Process

Configuring the Client Desktop Software

1. Install the client configuration tool
2. Install the desktop administrator software
3. Configure reason codes
4. Configure work flow group information
5. Install the supervisor desktop
6. Install the agent desktop

In this process, you download the Cisco Desktop Administrator, Cisco Supervisor Desktop, and the Cisco Agent Desktop clients from the server to a user’s PC. You can download these applications to any PC that has network access to the server through the Cisco Unified CCX Administration page.

Procedure 1: Install the client configuration tool

Because this is the first time you're downloading the desktop applications, you must run the Cisco Unified CCX Client Configuration Tool. You only have to do this once per installation or upgrade.

Depending on the operating system and browser on your PC, you will have to answer and acknowledge several security-related prompts to download and run the tool.

Step 1: From the Cisco Unified CCX Administration page, Navigate to Tools > Plug-ins, and then click Cisco Unified CCX Desktop Suites.

Step 2: To download the tool, click Cisco Unified CCX Client Configuration tool.

Step 3: In the location where the software was downloaded, click CAD Client Configuration.msi.

Step 4: On the CAD Client Configuration page, which may be hidden behind other windows on your PC, enter the IP address of the Cisco Unified CCX server: 10.4.48.126, and then click Next.

The Client Configuration wizard configures the desktop applications into a format that can be downloaded by users of the system. After the wizard is finished, it returns to the download page of Unified CCX Administration. Depending on the speed of your connection to the server, this process can take more than 30 minutes to complete.
**Procedure 2**  
*Install the desktop administrator software*

After configuring the client software on the Unified CCX server, install the desktop administrator software.

**Step 1:** From the Cisco Unified CCX Administration page, navigate to Tools > Plug-ins, and then click Cisco Unified CCX Desktop Suites.

**Step 2:** To download the software, click Cisco Unified CCX Desktop Administrator, and then follow the prompts to download the software.

**Step 3:** In the location where the software was downloaded, click CiscoDesktopAdministrator.msi, and then follow the installation prompts to install the software.

---

**Procedure 3**  
*Configure reason codes*

After installing the desktop administrator, the next procedure configures the reason codes required for the agents. Reason codes are used to identify the different tasks an agent may be doing before and after taking a call.

**Step 1:** From the PC menu bar, navigate to Start > All Programs > Cisco > Desktop, and then click Admin.

**Tech Tip**

The default path to the application on your hard drive is as follows: C:\Program Files (x86)\Cisco\Desktop\bin\SplkView.exe

**Step 2:** Navigate to Call Center 1 > Work Flow Configuration > Reason Codes and click Edit Master List.

**Step 3:** On the Master Reason Code Editor page, enter the following information, and then click Add:

- Code—1 (Each reason must have a unique number.)
- Description—*End of Shift*

**Step 4:** Repeat Step 3 for each additional reason code needed for your help desk installation, and then click Done.
Step 5: On the Logout tab, select the appropriate reasons for logging out, and then click the right arrow to make them available to agent.

Step 6: On the Not Ready tab, select the appropriate reasons that an agent might not be ready, and then click the right arrow to make them available to the agent.

Step 7: After theLogout and Not Ready tabs are updated, click Apply.

Procedure 4 Configure work flow group information

After you have created the reason codes, you need to enable them in the work flow. Caution and warning levels are thresholds set up by the administrator to let call center agents know when the call is going on longer than what is ideal for the given call center. The home page is used in the integrated browser of the agent desktop software.

Step 1: Navigate to Call Center 1 > Work Flow Configuration > Work Flow Groups > default > Reason Codes.
**Step 2:** On the Logout tab, select **Enable Logout Reason Codes**.

**Step 3:** On the Not Ready tab, select **Enable Not Ready Reason Codes**, and then click **Apply**.

**Tech Tip**

Enter the Warning threshold before the Caution threshold for each row of the table because the Warning time must be greater than the Caution time.

**Step 4:** Navigate to **Call Center 1 > Work Flow Configuration > Work Flow Groups > default > Enterprise Data**.
Step 5: On the Call Activity tab, specify the thresholds for the CSQ (time the caller was in queue) and agent (time the caller has been speaking to the agent), and then click Apply.

Step 6: Navigate to Call Center 1 > Work Flow Configuration > Work Flow Groups > default > CAD Agent > User Interface, and then click the Browser Setup tab.

Step 7: Enter the home page, for example: http://www.cisco.com/, click Update, and then click Apply.

Step 8: Exit the Cisco Desktop Work Flow Administrator by clicking the X at the top right of the page.

Step 9: On the Administrator page, click Yes to save your changes.
Procedure 5  
**Install the supervisor desktop**

After configuring the work flow information from the administrator’s desktop, install the supervisor desktop software on each PC where it is required.

**Tech Tip**

Install either the supervisor or agent desktop on a particular PC, but not both. The Supervisor Desktop installation includes both the agent and supervisor applications. The Agent Desktop installation includes only the agent application.

**Step 1:** From the Cisco Unified CCX Administration page, navigate to Tools > Plug-ins, and then click Cisco Unified CCX Desktop Suites.

**Step 2:** To download the software, click Cisco Unified CCX Supervisor Desktop, and then follow the download prompts.

**Step 3:** In the location where the software was downloaded, click CiscoSupervisorDesktop.msi, and then follow the prompts to install the software.

**Step 4:** From the PC menu bar, navigate to Start > All Programs > Cisco > Desktop, and then click Supervisor.

**Tech Tip**

The default path to the application on your hard drive is as follows: C:\Program Files (x86)\Cisco\Desktop\bin\Supervisor.exe

**Step 5:** On the login page, enter the following information, and then click OK.

- Login ID—**ggudgin** (supervisor)
- Password—[password]

**Step 6:** From the Select Team menu at the top of the page, choose the name of the team, which is **HR** for this supervisor.

**Step 7:** Repeat this procedure on each PC that requires the supervisor desktop software.
Procedure 6  Install the agent desktop

After installing the supervisor desktop, install the agent desktop on each PC where it is required.

Step 1: From the Cisco Unified CCX Administration page, Navigate to Tools > Plug-ins, and then click Cisco Unified CCX Desktop Suites.

Step 2: To download the software, click Cisco Unified CCX Agent Desktop, and then follow the download prompts.

Step 3: In the location where the software was downloaded click CiscoAgentDesktop.msi, and then follow the prompts to install the software onto your PC.

If your agents are using extension mobility, they must be logged into their phone before starting the Agent Desktop software on their PC.

Step 4: From the PC menu bar, navigate to Start > All Programs > Cisco > Desktop, and then click Agent.

Tech Tip

The default path to the application on your hard drive is as follows: C:\Program Files (x86)\Cisco\Desktop\bin\Agent.exe

Step 5: On the login page, enter the following information, and then click OK.

- ID—kfleshne (agent)
- Password—[password]
- Extension—8000027 (IPCC Extension from Unified CM)

Step 6: At the top of the page, click the Ready icon. This allows the agent to begin taking calls.

Step 7: Repeat Step 1 through Step 6 for each PC that requires the agent desktop software.

After the agents are logged in, the supervisor desktop shows the status of each of their assigned agents.

Users call the help desk pilot at 8009940 and are placed into the appropriate HR or IT queue based on their selection.

The help desk baseline configuration is now complete.
## Data Center or Server Room

<table>
<thead>
<tr>
<th>Functional Area</th>
<th>Product Description</th>
<th>Part Numbers</th>
<th>Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Center</td>
<td>Cisco MCS 7845-I3 for unified communications applications</td>
<td>MCS-7845-I3-IPC2</td>
<td>9.0(2)</td>
</tr>
<tr>
<td></td>
<td>Cisco MCS 7835-I3 for unified communications applications</td>
<td>MCS-7835-I3-IPC2</td>
<td></td>
</tr>
<tr>
<td>Call Control</td>
<td>Cisco MCS 7845-I3 for Unified Communications Manager with 2500 to 10,000 users</td>
<td>MCS7845I3-K9-CME1</td>
<td>9.1(1)</td>
</tr>
<tr>
<td></td>
<td>Cisco MCS 7835-I3 for Unified Communications Manager with 1000 to 2500 users</td>
<td>MCS7835I3-K9-CME1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cisco MCS 7825-I5 for Unified Communications Manager with up to 1000 users</td>
<td>MCS7825I5-K9-CME1</td>
<td></td>
</tr>
<tr>
<td>Virtual Servers</td>
<td>Cisco UCS C240 M3 C-Series Solution Pak for unified communications applications</td>
<td>UCUCS-EZ-C240M3S</td>
<td>9.0(2) or 9.1(1)</td>
</tr>
<tr>
<td></td>
<td>Cisco UCS C220 M3 C-Series Solution Pak for unified communications applications</td>
<td>UCUCS-EZ-C220M3S</td>
<td>ESXi 5.0</td>
</tr>
<tr>
<td></td>
<td>Cisco UCS C220 M3 for Business Edition 6000</td>
<td>UCSC-C220-M3SBE</td>
<td>9.0(2) or 9.1(1a)</td>
</tr>
<tr>
<td></td>
<td>Cisco UCS C220 M3 for Business Edition 6000</td>
<td>ESXi 5.0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cisco UCS C220 M3 for Business Edition 6000</td>
<td>ESXi 5.0</td>
<td></td>
</tr>
</tbody>
</table>

## Data Center Core

<table>
<thead>
<tr>
<th>Functional Area</th>
<th>Product Description</th>
<th>Part Numbers</th>
<th>Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>Core Switch</td>
<td>Cisco Nexus 5596 up to 96-port 10Gbe, FCoE, and Fibre Channel SFP+</td>
<td>N5K-C5596UP-FA</td>
<td>NX-OS 5.2(1)</td>
</tr>
<tr>
<td></td>
<td>Cisco Nexus 5596 Layer 3 Switching Module</td>
<td>N55-M160L30V2</td>
<td>Layer 3 License</td>
</tr>
<tr>
<td></td>
<td>Cisco Nexus 5548 up to 48-port 10Gbe, FCoE, and Fibre Channel SFP+</td>
<td>N5K-C5548UP-FA</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cisco Nexus 5548 Layer 3 Switching Module</td>
<td>N55-D160L3</td>
<td></td>
</tr>
<tr>
<td>Ethernet Extension</td>
<td>Cisco Nexus 2000 Series 48 Ethernet 100/1000BASE-T (enhanced) Fabric Extender</td>
<td>N2K-C2248TP-E</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>Cisco Nexus 2000 Series 48 Ethernet 100/1000BASE-T Fabric Extender</td>
<td>N2K-C2248TP-1GE</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cisco Nexus 2000 Series 32 1/10 GbE SFP+, FCoE capable Fabric Extender</td>
<td>N2K-C2232PP-10GE</td>
<td></td>
</tr>
</tbody>
</table>
## Server Room

<table>
<thead>
<tr>
<th>Functional Area</th>
<th>Product Description</th>
<th>Part Numbers</th>
<th>Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stackable Ethernet Switch</td>
<td>Cisco Catalyst 3750-X Series Stackable 48 Ethernet 10/100/1000 ports</td>
<td>WS-C3750X-48T-S</td>
<td>15.0(2)SE IP Base license</td>
</tr>
<tr>
<td></td>
<td>Cisco Catalyst 3750-X Series Stackable 24 Ethernet 10/100/1000 ports</td>
<td>WS-C3750X-24T-S</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cisco Catalyst 3750-X Series Four GbE SFP ports network module</td>
<td>C3KX-NM-1G</td>
<td></td>
</tr>
<tr>
<td>Standalone Ethernet Switch</td>
<td>Cisco Catalyst 3560-X Series Standalone 48 Ethernet 10/100/1000 ports</td>
<td>WS-C3560X-48T-S</td>
<td>15.0(2)SE IP Base license</td>
</tr>
<tr>
<td></td>
<td>Cisco Catalyst 3560-X Series Standalone 24 Ethernet 10/100/1000 ports</td>
<td>WS-C3560X-24T-S</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cisco Catalyst 3750-X Series Four GbE SFP ports network module</td>
<td>C3KX-NM-1G</td>
<td></td>
</tr>
</tbody>
</table>
Appendix B: Changes

This appendix summarizes the changes to this guide since the previous Cisco SBA series.

- We added the procedures and steps for connecting the platform to the LAN.
- We added the procedures and steps for downloading, installing, and opening the supervisor and agent desktop software.
- We updated the prompts and script to match the configuration in the guide.
- We added instructions for enabling the reason codes and the default home page in the workflow configuration.
- We added the steps for configuring the agent phones using extension mobility.
- We added the scaling options for virtual and standalone servers.
- We changed the dial plan information, to align it with new telephony integration guides. This change ensures the voice guides use a common set of extension numbers and dialing rules.
- We updated the software on the voice infrastructure equipment and the endpoints to the latest shipping versions.
ALL DESIGNS, SPECIFICATIONS, STATEMENTS, INFORMATION, AND RECOMMENDATIONS (COLLECTIVELY, "DESIGNS") IN THIS MANUAL ARE PRESENTED "AS IS," WITH ALL FAULTS. CISCO AND ITS SUPPLIERS DISCLAIM ALL WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE. IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THE DESIGNS, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THE DESIGNS ARE SUBJECT TO CHANGE WITHOUT NOTICE. USERS ARE SOLELY RESPONSIBLE FOR THEIR APPLICATION OF THE DESIGNS. THE DESIGNS DO NOT CONSTITUTE THE TECHNICAL OR OTHER PROFESSIONAL ADVICE OF CISCO, ITS SUPPLIERS OR PARTNERS. USERS SHOULD CONSULT THEIR OWN TECHNICAL ADVISORS BEFORE IMPLEMENTING THE DESIGNS. RESULTS MAY VARY DEPENDING ON FACTORS NOT TESTED BY CISCO.

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental.

© 2013 Cisco Systems, Inc. All rights reserved.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company.