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Preface
The Network Connectivity Monitor Operator’s Guide describes how to use the 
Global Console to access event information and diagnostic results that the Service 
Assurance Global Manager abstracted and consolidated from underlying domains. 

This guide is intended as a comprehensive resource for operator tasks. For 
information about configuration tasks, see:

• The Network Connectivity Monitor Service Assurance Manager 
Configuration Guide for information about the Global Manager 
Administration Console.

• The Nework Connectivity Monitor IP Discovery Guide for information about 
discovery. 

• The user’s guides for specific NCM applications for information about 
polling and thresholds accessed by the Domain Manager Administration 
Console.

• InCharge Service Assurance Manager Business Dashboard Configuration 
Guide for information about configuring Dashboard Viewlets™ (“viewlets”).

Administrative tasks are described in the Network Connectivity Monitor System 
Administration Guide.

Detailed descriptions of diagnostic results for specific NCM applications are 
described in their respective user’s guides.

Intended Audience
This guide is intended for operators who are responsible for acting upon the 
failures reported by the CNCC NCM Service Assurance Manager (Service 
Assurance) product. Network administrators, who are assigned monitoring duties, 
will find this document helpful. 
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Preface
Prerequisites
This guide assumes that:

• You understand the concepts discussed in An Introduction to Network 
Connectivity Monitor Service Assurance Manager.

• Your NCM products and the Global Console are properly installed, 
configured, and operational. To verify that the Global Manager for Service 
Assurance is running properly, use the brcontrol command or select the 
Browse button when you start the console (see Checking CNCC Manager 
Status on page 133). Installation instructions are provided in the Network 
Connectivity Monitor Service Assurance Management Suite Installation 
Guide. 

• You know which user name and password, CNCC Manager(s), and broker 
location to use. Check with your administrator for assistance. 

Document Organization
This guide consists of the following:

CHAPTER/APPENDIX DESCRIPTION

1. INTRODUCTION Provides general discussions about notification concepts, consoles, 
and views

2. STARTING A SESSION Explains how to start a session, open a console, end a session, and 
how to attach to CNCC Managers

3. EXAMINING NOTIFICATIONS Explains how to interpret notifications and filter your console display

4. EXAMINING TOPOLOGY Explains how to obtain topological information, including search 
tools

5. EXAMINING MAPS Explains how to interpret maps and customize maps

6. EXAMINING SUMMARIES Explains how to interpret summaries and modify summaries

7. EXAMINING STATUS TABLES Explains how to use and configure status tables
xii Network Connectivity Monitor Operator’s Guide



D o c u m e n t a t i o n  C o nv e n t i o n s
Table 1: Document Organization

Documentation Conventions
Several conventions may be used in this document as shown in Table 2.

Table 2: Documentation Conventions

Directory path names are shown with forward slashes (/). Users of the Windows 
operating systems should substitute back slashes (\) for forward slashes.

Also, if there are figures illustrating consoles in this document, they represent the 
consoles as they appear in Windows. Under UNIX, the consoles appear with slight 
differences. For example, in views that display items in a tree hierarchy such as the 
Topology Browser, a plus sign displays for Windows and an open circle displays 
for UNIX.

Finally, unless otherwise specified, the term CNCC Manager is used to refer to 
NCM programs such as Domain Managers, Global Managers, and adapters.

8. RESPONDING TO 
NOTIFICATIONS

Explains actions that can be taken in response to notifications and 
map states

9. CUSTOMIZING YOUR 
CONSOLE

Explains how to change your console layout, including adding and 
deleting views

10. TROUBLESHOOTING Provides answers to issues that may arise while running the Global 
Console

A. WILDCARD PATTERNS Lists available wildcards for filter and search criteria

CONVENTION EXPLANATION

sample code Indicates code fragments and examples in Courier font

keyword Indicates commands, keywords, literals, and operators in bold

% Indicates C shell prompt

# Indicates C shell superuser prompt

<parameter> Indicates a user-supplied value or a list of non-terminal items in angle 
brackets

[option] Indicates optional terms in brackets

/InCharge Indicates directory path names in italics

yourDomain Indicates a user-specific or user-supplied value in bold, italics

File > Open Indicates a menu path in italics
Network Connectivity Monitor Operator’s Guide xiii



Preface
The instructions in this document assume that you use the left mouse button for 
clicking selections unless otherwise noted.

NCM Installation Directory
In this document, the term BASEDIR represents the location where NCM software 
is installed.

• For UNIX, this location is: /opt/InCharge<n>/<productsuite>.

• For Windows, this location is: C:\InCharge<n>\<productsuite>.

The <n> represents the software platform version number. The <productsuite> 
represents the product suite that the product is part of.

Table 3 defines the <productsuite> directory for each product.

PRODUCT SUITE INCLUDES THESE PRODUCTS DIRECTORY

CNCC NCM IP 
Management Suite

• IP Availability Manager
• IP Performance Manager
• IP Discovery Manager
• CNCC NCM Adapter for HP OpenView NNM
• CNCC NCM Adapter for IBM/Tivoli NetView
• CNCC NCM Adapter for CiscoWorks LMS and 

ITEM

/IP

CNCC NCM Service 
Assurance 
Management Suite

• Service Assurance Manager
• Global Console
• Business Dashboard
• Business Impact Manager
• Report Manager
• SAM Failover System
• Notification Adapters
• Adapter Platform
• SQL Data Interface Adapter
• SNMP Trap Adapter
• Syslog Adapter
• XML Adapter
• Adapter for Remedy
• Adapter for TIBCO Rendezvous
• Adapter for Concord eHealth
• Adapter for InfoVista
• Adapter for NetIQ AppManager

/SAM
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A d d i t i o n a l  R e s o u r c e s
Table 3:  Product Suite Directory for NCM Products

For example, on UNIX operating systems, CNCC NCM IP Availability Manager 
is, by default, installed to /opt/InCharge6/IP/smarts. This location is referred to as 
BASEDIR/smarts.

Optionally, you can specify the root of BASEDIR to be something other than 
/opt/InCharge6 (on UNIX) or C:\InCharge6 (on Windows), but you cannot change 
the <productsuite> location under the root directory.

For more information about the directory structure of NCM software, refer to the 
Network Connectivity Monitor System Administration Guide.

Additional Resources
In addition to this manual, Cisco provides the following resources.

Commands
Descriptions of commands are available as HTML pages. The index.html file, 
which provides an index to the various commands, is located in the 
BASEDIR/smarts/doc/html/usage directory.

Documentation
Readers of this manual may find other documentation (also available in the 
BASEDIR/smarts/doc/pdf directory) helpful. 

InCharge Application 
Management Suite

• Application Services Manager
• Beacon for WebSphere
• Application Connectivity Monitor

/APP

InCharge Security 
Infrastructure 
Management Suite

• Security Infrastructure Manager
• Firewall Performance Manager
• InCharge Adapter for Check Point/Nokia
• InCharge Adapter for Cisco Security

/SIM

InCharge Software 
Development Kit

• Software Development Kit /SDK

PRODUCT SUITE INCLUDES THESE PRODUCTS DIRECTORY
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Preface
N e t w o r k  C o n n e c t i v i t y  M o n i t o r  D o c u m e n t a t i o n

The following documents are product independent and thus relevant to users of all 
Network Connectivity Monitor products:

• Release Notes for Network Connectivity Monitor 1.1

• Network Connectivity Monitor Documentation Roadmap

• Network Connectivity Monitor System Administration Guide

• ICIM Reference

• InCharge ASL Reference Guide

• Cisco Network Connectivity Center Perl Reference Guide

N e t w o r k  C o n n e c t i v i t y  M o n i t o r  S e r v i c e  A s s u r a n c e  

M a n a g e m e n t  D o c u m e n t a t i o n

The following documents are relevant to users of the NCM Service Assurance 
Management product suite.

• Network Connectivity Monitor Service Assurance Management Suite 
Installation Guide

• An Introduction to Network Connectivity Monitor Service Assurance 
Manager

• Network Connectivity Monitor Operator’s Guide

• Network Connectivity Monitor Service Assurance Manager Configuration 
Guide

• InCharge Service Assurance Manager Business Dashboard Configuration 
Guide

• InCharge Service Assurance Manager User’s Guide for Business Impact 
Manager

• InCharge Service Assurance Manager User’s Guide for Report Manager

• InCharge Service Assurance Manager Failover System User’s Guide

The following documents are relevant to NCM Service Assurance Manager 
adapters.

• Network Connectivity Monitor Service Assurance Manager Notification 
Adapters User’s Guide

• InCharge Service Assurance Manager SQL Data Interface Adapter User’s 
Guide
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• Network Connectivity Monitor Service Assurance Manager Adapter Platform 
User’s Guide

• InCharge  XML Adapter User’s Guide

• InCharge Service Assurance Manager User’s Guide for Remedy Adapter

• InCharge Service Assurance Manager User’s Guide for Concord eHealth 
Adapter

• InCharge Connectivity Monitor Service Assurance Manager User’s Guide for 
InfoVista Adapter

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco 
also provides several ways to obtain technical assistance and other technical 
resources. These sections explain how to obtain technical information from Cisco 
Systems.

Cisco.com
You can access the most current Cisco documentation at this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

You can access international Cisco websites at this URL:

http://www.cisco.com/public/countries_languages.shtml
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Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product 
documentation from the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/index.shtml

• Nonregistered Cisco.com users can order documentation through a local 
account representative by calling Cisco Systems Corporate Headquarters 
(California, USA) at 408 526-7208 or, elsewhere in North America, by 
calling 800 553-NETS (6387).

Documentation Feedback
You can send comments about technical documentation to bug-doc@cisco.com.

You can submit comments by using the response card (if present) behind the front 
cover of your document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco service 
contracts, Cisco Technical Support provides 24-hour-a-day, award-winning 
technical assistance. The Cisco Technical Support Website on Cisco.com features 
extensive online support resources. In addition, Cisco Technical Assistance Center 
(TAC) engineers provide telephone support. If you do not hold a valid Cisco 
service contract, contact your reseller.
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Cisco Technical  Support  Website
The Cisco Technical Support Website provides online documents and tools for 
troubleshooting and resolving technical issues with Cisco products and 
technologies. The website is available 24 hours a day, 365 days a year at this URL:

http://www.cisco.com/techsupport

Access to all tools on the Cisco Technical Support Website requires a Cisco.com 
user ID and password. If you have a valid service contract but do not have a user 
ID or password, you can register at this URL:

http://tools.cisco.com/RPF/register/register.do

Submitt ing a Service Request
Using the online TAC Service Request Tool is the fastest way to open S3 and S4 
service requests. (S3 and S4 service requests are those in which your network is 
minimally impaired or for which you require product information.) After you 
describe your situation, the TAC Service Request Tool automatically provides 
recommended solutions. If your issue is not resolved using the recommended 
resources, your service request will be assigned to a Cisco TAC engineer. The TAC 
Service Request Tool is located at this URL:

http://www.cisco.com/techsupport/servicerequest

For S1 or S2 service requests or if you do not have Internet access, contact the 
Cisco TAC by telephone. (S1 or S2 service requests are those in which your 
production network is down or severely degraded.) Cisco TAC engineers are 
assigned immediately to S1 and S2 service requests to help keep your business 
operations running smoothly.

To open a service request by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227)
EMEA: +32 2 704 55 55
USA: 1 800 553 2447

For a complete list of Cisco TAC contacts, go to this URL:

http://www.cisco.com/techsupport/contacts

Definit ions of  Service Request  Severity
To ensure that all service requests are reported in a standard format, Cisco has 
established severity definitions.
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Severity 1 (S1)—Your network is “down,” or there is a critical impact to your 
business operations. You and Cisco will commit all necessary resources around the 
clock to resolve the situation. 

Severity 2 (S2)—Operation of an existing network is severely degraded, or 
significant aspects of your business operation are negatively affected by inadequate 
performance of Cisco products. You and Cisco will commit full-time resources 
during normal business hours to resolve the situation.

Severity 3 (S3)—Operational performance of your network is impaired, but most 
business operations remain functional. You and Cisco will commit resources 
during normal business hours to restore service to satisfactory levels.

Severity 4 (S4)—You require information or assistance with Cisco product 
capabilities, installation, or configuration. There is little or no effect on your 
business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is available 
from various online and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and 
logo merchandise. Visit Cisco Marketplace, the company store, at this URL:

http://www.cisco.com/go/marketplace/

• The Cisco Product Catalog describes the networking products offered by 
Cisco Systems, as well as ordering and customer support services. Access the 
Cisco Product Catalog at this URL:

http://cisco.com/univercd/cc/td/doc/pcat/
xx Network Connectivity Monitor Operator’s Guide

http://www.cisco.com/go/marketplace/
http://cisco.com/univercd/cc/td/doc/pcat/


O b t a i n i n g  A d d i t i o n a l  P u b l i c a t i o n s  a n d  I n f o r m a t i o n
• Cisco Press publishes a wide range of general networking, training and 
certification titles. Both new and experienced users will benefit from these 
publications. For current Cisco Press titles and other information, go to Cisco 
Press at this URL:

http://www.ciscopress.com

• Packet magazine is the Cisco Systems technical user magazine for 
maximizing Internet and networking investments. Each quarter, Packet 
delivers coverage of the latest industry trends, technology breakthroughs, and 
Cisco products and solutions, as well as network deployment and 
troubleshooting tips, configuration examples, customer case studies, 
certification and training information, and links to scores of in-depth online 
resources. You can access Packet magazine at this URL:

http://www.cisco.com/packet

• iQ Magazine is the quarterly publication from Cisco Systems designed to 
help growing companies learn how they can use technology to increase 
revenue, streamline their business, and expand services. The publication 
identifies the challenges facing these companies and the technologies to help 
solve them, using real-world case studies and business strategies to help 
readers make sound technology investment decisions. You can access iQ 
Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems 
for engineering professionals involved in designing, developing, and 
operating public and private internets and intranets. You can access the 
Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• World-class networking training is available from Cisco. You can view 
current offerings at this URL:

http://www.cisco.com/en/US/learning/index.html
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Introduction
In a typical Operations center, there are several operators who may perform 
monitoring duties and assist with or perform problem resolution. In order to 
perform their duties, operators need information about their managed domains and 
the events that occur. For example, they may need information about topological 
relationships, sources of notifications, and how the events affect other 
infrastructure devices.

Note: Console access is controlled by the user profile that is associated with a user 
account. Therefore, users might have access to different types of consoles and 
console operations. For example, a user might be able to browse for details, but not 
be able to acknowledge a notification or add a view to a console. Also, certain 
features are controlled by your NCM license. For information about console 
operations, see the Network Connectivity Monitor Service Assurance Manager 
Configuration Guide.

Using the Global Console, an operator with access to the appropriate console 
operations can:

• Investigate topological information, including detailed information about an 
element’s internal components. Topological information is presented in a 
topological tree format and map representations.

• Monitor notifications and identify the causes of each failure and systems that 
the failure affects.

• Respond to notifications. For example, operators can take ownership of 
notifications, open trouble tickets, or ping a device.

• Save information, print information, and record tracking comments in 
notification audit logs.
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In addition, users can perform administrative tasks such as configuring Global 
Managers and managing underlying Domain Managers if they have administrative 
privileges and access to those console operations. 

For a discussion of the layout and features of the Global Console, see Global 
Console Overview on page 4. For a general discussion of notifications, see 
Notification Concepts on page 2.

Notification Concepts
Service Assurance notifications are generated when abnormal conditions occur in 
your underlying managed domains. The underlying domains, such as CNCC NCM 
IP Availability Manager and InCharge IP Performance Manager, pass the 
notifications and any relevant event or topological information to the Service 
Assurance Global Manager. The Global Manager, in turn, consolidates, abstracts, 
and passes the notifications to clients such as the Global Console or adapters.

Notifications are objects in the Global Manager used to represent the notifications 
received from the underlying domains. Each notification consists of a set of 
attributes which describe properties of the notification, such as the severity of the 
notification and a textual description of the event. (For a list of visible attributes, 
see Notification Log Columns on page 41.)

A notification list configured by your administrator determines which notifications 
display in your console and are reflected in a map. Your administrator can use 
special filters to organize notifications by some useful criteria and then associate 
the filtered list with your user profile. As a result, your console may display all or a 
subset of possible notifications. As an operator, you can further refine your display 
by setting additional filters provided as console options.

The severity of notifications is reflected in severity icons, color-coded rows and 
indicator bars underneath map icons. Notifications, severity icons, their color 
coding, and how to display their properties are described in About Notifications on 
page 38 and Displaying Notification Properties on page 43. Map icons and their 
color coding are described in Representing Notifications in Maps on page 72.

Note: If a notification list does not include an event, notifications for the event will not 
appear in your console or be reflected in the map icons. For example, if a 
notification list excludes all events from a specific router, the router always appears 
with a normal state in the map. (If your console does not accurately reflect 
observed conditions, contact your administrator.)
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Service Assurance information is archived at time intervals specified by the 
administrator and can be viewed later using a text editor. The archives include 
notifications that are acknowledged and their related audit logs. Once notifications 
are archived, they no longer display in the Global Console. For information about 
archival parameters and the archived files, see the Network Connectivity Monitor 
Service Assurance Manager Configuration Guide.

Service Assurance Notif icat ions
Most of the notifications that display in the Global Console are generated by 
underlying CNCC Managers. However, the Global Manager will generate a 
Session Disconnected notification when an underlying CNCC Manager 
disconnects from it. Also, if Business Impact Manager is deployed, the Global 
Manager will generate business impact notifications. For information about 
disconnect situations, see Troubleshooting on page 133. For information about 
business impact notifications, see the InCharge Service Assurance Manager User’s 
Guide for Business Impact Manager.

Detailed descriptions of diagnostic results for specific NCM applications like 
CNCC NCM IP Availability Manager, InCharge IP Performance Manager, 
InCharge Discovery Manager, and InCharge Application Services Manager are 
described in their respective user’s guides.

Types of  Managers
Depending upon your Service Assurance deployment, a Global Manager can be: a 
Service Assurance Global Manager, Security Infrastructure Manager (SIM), or 
SAM Adapter Platform. 

A Domain Manager can be: an IP Availability Manager, IP Performance Manager, 
Discovery Manager, Firewall Performance Manager, or Application Services 
Manager (ASM). 

The term CNCC Manager refers to either a Global Manager or Domain Manager. 
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Global Console Overview
The Global Console is a collection of consoles: 

• The Notification Log Console presents notifications in tabular format. 

• The Map Console graphically represents your topology in a map format. In 
the map, icons change color when they are affected by one or more abnormal 
conditions. 

• The Topology Browser Console represents the topology in a hierarchical 
format and provides topological information. 

• The Summary View Console represents overviews or summaries of 
notifications organized by meaningful criteria. 

• The Status Table Console represents the status of underlying infrastructure 
elements as they affect the collection objects (ServiceOffering, 
ServiceSubscriber, or any group created by your administrator) specified in 
the Status Table. 

• The Web Console provides Global Console functionality in a standard web 
browser.

• The Domain Manager Administration Console enables administrators to 
discover topology and manage underlying Domain Managers. 

For information about discovery, see the Network Connectivity Monitor IP 
Discovery Guide. Information about polling and thresholds accessed by the 
Domain Manager Administration Console for specific NCM applications is 
provided in their respective user’s guides.

• The Global Manager Administration Console enables administrators to 
configure Global Managers. 

For information about the Global Manager Administration Console, see the 
Network Connectivity Monitor Service Assurance Manager Configuration 
Guide.

• The Topology Builder Console enables administrators to modify and refine 
the topology stored in the NCM repository. 

This console is available if Business Impact Manager or InCharge 
Application Services Manager is deployed. For information about the 
Topology Builder Console, see the InCharge Service Assurance Manager 
User’s Guide for Business Impact Manager or InCharge Application Services 
Manager Discovery Guide. 
4 Network Connectivity Monitor Operator’s Guide



G l o b a l  C o n s o l e  O v e r v i e w
The following consoles display information from or manage:

• Global Managers—a Notification Log Console, Map Console, Summary 
Console, Status Table Console, views, Global Manager Administration 
Console, and Topology Builder Console for Business Impact Manager.

• Domain Managers—a Domain Manager Administration Console and 
Topology Builder Console for InCharge Application Services Manager.

A Topology Browser Console or view can display information from Global 
Managers and Domain Managers.

After you log on, one or more consoles display, depending upon your user profile. 
For example, if your user profile is configured for the Notification Log Console 
and Map Console, then two consoles will display after you log on. Since Domain 
Managers do not maintain user profiles, if you log on to a Domain Manager, the 
Topology Browser Console displays first. 

You can also customize a console for your operational needs, save it, and continue 
to use it. For example, you can add one or more views to a console. 

The layout of each console, including menu options and toolbar buttons, is briefly 
described in the following subsections. More complete information about 
individual menu options is provided in subsequent chapters. Menu options and 
toolbar buttons might be disabled or not display if you do not have access to those 
console operations.

Tool tips are available for each console. A tool tip provides information about 
console components, notifications, map icons, and summaries. To activate a tool 
tip, hold the cursor over the object. For example, if you hold the cursor over a 
Global Manager, the tool tip provides the IP address and port number. If the text in 
an attribute field of the Notification Log is truncated, the full text is displayed in 
the tool tip. 

The status bar for each console displays status (Ready, for example) and the 
following information:

• For a locally saved console, the directory path and its file name.

• For a remotely saved console, the CNCC Manager or IP address where it is 
saved, user name, and the console name. 

If you logged on using a default user profile, the console name 
NotificationLog appears unless the name has been modified by an 
administrator.

• For an unsaved console, the text "Not saved" appears.
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To quickly open menus in the consoles, press the Alt key + underlined character. 
For example, to open the File menu, use Alt + F.

View Concepts
NCM information is displayed in the following views: Notification Log, Map, 
Topology Browser, Summary View, Status Table, Notification Properties, and 
Containment. Depending on your NCM deployment, you will see these views in a 
Global Console window, Web Console window (available through a Web 
Browser), in a Business Dashboard configured by your administrator, or in a a 
third-party Web Portal product.

You or your administrator can configure views to display certain information, for 
example, by applying filters. These views can be saved, and associated with user 
accounts and user profiles. Views that are saved in HTML (as Java applets) for 
display in Web Browsers are called DashboardViewletsTM (“viewlets”). Viewlets 
are available when the Business Dashboard is installed. 

You can display more than one view in a Global Console window. For example, if 
you wish, you can include a Notification Log view along with a Map and a Status 
Table in a console. For more information about managing view display, see 
Tailoring Your Console With Views on page 123.

In a view, to perform actions such as saving or deleting, or to access menu options, 
you need to activate the view. To do so, click anywhere in the view. The active 
view has a dark gray border.

Availabi l i ty  of  Viewlets
Generally, views that are available for the Global Console are available for the Web 
Console (as views), Business Dashboard (as viewlets), and third-party Web Portal 
products (as viewlets). Table 4 indicates which views can be implemented as 
viewlets.

VIEWS AVAILABLE AS VIEWLETS?

Notification Log view Yes

Map Yes 

Summary view Yes

Status Table view Yes

Notification Properties view Yes
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Table 4: View Availability

Layout of  a  Notif icat ion Log Console
The Notification Log Console is designed specifically for viewing notifications. It 
consists of one view, the Notification Log view. Figure 1 illustrates one example of 
a Notification Log Console for an administrator. Your Notification Log console 
may look slightly different.

Menu options for the Notification Log Console are summarized in Notification 
Log Menus and Pop-up Menus on page 8. Toolbar buttons are also summarized in 
Notification Log Console Toolbar Buttons on page 11.

The notification list configured by your administrator is included in the title of the 
Notification Log view. For example, the title "Notification Log - Default" 
identifies a notification list named Default.

The Manager pull-down menu lists attached Global Managers. You can view 
notifications for a different attached Global Manager by selecting it from the pull-
down menu. Domain Managers are not listed in the pull-down menu.

The notification legend and icons in the Severity column provide the color 
indicators which reflect the notifications’ severity.

You can also customize the Notification Log view with a filter. The filter enables 
you to select attributes and specify wildcard characters to control which 
notifications appear in the view.

Containment view Yes

Topology Browser view No

VIEWS AVAILABLE AS VIEWLETS?
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Figure 1: Notification Log Console for an Administrator

N o t i f i c a t i o n  L o g  M e n u s  a n d  P o p - u p  M e n u s

Table 5 summarizes the menus which are available for the Notification Log 
Console or view. Two menus, Event and Log, are specific to the Notification Log. 
The Configure menu is displayed depending on your user access control privileges. 

MENU OPTION DESCRIPTION

File New Opens a new console

Open Opens an existing console, locally-saved or remotely-
saved

Close Closes an individual console

Save Saves an unsaved console on a local or remote host. 
Saves a saved console to a previously-specified 
destination.

Save As Saves a console on a local or remote host

Layout Arranges multiple views in a console and changes 
console title

Exit Ends the session and closes all consoles
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Edit Find Instance Searches for any topological element in any class 
including application services, service offerings, 
service subscribers, and systems

Find System Searches for a system (infrastructure element)

Recipients Opens the Recipient Editor dialog box for e-mail or 
pager tools

View Java Console Displays console debugging information, including 
store exceptions, errors reading attributes, and stack 
traces.

Message Log Displays communications sent from a CNCC 
Manager to the console

Toolbar Toggles the display of the toolbar buttons

Status Toggles the display of the status bar

Add View Inserts a view in the current console

Copy View Copies a view in the current console or to another new 
console

Save View As 
Viewlet

Saves a view as a viewlet for the Web pages or third-
party Web Portal products; Business Dashboard must 
be installed.

Delete View Removes a view from the current console

Listen to Context Configures a view for context sharing.

Refresh Redisplays the console

Manager Attach Connects to a CNCC Manager

Detach Disconnects from a CNCC Manager

MENU OPTION DESCRIPTION
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MENU OPTION DESCRIPTION

Configure Groups Creates groups or child groups of infrastructure 
elements. For information about creating groups, see 
the Network Connectivity Monitor Service Assurance 
Manager Configuration Guide.

Domain Manager 
Administration 
Console

Opens a Domain Manager Administration Console 
for managing underlying Domain Managers. 

Global Manager 
Administration 
Console

Opens a Global Manager Administration Console for 
configuring Global Managers. 

Topology Builder Opens a Topology Builder Console. For information 
about the Topology Builder Console, see the 
InCharge Service Assurance Manager User’s Guide 
for Business Impact Manager or InCharge 
Application Services Manager Discovery Guide.

Event Properties Displays notification properties for a selected 
notification

Acknowledge Acknowledges a selected notification

Unacknowledge Removes acknowledgement

Take Ownership Assigns a user name to a selected notification for 
problem resolution

Release Ownership Removes a user name

Add to Audit Log Adds comment entries to notification audit log 

Audit Log Opens the audit log

Browse Opens the Topology Browser view for the current 
Global Manager that contains the selected element in 
a secondary window

Browse Detail Opens the Topology Browser view for the underlying 
CNCC Manager that contains the selected element in 
a secondary window

Containment Displays an element’s components 

Show Map Opens the Map Console in a secondary window

Mail Opens the e-mail tool for a selected notification

Page Opens the pager message tool for a selected 
notification
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Table 5: Notification Log Menus and Their Options

Pop-up menus are also available when you right-click on selected entities. Table 6 
summarizes the options and selection criteria.

Table 6: Notification Log Pop-up Menus

N o t i f i c a t i o n  L o g  C o n s o l e  T o o l b a r  B u t t o n s

In the Notification Log Console, certain menu options are provided as toolbar 
buttons. They are summarized in Table 7.

Log Select Columns Controls which columns are displayed in the 
Notification Log view

Save Log Contents 
to File

Saves the contents of the Notification Log view 
locally as a text file

Sort Columns Sorts columns in the Notification Log view

Filter Specifies a filter for the Notification Log view

Log Properties Changes the title of the Notification Log view and 
specifies continuous or scheduled display updates of 
notifications

Freeze Display Stops the display from changing in the Notification 
Log view

Help About Lists Global Console information: version, contact, 
and outsourcing information

SELECTION 
CRITERIA

OPTION POP-UP MENU OPTIONS

Right-click on or 
near the view title

Same as Log menu options.

Right-click on a 
column heading

Hide Column Hides a column from display.

Insert Column Inserts a column to the left of the selected column.

Right-click on a 
notification

Same as Event menu options.
Plus, the Server Tools and Client Tools options for tools if they are enabled. 
For information configuring tools, see the Network Connectivity Monitor 
Service Assurance Manager Configuration Guide.

Note: A Notification Log view for a summary only supports the pop-up menu that results from 
right-clicking on a notification.

MENU OPTION DESCRIPTION
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Table 7: Notification Log Console Toolbar Buttons

Layout of  a  Map Console
The Map Console is designed specifically for viewing maps. When you open the 
Map Console (see Figure 2), it consists of two panels.

L e f t  P a n e l

In the left panel, you can select a Global Manager from the Manager pull-down 
menu to see maps for that manager. The pull-down menu lists attached Global 
Managers. Domain Managers are not listed in the pull-down menu.

In the left panel, there are also two tabs: 

• The Topology tab displays a map tree which is a hierarchical representation of 
the attached Global Managers, classes of infrastructure elements, logical 
groups such as IP networks and VLANs, business services, applications, 
sessions and transactions, and the instances available for each class. 

• The Groups tab displays user-defined groups of topological elements if the 
groups exist. (Your administrator can create groups. For information on 
groups, see the Network Connectivity Monitor Service Assurance Manager 
Configuration Guide.)

Different types of maps are available for the instances in each tab.

BUTTON DESCRIPTION

Opens a local console

Saves an unsaved console on a local or remote host. Saves a 
saved console to a previously-specified destination.

Displays the Select Context(s) To Listen To dialog box for 
configuring context sharing.

Opens a browser for reporting. For information, see InCharge 
Service Assurance Manager User’s Guide for Report 
Manager.

Displays the Notification Properties dialog box for a selected 
notification

Acknowledges an active, selected notification

Displays the Map Console for selected notifications
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R i g h t  P a n e l

The right panel displays the map. After you select an instance from the expanded 
map tree, the map displays and the selected device is surrounded by a blue box. 
Alternatively, if you used the Show Map option for a selected notification, this 
panel shows a map containing your selection. 

Menu options for the Map Console are summarized in Map Menus and Pop-up 
Menus on page 14. Toolbar buttons specific to the Map Console are summarized in 
Map Console Toolbar Buttons on page 19.

The left arrowhead on the panel divider hides the map tree and enlarges the right 
panel for a larger display area.

Indicators, at the top of the right panel, show if coloring by root-cause is enabled 
and the map’s layout type. See Adjusting the Appearance of a Map on page 78 for 
more information.

A drop-down history field lists the current map (instance and map type) and other 
recently-viewed maps. 

The map legend provides a list of map elements and color indicators. To view the 
legend, select Map > Map Legend.

You can customize individual maps with a map filter. The filter enables you to add 
and remove classes from a map.

Figure 2 displays an example of a Physical Connectivity map.
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Figure 2: Map Console

M a p  M e n u s  a n d  P o p - u p  M e n u s

Table 8 summarizes the menus which are available for the Map Console. Two 
menus, Layout and Map, are specific to the Map Console. The Configure menu is 
displayed depending on your user access control privileges.
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MENU OPTION DESCRIPTION

File New Opens a new console

Open Opens an existing console, locally-saved or remotely-
saved

Close Closes an individual console

Save Saves an unsaved console on a local or remote host. 
Saves a saved console to a previously-specified 
destination.

Save As Saves a console on a local or remote host

Layout Arranges multiple views in a console and changes 
console title

Exit Ends the session and closes all consoles

Edit Find Instance Searches for any topological element in any class 
including application services, service offerings, 
service subscribers, and systems

Find System Searches for a system (infrastructure element)

View Java Console Displays console debugging information, including 
store exceptions, errors reading attributes, and stack 
traces.

Message Log Displays communications sent from a CNCC 
Manager to the console

Toolbar Toggles the display of the toolbar buttons

Status Toggles the display of the status bar

Add View Inserts a view in the current console

Copy View Copies a view in the current console or to another new 
console

Delete View Removes a view from the current console

Listen to Context Configures a view for context sharing.

Refresh Redisplays the console

Manager Attach Connects to a CNCC Manager

Detach Disconnects from a CNCC Manager

Layout Circular Layout Displays circular layout of a map

Manual Layout Enables manual positioning of nodes in a map 

Hierarchical Layout Displays hierarchical layout of a map

Fit in Window Fits the map to the size of the right panel
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Table 8: Map Menus and Their Options

Map Save Map Saves an individual map

Edit Map Filter Specifies a filter for a map

Expand Node Expands one or more individual nodes

Increment Hops Expands an entire map by one hop

Decrement Hops Decreases an entire map by one hop

Map Legend Displays a list of map icons and colors

Print Map Prints a map

Overview Opens the Overview window for magnification

Reset Map Resets changes made to a map or returns to the saved 
map

Set Background Specifies a user-defined background image for a map 

Configure Groups Creates groups or child groups of infrastructure 
elements. For information about creating groups, see 
the Network Connectivity Monitor Service Assurance 
Manager Configuration Guide.

Domain Manager 
Administration 
Console

Opens a Domain Manager Administration Console 
for managing underlying Domain Managers. 

Global Manager 
Administration 
Console

Opens a Global Manager Administration Console for 
configuring Global Managers. 

Topology Builder Opens a Topology Builder Console. For information 
about the Topology Builder Console, see the 
InCharge Service Assurance Manager User’s Guide 
for Business Impact Manager or InCharge 
Application Services Manager Discovery Guide.

Edit Map Icons Assigns custom icons for a class or an instance.

Help About Lists Global Console information: version, contact, 
and outsourcing information

MENU OPTION DESCRIPTION
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Pop-up menus are also available when you right-click on selected entities. Table 9 
summarizes the options and selection criteria.

SELECTION 
CRITERIA

OPTION DESCRIPTION

Right-click on an 
instance in the 
Topology tab

available maps for 
display

Available maps depend upon the selected instance 
(See Types of Maps on page 74.)

Browse Opens the Topology Browser view for the current 
Global Manager that contains the selected element in 
a secondary window

Browse Detail Opens the Topology Browser view for the underlying 
CNCC Manager that contains the selected element in 
a secondary window

Containment Displays an element’s components 

Edit Map Icons Assigns custom icons for a class or an instance.

Server Tools Displays a list of server tools if enabled

Client Tools Displays a list of client tools if enabled

Right-click on an 
instance in the 
Groups tab

available maps for 
display

Available maps depend upon the selected instance 
(See Types of Maps on page 74.)

Right-click in the 
background of a 
map 

Circular Layout Displays circular layout of a map

Manual Layout Enables manual positioning of nodes in a map 

Hierarchical Layout Displays hierarchical layout of a map

Fit in Window Fits the map to the size of the right panel

Increment Hops Expands an entire map by one hop

Decrement Hops Decreases an entire map by one hop

Reset Map Resets changes made to a map or returns to the saved 
map

Edit Map Icons Assigns custom icons for a class or an instance.

Set Background Specifies a user-defined background for maps
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Table 9: Map Pop-up Menus

Right-click on a 
selected node in a 
map

available maps for 
display

Available maps depend upon the selected instance 
(See Types of Maps on page 74.)

Notification 
Properties

Displays notification properties 

Browse Opens the Topology Browser view for the current 
Global Manager that contains the selected element in 
a secondary window

Browse Detail Opens the Topology Browser view for the underlying 
CNCC Manager that contains the selected element in 
a secondary window

Containment Displays an element’s components 

Edit Map Icons Assigns custom icons for a class or an instance.

Expand Node Expands one or more individual nodes

Map Window Opens another map in a secondary window

Server Tools Displays a list of server tools if enabled

Client Tools Displays a list of client tools if enabled

Right-click on a 
selected edge in a 
map

Notification 
Properties

Displays notification properties 

Browse Opens the Topology Browser view for the current 
Global Manager that contains the selected element in 
a secondary window

Browse Detail Opens the Topology Browser view for the underlying 
CNCC Manager that contains the selected element in 
a secondary window

SELECTION 
CRITERIA

OPTION DESCRIPTION
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M a p  C o n s o l e  T o o l b a r  B u t t o n s

In the Map Console, certain menu options are provided as toolbar buttons. They 
are summarized in Table 10.

Table 10: Map Console Toolbar Buttons

BUTTON DESCRIPTION

Opens a Notification Log Console

Displays the Select Context(s) To Listen To dialog box for 
configuring context sharing.

Opens a browser for reporting. For information, see InCharge 
Service Assurance Manager User’s Guide for Report 
Manager.

Displays circular layout of a map. This is the default layout for 
all maps except for Business Services maps.

Displays hierarchical layout of a map. This is the default 
layout for Business Services maps.

Allows manual layout of a map, leaving nodes where you 
place them (important when you place nodes on a custom map 
background such as a geographic map)

Fits the map to the size of the right panel

Zoom out, shrink map

Zoom in, magnify map

Opens the Overview window

Shows previous map

Shows next map

Expands selected node (A plus sign next to a node indicates 
that the node can be expanded)

Changes the color of map objects. Only objects experiencing 
root-cause events are colored. 
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Layout of  a  Topology Browser Console
The Topology Browser Console is designed specifically for viewing the topology 
of any CNCC Manager. 

• For a Global Manager, the Topology Browser presents an abstracted topology.

• For a Domain Manager, the Topology Browser presents a complete topology.

It also displays detailed topology if a selected topology element has an underlying 
topology source. It consists of one view, the Topology Browser view. Figure 3 
illustrates an example of a Topology Browser Console. 

In the left panel, you can select a CNCC Manager from the Manager pull-down 
menu to see the topology for that manager. You can expand each object in the 
topology tree and see its contents.

If multiple CNCC Managers are attached, the console displays the Managers one 
at a time, classes, instances of each class, and their relationships. For each object 
you select, a corresponding property sheet with one or more tabs is displayed in the 
right panel:

• For a CNCC Manager, the Modules and Threads tabs provide information 
about models, programs, and process threads.

• For classes, the Description and Attributes tabs describe the class and its 
attributes.

• For elements (instances):

• Attributes tab lists the attribute names, data types, values, and 
descriptions of the attributes. 

• Groups tab displays groups if the instance belongs to any groups. 

• Global Manager only, the Events tab displays notifications if they are 
generated.

In the Topology Browser Console, the menu options and toolbar buttons are the 
same as those in the Notification Log Console, except that the following do not 
exist for the Topology Browser Console (see Table 5 and Table 7, respectively):

• Event and Log menus

• View menu options: Save as Viewlet and Listen to Context 

Pop-up menu options are summarized in Topology Browser Pop-up Menus on 
page 22.
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Figure 3 illustrates a typical Topology Browser Console. In the left panel, the tree 
displays an instance of a probe, 172.16.127.251, and the right panel displays the 
Attributes tab for the probe.

Figure 3: Topology Browser Console
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T o p o l o g y  B r o w s e r  P o p - u p  M e n u s

Pop-up menus are also available when you right-click on selected entities. Table 11 
summarizes the options and selection criteria.

Table 11: Topology Browser Pop-up Menus

SELECTION 
CRITERIA

OPTION DESCRIPTION

Right-click in panel 
of the topology tree

Select Specifies a filter for a topology tree

Refresh Tree Refreshes the tree contents

Right-click on an 
instance in the 
topology tree

Make Root Begins the tree with the selected instance as the root

Browse Opens the Topology Browser view for the current 
CNCC Manager that contains the selected element in 
a secondary window

Browse Detail Opens the Topology Browser view for the underlying 
CNCC Manager that contains the selected element in 
a secondary window

Containment Displays an element’s components 

Show Map Opens the Map Console in a secondary window

Server Tools Displays a list of server tools if enabled

Client Tools Displays a list of client tools if enabled

Right-click on the 
notification in the 
Events tab

Properties Displays notification properties 

Browse Opens the Topology Browser view for the current 
CNCC Manager that contains the selected element in 
a secondary window

Show Map Opens the Map Console in a secondary window

Server Tools Displays a list of server tools if enabled

Client Tools Displays a list of client tools if enabled

Right-click in the 
Group tab

Browse Opens the Topology Browser view for the current 
CNCC Manager that contains the selected element in 
a secondary window

Show Map Opens the Map Console in a secondary window
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Layout of  a  Summary View Console
The Summary View Console is designed to present overviews or summaries of 
notifications. The console consists of one view, the Summary view. Each summary 
represents information in a horizontal bar chart or pie chart, organized by 
meaningful criteria. For example, a summary can organize notifications by 
severity. A Summary View Console can present summaries for one or more Global 
Managers. Figure 4 illustrates an example of a Summary View Console. 

You can customize a summary. For example, you can edit its parameters to change 
its contents or apply a filter. You can also display a Notification Log view or map 
for a selected summary in a secondary window. For more information, see 
Examining Summaries on page 85.

In the Summary View Console, the menu options are the same as those in the 
Notification Log Console (see Table 5), except that the Event and Log menus do 
not exist for the Summary View Console. One menu, Summary, is specific to the 
Summary View Console (see Table 12). Pop-up menu options are summarized in 
Table 13. Toolbar buttons are also summarized in Table 14.

Figure 4: Summary View Console

S u m m a r y  V i e w  M e n u  a n d  P o p - u p  M e n u s

One menu, Summary, is specific to the Summary View Console (see Table 12). 
Pop-up menu options are summarized in Table 13.
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Table 12 summarizes the Summary menu. 

Table 12: Summary View Menus and Their Options

Pop-up menus are also available when you right-click on selected entities. Table 13 
summarizes the options and selection criteria.

Table 13: Summary View Pop-up Menus

MENU OPTION DESCRIPTION

Summary Edit Summary 
Parameters

Changes a summary’s contents, its title, its chart type 
(horizontal bar or pie chart), and specifies continuous 
or scheduled display updates of notifications, alarmed 
elements and impacts

Filter Specifies a filter for a selected summary

Show Notifications Displays a Notification Log view for a selected 
summary in a secondary window

Move Summary 
Left

Moves a summary one cell to the left

Move Summary 
Right

Moves a summary one cell to the right

Add Summary Adds a summary to the Summary view

Layout Specifies the maximum number of summaries per row 
in a Summary view

Delete Summary Deletes a selected summary from the Summary view

SELECTION 
CRITERIA

OPTION DESCRIPTION

Right-click on or 
near the summary 
title

Edit Summary 
Parameters

Changes a summary’s contents, its title, its chart type 
(horizontal bar or pie chart), and specifies continuous 
or scheduled display updates of notifications, alarmed 
elements and impacts

Filter Specifies a filter for a selected summary

Show Notifications Displays a Notification Log view for a selected 
summary in a secondary window

Show Map Displays a map for a selected summary in a secondary 
window

Delete Summary Deletes a selected summary from the Summary view

Right-click in a 
view

Add Summary Adds a summary to the Summary view

Layout Specifies the maximum number of summaries per row 
in a Summary view
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Note: Pop-up menus for a Notification Log view for a summary are described in Table 6. 
A Notification Log view for a summary only supports the pop-up menu that results 
from right-clicking on a notification.

S u m m a r y  V i e w  C o n s o l e  T o o l b a r  B u t t o n s

In the Summary View Console, certain menu options are provided as toolbar 
buttons. They are summarized in Table 14.

Table 14: Summary View Console Toolbar Buttons

BUTTON DESCRIPTION

Opens a local console

Saves an unsaved console on a local or remote host. Saves a 
saved console to a previously-specified destination.

Displays the Select Context(s) To Listen To dialog box for 
configuring context sharing.

Opens a browser for reporting. For information, see InCharge 
Service Assurance Manager User’s Guide for Report 
Manager.

Displays the Notification Properties dialog box for a selected 
notification

Acknowledges an active, selected notification

Displays the Map Console

Edits the parameters of a selected summary. Changes a 
summary’s contents, its title, its chart type, and specifies 
continuous or scheduled display updates of notifications.

Specifies a filter for a selected summary.

Displays a Notification Log view for a selected summary in a 
secondary window.

Moves a selected summary one cell to the left

Moves a selected summary one cell to the right
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Layout of  a  Status Table Console
A Status Table Console provides a high-level overview of the status of the 
underlying elements that affect the operation of business entities such as business 
processes, customers, and lines of business. Note that the Status Table Console is 
available when the Business Dashboard is installed.

The Status Table Console displays a grid comprised of the following:

• Primary Class (Y axis)—Selection from a group of collection objects 
(ServiceOffering, ServiceSubscriber, or any group created by your 
administrator) 

• Secondary Class (X axis)—Selection from the group of corresponding 
instances of the Primary Class. Note that these options change as the Primary 
Class changes.

For example, for the class, Customer, a Status Table view can show the instances 
and notification status of the various service offerings available to the Customer 
class.

Your administrator can configure the groups (business entities) and Status Table 
views. To configure Status Table views, see Configuring a Status Table View on 
page 97.

In the Status Table Console, the menu options are similar to those in the 
Notification Log Console (see Table 5), except that the Event and Log menus do 
not exist for the Status Table Console. One menu, Status Table, is specific to the 
Status Table Console. For information, see Status Table Menu and Pop-up Menus 
on page 27.
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Figure 5 illustrates instances of the Service Offerings (X-axis) provided by the 
Service Subscribers listed on the Y-axis.

Figure 5: Status Table Console

S t a t u s  T a b l e  M e n u  a n d  P o p - u p  M e n u s

One menu, Status Table, is specific to the Status Table Console. This menu 
includes one option, Configure Status Table. The Configure Status Table menu is 
displayed depending on your user access control privileges.

A pop-up menu is available when you right-click on the severity icon for an entity 
in the table, or on a class or instance name (on the X and Y axes). 

Table 15: Status Table Pop-Up Menus

SELECTION 
CRITERIA

OPTION DESCRIPTION

Right-click on 
the severity icon 
for an instance

Browse Opens the Topology Browser view for the current 
Global Manager that contains the selected element 
in a secondary window

Containment Displays an element’s components

Notification Properties Displays notification properties for that element

Show Map Opens a map with that element as focus
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S t a t u s  T a b l e  C o n s o l e  T o o l b a r  B u t t o n s

In the Status Table Console, certain menu options are provided as toolbar buttons. 
They are summarized in Table 16.

Table 16: Status Table Console Toolbar Buttons

BUTTON DESCRIPTION

Opens a local console

Saves an unsaved console on a local or remote host. Saves a 
saved console to a previously-specified destination.

Opens the Configure Status Table dialog box. 
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Starting a Session
You can open a Global Console in a Windows or UNIX environment, or as a Web 
Console in a Web Browser. 

This chapter provides instructions for:

• Opening the Global Console and logging on

• Opening an additional console from an existing console 

• Opening a Web Console from a Web browser and logging on 

• Closing a console and ending a session

• Attaching to different or multiple CNCC Managers

When you open a console at the beginning of your session, you will need to log on. 
This involves specifying your NCM user name and password, broker information, 
and the CNCC Manager name for attachment.

If you initially attach to a Global Manager, one or more consoles display after you 
log on, depending upon your user profile or the default user profile. For example, if 
your user profile is configured for the Notification Log and Map Consoles, then 
two consoles will display after you log on. If you attach to a Domain Manager, the 
Topology Browser Console displays first since Domain Managers do not maintain 
user profiles.
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Opening the Global Console 
This section describes how to start a Global Console session in a Windows or 
UNIX environment. 

Opening a Global  Console  in a Windows Environment
To start a new session and open a new console in a Windows environment, click 
the Start button in the Windows Taskbar. Then, select Programs > InCharge 6 > 
Global Console. 

Opening a Global  Console  in a  UNIX Environment
To start a new session and open a new console in a UNIX environment, use the 
sm_gui command.

% BASEDIR/smarts/bin/sm_gui 

Logging on and Attaching to a  Manager
Before the console appears, you are prompted to log on and attach to a Manager. 

1 For the Broker field, the broker host name and port number values (that were 
provided during the installation process) appear. You may need to change 
them; check with your administrator for the correct values. 

For example, in Figure 6, the broker host name is cisco-broker and the port 
number is 426.

Figure 6: Attach CNCC Manager Dialog Box

2 Click on the Manager drop-down list or the Browse button to display a list of 
active (running) CNCC Managers. 
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Note: If the specified broker is a secure broker, when you click on the Manager 
drop-down list or the Browse button, you might be prompted to supply a 
NCM user name and password for the broker, depending upon the security 
configuration. Click OK and then select a CNCC Manager from the displayed 
list.

3 For the User name field, type your NCM user name.

4 For the Password field, type your password.

5 Click OK. 

After you click OK, the console displays. To close the dialog box and end the 
session, click Cancel.

Opening an Additional Global Console 
If you already started a session, you can open a new console or a saved console 
from your current console.

Opening a New Console  
You can open a new console from any running console in a session. Select one of 
the following consoles: 

• File > New > Notification Log Console 

• File > New > Map Console

• File > New > Topology Browser Console

• File > New > Summary View Console

• File > New > Status Table Console

This opens a console and attaches it to the same CNCC Managers as the running 
console. In the status bar, the text "Not saved" appears since it is an unsaved 
console. The new console is part of the same session as the running console.

If the value “None” appears in the Manager pull-down menu, you need to select a 
Global Manager or a CNCC Manager from the pull-down menu, depending on the 
type of console. A new Summary View Console displays one default summary for 
each attached Global Manager.
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Opening a Local ly  Saved Console
You can open a console saved on the host where the Global Console is running. To 
do so, perform these steps:

1 Select File > Open > Open Local. Or click the Open Local toolbar button. 
This displays the Open Console dialog box.

2 In the Open Console dialog box, select the console and click Open. This 
opens the console. The status bar displays the directory path and its file name.

Opening a Remotely Saved Console
You can open a console saved on the host where a CNCC Manager is running. To 
so, perform these steps:

1 Select File > Open > Open Remote. This displays the Open Remote Console 
dialog box.

2 In the Open Remote Console dialog box, select the location of the saved 
console. Choose a CNCC Manager. 

3 Click on the Load from drop-down list to display the list of available 
consoles.

4 Select the console and click OK. This opens the console. The status bar 
displays the CNCC Manager where it is saved, user name, and the console 
name.

Opening a Web Console
You can open a Web Console, which provides Global Console functionality, in a 
Web Browser. When you open a Web Console, the console opens within the 
browser, not in a separate window. 

For information about browser requirements, see the Network Connectivity 
Monitor Service Assurance Management Suite Installation Guide.
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To open a Web Console, perform these steps:

1 Start your browser and point it at the following URL:

http://<Tomcat_host>:8080/webconsole/NCMApplet.html

Where <Tomcat_host> is the name of the machine where the Jakarta Tomcat 
Servlet Engine is installed; 8080 is the value for the port.

Note: Jakarta Tomcat Servlet Engine is installed as part of the Web Console or 
Business Dashboard. The Tomcat Engine serves the files used by the Web 
application.

2 In the Java Security Warning dialog box, click Yes or Always.

Yes or Always grants the Web Console full access to your machine. This 
allows the console to connect to any CNCC Manager from your machine, 
provided your login ID has authorization, and the console can save files 
locally.

No allows the Web Console to run without full access to your machine. 

3 Log on as described in Logging on and Attaching to a Manager on page 30.

Using Java Web Start  (Optional)
To use Java Web Start with the Web Console, specify the following URL or select 
its icon if Java Web Start is installed.

To download and install Java Web Start, perform these steps:

1 Start your browser and point it at the following URL:

http://<Tomcat_host>:8080/webconsole/globalConsoleCached.html

Where <Tomcat_host> is the name of the machine where the Jakarta Tomcat 
Servlet Engine is installed; 8080 is the value for the port.

In the Java Security Warning dialog box, click Yes or Always.

Yes or Always grants the Web Console full access to your machine. This 
allows the console to connect to any CNCC Manager from your machine, 
provided your login ID has authorization, and the console can save files 
locally.

No allows the Web Console to run without full access to your machine. 

2 Optionally, select the option to download and install the Java Web Start 
product and the application.
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A Java Web Start icon will install on your desktop or your Start menu. To start 
the Web Console after this, you can click this icon.

3 Log on as described in Logging on and Attaching to a Manager on page 30.

If you do not have Java Web Start installed, you might be prompted to use an 
automatic installer or be directed to a Sun Microsystems web page, depending 
upon your operating system or browser. 

Closing a Console and Ending a Session
If you have one or more consoles running, you can close specific consoles or end 
the entire session.

Closing a Console
To close a console, select File > Close. The Close command closes an individual 
console and the session continues. The CNCC Manager is not affected by this 
operation. 

If the console is the last opened one, you are prompted to confirm whether to close 
it. Click Yes to close it. When you close the last console, you end the session.

Note that when you close a Web Browser window, the console closes. If that is the 
only open window for this session, the session closes. In the Web Console, you 
may not be prompted to confirm closing the last open console.

Ending a Session
To close a session and exit a console, select File > Exit and click Yes to confirm it. 
All consoles that are part of the session are closed and the session ends. The CNCC 
Manager is not affected by this operation.

Attaching to Different or Multiple CNCC Managers 
After you log on, if you need to use a different CNCC Manager, you can attach to 
another without exiting the console. If you detach from a CNCC Manager, you can 
attach to it again at any time.

If you need to access multiple CNCC Managers, you can attach to them, one at a 
time.
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The attach procedure is similar to the logon procedure with some minor 
differences. For the attach procedure, you can use the same login user name and re-
enter your password or specify a different login ID. If you wish to attach to a 
CNCC Manager using a different login ID, you do not have to start another Service 
Assurance session.

D e t a c h i n g  F r o m  a  C N C C  M a n a g e r

Detach from a CNCC Manager when you no longer want to interact with it. The 
detach operation does not stop the CNCC Manager. 

To detach from a CNCC Manager, perform these steps:

1 Select Manager > Detach.

2 Click Yes to confirm the detach.

If multiple CNCC Managers are attached, the Detach Manager dialog box 
displays. Select the CNCC Manager you wish to detach and click OK or click 
Cancel.

For the detached CNCC Manager, the value “None” appears in the Manager 
pull-down menu; other attached CNCC Managers remain listed and available. 
If you are using the Summary View Console, the summaries for the detached 
Global Manager turn gray.

A t t a c h i n g  t o  a  C N C C  M a n a g e r

To attach to a CNCC Manager, perform these steps:

1 Select Manager > Attach. This displays the Attach Manager dialog box.

2 The last attached CNCC Manager displays in the Manager pull-down menu. 
If you wish to reattach, accept the value. Or, click on the Manager drop-down 
list or the Browse button to select another CNCC Manager.

Note: If the specified broker is a secure broker, when you click on the Manager 
drop-down list or the Browse button, you might be prompted to supply your 
NCM username and password, depending upon the security configuration. 
Click OK and then select a CNCC Manager from the displayed list.

3 Type your password in the Password field.

You do not need to change the values for the Broker field or the User name 
field.

If you wish to specify a different login ID, you can change the values for the 
User name and Password fields.

4 Click OK.
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To close the dialog box without attaching to a CNCC Manager, click Cancel.

The name of CNCC Manager is listed in the Manager drop-down menu. If 
you are using the Summary View Console, the Global Manager’s name is 
listed at the bottom of a summary after it is added to the view.
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Examining Notifications
As you monitor your managed domain, you might need to examine notifications or 
investigate their causes. You may also need to refine the appearance of diagnostic 
results in your console.

This chapter explains:

• Alternative methods for accessing notifications

• How to interpret notifications

• Notifications and their color-coding 

• The meanings of column names in the Notification Log Console

• How to display notification properties, including an audit log, 
symptomatic events for root-cause notifications, affected systems, critical 
failures that generate notifications, and aggregates

• How to dynamically change the contents of your console as you work. For 
example, console features for refining the contents of your Notification Log 
Console may include arranging columns, sorting, update intervals, and 
filtering.

For descriptions of console layout and available menus, see Global Console 
Overview on page 4.
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Accessing Notifications
Once you start a session, events may appear as notifications in your Notification 
Log Console and may update summaries in your Summary View Console. Or, you 
can display topological information in a map or topology tree.

Once any console is opened, there are alternative methods for accessing 
notification information:

• Add a Notification Log view to any console. (For information about views 
and adding views, see Customizing Your Console on page 119.)

• Check the Events tab of the Topology Browser for any available notifications.

• Display notification properties by double-clicking an affected node 
(non-green color) in a map or on a selected notification.

• Use the Show Notifications toolbar button to display a Notification Log view 
for a selected summary in a secondary window.

About Notifications
When you are interpreting notifications, you should be aware of the different 
severity levels for notifications, and important attributes such as Source, IsRoot, 
and Impact that display as columns in your console. This section also explains how 
to obtain more information about notification properties. 

Notification information is displayed in: 

• The Notification Log Console or view (including a view for a selected 
summary), when events occur

• The Events tab of the Topology Browser for the object where the problem or 
event occurs

• The Notification Properties view. See Displaying Notification Properties on 
page 43.

• Maps where notifications affect the state of icons. See Adjusting the 
Appearance of a Map on page 78.

• Status Table Console, for status of the underlying elements that affect the 
operation of business entities. See Examining Status Tables on page 95.
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Notif icat ion Naming Convention
Each notification has a unique name. A notification’s name consists of the class 
name and instance name where the event occurred, and the event name. The 
notification naming convention is:

NOTIFICATION-ClassName_InstanceName_EventName

For example, the notification NOTIFICATION-Router_R1_Down identifies the 
event Down, which occurred in instance R1 of the Router class. 

Unique notification names with this convention are displayed in the 
InternalEventHandle column. By default, the InternalEventHandle column is not 
displayed in the Notification Log Console, but you can add it by selecting Log > 
Select Columns. The Class, Name, and Event columns display a more readable 
form of this information.

The Notification Log Console will not list more than one notification with this 
name. If the event clears and occurs again before it is archived, the Count field is 
increased accordingly.

Notif icat ion Severity
Service Assurance generates five levels of severity for notifications: critical, major, 
minor, unknown, and normal. Each level has an associated severity icon, a unique 
color-coded icon. Table 17 summarizes severity and how severity displays in your 
Notification Log Console.

Note: The notification list configured by your administrator determines which 
notifications appear in your console. If the notification list does not include an 
event, notifications for the event will not appear in your console. If your 
Notification Log Console does not accurately reflect observed conditions, contact 
your administrator.
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Table 17: Notifications and Console Display

When an event’s state changes from ACTIVE (notified) to INACTIVE (cleared), 
the notification turns transparent (white). An inactive state means that the event is 
no longer occurring. If an event recurs, the Global Manager sends another 
notification, the state of the event returns to active, and the event counter is 
incremented.

SEVERITY LEVEL DESCRIPTION SEVERITY ICON

CRITICAL (RED)
SEVERITY 1

A critical notification identifies a fatal condition. It requires 
immediate attention.
When you receive multiple critical notifications, it means 
that Service Assurance has determined several independent 
fatal conditions. 

MAJOR (ORANGE)
SEVERITY 2

This represents a serious condition. It requires immediate 
attention.

MINOR (YELLOW)
SEVERITY 3

This represents an abnormal condition. Action is required 
but the condition is not serious.

UNKNOWN (BLUE)
SEVERITY 4

This represents elements and/or events that are in an 
unknown state because of network or management 
connectivity failures. It requires investigation.

NORMAL (GREEN)
SEVERITY 5

This represents a normal state and is usually displayed 
when an event is informational.

OTHER INDICATORS DESCRIPTION COLOR OF ITEM 

INACTIVE This indicates that the state cleared (changed to 
INACTIVE) and notification turns transparent. 

White with black text

SELECTED Clicking on a notification selects it. Black border surrounding 
notification

UNMONITORED OR 
SUSPENDED

In the Notification Properties view, this indicates an event is 
unmonitored or suspended.

Gray text 
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Notif icat ion Log Columns 
In the Notification Log view, notification attributes display as column headings. 
Table 18 lists the column names and their descriptions. 

COLUMN / ATTRIBUTE DESCRIPTION

InternalEventHandle A unique key that identifies the event.

ClassName Class name of the managed element where the event occurred. One of 
three attributes that uniquely identifies a notification, not modifiable. 

InstanceName Name of the instance where the problem was diagnosed. One of three 
attributes that uniquely identifies a notification, not modifiable. 

EventName Name of the notification. One of three attributes that uniquely identifies a 
notification, not modifiable. 

Class Display name for the event class. 

Name Display name for the event instance.

Event Display name for the event name.

Element Name The name of the topology element associated with the event in the 
repository where this event resides. The string is empty if there is no 
related element. This may or may not have the same value as 
InstanceName.

Element Class The class name of the topology element associated with the event in the 
repository where this event resides. This may or may not have the same 
value as Class or may be empty.

Source Identifies the software component(s) from which the notification was 
received, where the event is diagnosed (for example, a Global Manager, 
Domain Manager, SAM Adapter Platform, or SAM adapter).
If there is more than one source, the attribute lists each separated by a 
comma.

Active Indicates if the event is active.

Count The number of occurrences of this event starting from First Notify until 
Last Notify.
For a momentary event (no duration), each occurrence increases the count 
value regardless of the current event state. 
For a durable event (a duration), the count value is maintained for 
individual sources.

First Notify First notification time. (This value is reset after an event is archived.)

Last Notify Last notification time.

Last Clear Last clear time. "Never" indicates the notification has never cleared.

Last Change Time of last event change.
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Table 18: Columns in the Notification Log View

IsRoot Yes indicates that the current notification is the root event.
No indicates that the current notification is not a root event and is caused 
by another event. 

Acknowledged Indicates the event has been acknowledged.

Event Type Indicates the nature of the event. A momentary event has no duration. A 
durable event has a period during which the event is active and after 
which the event is no longer active.

Category Represents a broad categorization of the event (for example, Availability 
versus Temperature). Valid values can be: Availability, Discovery, Error, 
Operational, Performance, PowerSupply, Resource, Temperature, and 
IMPACT.

Event Text A longer textual description of the event.

Event State Indicates the state of the event. Values can be ACTIVE (notified), 
SUSPENDED, WAS_ACTIVE, or INACTIVE (cleared). 

Severity A graphical severity icon (color-coded icon) that categorizes the severity 
level of the event from the notifier's point of view:
1 - Critical, indicates a fatal condition and that the scope is broad (for 
example, an outage to a critical resource).
2 - Major, indicates a serious condition.
3 - Minor, indicates an abnormal condition but not a serious one.
4 - Unknown, indicates that elements and/or events that are in an 
unknown state because of network or management connectivity failures. 
5 - Normal, indicates a normal state and that an event is purely 
informational.
For examples of the severity icons, see Table 17.

Impact If Business Impact Manager is available, the sum of the weights for all 
affected elements. The default weight for each affected element is 1. 
Weights quantify the event impact on the infrastructure and business 
processes. A large numeric value indicates a large impact. 

Certainty The certainty of this event.

In Maintenance Indicates whether this event occurred during a maintenance period.

Ticket ID Trouble ticket ID.

Owner The user name of the person responsible for handling the event.

User Defined1-10 10 user-defined fields. Reserved for custom configuration.

COLUMN / ATTRIBUTE DESCRIPTION
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For more information about the IsRoot and Impact attributes, use the Caused By 
tab and Impact tab, respectively, in the Notification Properties view.

• The Caused By tab lists another event that caused a selected notification if the 
IsRoot value is No. 

• The Impact tab lists all of the affected elements for the selected notification. 

Note: The default weight can be changed by your administrator. Contact your 
administrator for acceptable values if you intend to specify this attribute in a 
notification filter. 

For complete information about attributes, see the Network Connectivity Monitor 
Service Assurance Manager Configuration Guide.

Displaying Notification Properties
To obtain detailed information about individual notifications, you can display 
notification properties information in either a dialog box or a view. To do so, you 
can:

• Double-click on a notification in the Notification Log view

• Select a notification and click the Properties toolbar button

• Select Event > Properties

• Right-click a selected notification and select the Properties option in the pop-
up menu

• Double-click on a map icon if it is affected by active events and is no longer 
green. Or, right-click a selected map icon and select the Notification 
Properties option in the pop-up menu

• Add a Notification Properties view using View> Add View

Depending on the type of event and information available for display, the 
Notification Properties view displays up to seven types of tabs and up to four 
buttons. 

• The tabs are: General, Audit Log, Codebook, Impact, Details, Caused By, and 
Aggregates. (If a tab does not display but Fetch Details is enabled, click 
Fetch Details.)
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• The buttons are: Refresh to update values, Browse to display the Topology 
Browser for the instance of the event, Fetch Details to display information 
from underlying CNCC Managers, and, for the dialog box, Close to exit.

The Notification Properties view is available regardless of the notification’s state 
(active or inactive).

Depending upon the Global Manager’s configuration, the detailed information is 
retrieved from the Global Manager and may include information from underlying 
CNCC Managers. One indication is whether or not the Fetch Details button 
appears in the view.

• If the Fetch Details button does not exist, the information is retrieved from 
the Global Manager and its underlying CNCC Managers.

• If the Fetch Details button does exist, the information is retrieved from only 
the Global Manager. 

To display information from the underlying CNCC Managers, click Fetch 
Details.

Regardless of the configuration, Refresh updates the information from the 
appropriate sources.

General  Tab
The General tab lists the current values of the notification attributes. 

Audit  Log Tab
The Audit Log tab displays the audit trail for the selected notification. 

In the log, each row is an entry. To view the full entry, select the row and click 
Show Full Entry. To insert additional entries, click Add to Audit Log.

System actions such as archiving and user actions such as acknowledgement, 
ownership, and actions performed using server and automatic tools are recorded as 
entries in the audit log. Inserted comments cannot be edited or deleted and are 
archived as part of the audit log. For information, see Adding Comments to an 
Audit Log on page 112.

To save a copy of the current contents of an audit log locally as a text file, click 
Save table to file. In the Save table to file dialog box, you can choose field 
delimiters, whether to include column headers, and a location for the file. Click 
OK to save the audit log. For additional information, see Saving Audit Log and 
Containment Information on page 114.
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Codebook Tab
The Codebook tab only displays for a selected notification that represents a root-
cause event from an underlying CNCC Manager. Such a notification, regardless of 
its severity, has a value of Yes for its IsRoot attribute. If a notification is notified as 
a root cause from multiple sources, one Codebook tab displays for each source. If 
the tab does not display but Fetch Details is enabled, click Fetch Details to 
display the tab.

The Codebook tab displays all symptomatic events used in the analysis of a root-
cause event. The notification for an active symptomatic event indicates an 
abnormal condition in an underlying CNCC Manager. Notifications for 
symptomatic events are primarily displayed in this tab and might be displayed in 
the Notification Log Console. Their display in the console can be configured by 
your administrator. 

In the Codebook tab, information is presented as a tree. Each tree node represents a 
class associated with a symptomatic event. You can expand the node to display its 
instance or instances.

The coloring of an active notification for a symptomatic event is determined by its 
underlying source or whether the event has already been imported into the Global 
Manager. Typically, the coloring is:

• Orange if the symptomatic event is active

• White with black text if the event is inactive

• Gray text if the event is unmonitored or suspended

In the Codebook tab, you can:

• Right-click and deselect Show Active Only to display active and inactive 
symptomatic events. 

• Right-click and select Collapsed to collapse the tree hierarchy. To expand the 
subtree, select Collapsed again to uncheck it.

• Use a tool tip for information on the state of the symptomatic event. For 
example, use a tool tip to determine whether an event is unmonitored or 
suspended.

• Double-click on an instance to display the Notification Properties dialog box 
for more information.
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Impact  Tab
The Impact tab displays the objects affected by the selected notification. This tab 
displays for any type of event, including critical problems. Not all events affect 
other objects, so the Impact tab may not display. 

The tab presents information in a table. To sort it, click one of the column 
headings. In the table, you can view the affected object’s class and event.

For more information about an object, you can double-click on its row display the 
Notification Properties dialog box. Or, right-click it and select Browse to display a 
Topology Browser. You can also right-click on a row and select Show Map to 
display it in a Map Console. 

To display the events which, in turn, cause the selected notification, see Caused By 
Tab on page 47.

Detai ls  Tab
The Details tab displays the CNCC Manager (source), the object’s attributes and 
their corresponding values relevant to the event. If a notification has multiple 
sources, one Detail tab displays for each source.

The tab presents information in one of three formats: 

• A table of attributes and values

• A table of thresholds and their related attributes and values

• A sum or total value with a table of other attributes compared against a 
threshold value 

A gray line may appear in place of an attribute value in either the Details tab of the 
Notification Properties view or the Attribute tab in the Topology Browser.

If a gray line appears in place of an attribute value, the value cannot be obtained by 
Service Assurance because:

• It is unnecessary for the underlying CNCC Manager to poll the attribute value 
of an external device at this time. To minimize network overhead, the CNCC 
Manager only polls those values it needs to analyze your devices. 

• The underlying CNCC Manager has encountered an error while polling the 
attribute value of an external device. For example, the device might be down, 
or it might be up but inaccessible due to network problems. In this case, you 
receive a notification of the critical problem, but the value remains 
unavailable. 
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Caused By Tab
The Caused By tab displays the events that are causing the selected notification. It 
also displays the objects where the events occur.

The tab presents information in a table. To sort it, click one of the column 
headings. 

For more information about an object, you can double-click on its row to display 
the Notification Properties dialog box. Or, right-click it and select Browse to 
display a Topology Browser. You can also right-click on a row and select Show 
Map to display it in a Map Console. 

Aggregates  Tab
The Aggregates tab displays if the selected notification is an aggregate. This tab 
enables you to examine the component notifications of an aggregate.

An aggregate is a notification that consists of one or more component notifications. 

The tab displays the components of the aggregate, their class, object names, and 
the CNCC Manager (source). If a notification has multiple sources, one 
Aggregates tab displays for each source. To sort the table of information, click one 
of the column headings. 

In the tab, a component notification is colored:

• According to its severity if it is active

• White with black text if it is inactive

• Gray text if it is unmonitored or suspended

For more information about a component notification, you can double-click on it 
to display the Notification Properties dialog box. Or, right-click it and select 
Browse or Show Map to display a Topology Browser or a Map Console, 
respectively. 

A Map Consideration
If you double-click on a colored map node (or right-click on a colored edge) and:

• One notification exists, the Notification Properties dialog box displays. 

• Multiple notifications exist, the Active Notifications dialog box displays. 

In the Active Notifications dialog box, select the notification you wish to see 
and click Properties to display the Notification Properties view or click 
Close.
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Notif icat ion Properties  Tab Examples
Figure 7 shows the active symptomatic events for an Interface Disabled 
notification for the interface IF-lab-gw.

Figure 7: Codebook Tab
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Figure 8 shows an audit log for a Router Unresponsive notification for the router 
moto-gw.

Figure 8: Audit Log Tab

Figure 9 shows objects affected by a Card Down notification for the card 
wrcaswsjc4/4.

Figure 9: Impact Tab
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Adjusting the Contents of a Notification Log View
To make it easier to examine the contents of your console(s), you can rearrange or 
adjust the contents. This section describes how to:

• Change the contents of a Notification Log view.

• Adjust the appearance of a Notification Log Console (for example, how to 
rearrange columns, sort by column, and control the display of columns).

You can also adjust the contents by applying filters. See Using Filters on page 54.

For information about how to create a customized console, see Customizing Your 
Console on page 119.

Changing the Contents  of  a  Notif icat ion Log View
In a single Notification Log view, you can display notifications from different 
Global Managers by changing the selection in the Manager pull-down menu. 

Adjusting the Appearance of  a  Notif icat ion Log Console  or 
View

In your Notification Log Console or view, you can:

• Control which columns are displayed

• Adjust the column width

• Rearrange the order of columns

Note: In the following sections, some menu options are not available when you display a 
Notification Log view for a summary. In this case, the Notification Log view only 
supports the menu options that result from right-clicking on a notification (see 
Table 6).

For descriptions of notification columns, see Notification Log Columns on 
page 41.
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C o n t r o l l i n g  t h e  C o l u m n  D i s p l a y

Certain columns may be extraneous for your work. To control which columns 
display, perform these steps:

1 Select Log > Select Columns. Or, right-click in the area near the view title and 
select Select Columns in the pop-up menu. The Select Columns dialog box 
displays.

2 To add or hide a column from your display, select or deselect the appropriate 
check box.

3 Click OK to apply your changes.

Optionally, you can right-click on a column heading to hide it or to add another 
column next to it. 

• To hide a column, right-click on its heading and select Hide Column in the 
pop-up menu. 

• To add a new column, right-click on a column heading, select Insert Column 
in the pop-up menu, and select a new column in the submenu. The new 
column is inserted to the left of the selected column.

A d j u s t i n g  t h e  C o l u m n  W i d t h

You can adjust the column width, if necessary. To adjust the width of a column, 
select the divider between column titles and drag it with the mouse. 

R e a r r a n g i n g  t h e  O r d e r  o f  C o l u m n s

You can change the order of columns. To rearrange the columns, select a column 
title and drag it to the left or right.

To move a column, right-click on a column heading, select Insert, and, in the 
submenu, select the column you wish to move. The column is moved to the left of 
the selected column.

Sorting Notif icat ions
Two methods are available for sorting notifications: Click Sort and the Column 
Sort Order dialog box. A Notification Log view, by default, is unsorted.
Network Connectivity Monitor Operator’s Guide 51



Examining Notifications
C l i c k  S o r t  M e t h o d

To sort notifications by one column, click on the column title you wish to use for 
sorting. Notice that a triangular marker appears in the column title. 

• First click sorts the notifications in ascending order. The triangular marker 
points up.

• Second click sorts the notifications in descending order. The triangular 
marker points down.

• Third click disables the sort. The triangular marker is removed.

Note: If you disable the click sort and there are other sort columns specified in the 
Column Sort Order dialog box, the specified sort columns determine the sort 
order.

Columns that are moved and hidden from display may continue to affect the sort 
order.

C o l u m n  S o r t  O r d e r  D i a l o g  B o x

To sort notifications by multiple columns, perform these steps:

1 Select Log > Sort Columns. Or, right-click in the area near the view title and 
select Sort Column in the pop-up menu. The Column Sort Order dialog box 
displays.

2 Select the columns from the drop-down lists. Select Descending for a 
descending sort order; Ascending is the default.

If you already used Click Sort, your choice appears in the dialog box. You can 
also specify a Click Sort column. If you uncheck the Enabled check box, 
Click Sort is disabled until the next time you click on a column title or check 
the Enabled check box.

The primary sort field is the Click Sort column or, if no Click Sort column is 
specified, the first field that you specify in the dialog box.

If you need to reset your selections, click Reset.

3 Click OK to apply your changes.

Note: Except for the Click Sort selection, sorting, as determined by the selected columns 
in the Column Sort Order dialog box, is retained if you save a console.
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Updating and Freezing Notif icat ions
You can:

• Control whether the display of notifications is updated continuously or at 
scheduled interval

• Freeze the notifications and prevent the display from updating

S p e c i f y i n g  D i s p l a y  U p d a t e s  f o r  N o t i f i c a t i o n s

Notifications are constantly being updated in your console by default. If you wish 
to control how often notifications are updated, you can specify a time interval for 
scheduled updates. 

You should consider the following before you specify a time interval:

• You should balance the update period between timely updates and the 
processing resources required to continually update the Notification Log 
Console. Check with your system administrator about an appropriate setting.

• Simultaneous displays of notifications might be inconsistent. If you specify a 
time interval for scheduled updates, users’ actions, including your own, which 
occur during the interval are not updated in the display until after the interval. 
For example, you might acknowledge a notification that another user has 
already acknowledged. If this is a concern, use the time interval feature (the 
Update Every field) sparingly.

To specify an interval for scheduled updates, perform the following steps: 

1 Select Log > Log Properties. Or, right-click in the area near the view title and 
select Log Properties in the pop-up menu. The Log Properties dialog box 
displays. 

2 Uncheck the check box for Update Continuously and specify the time in the 
Update Every field.

3 Click OK. 

F r e e z i n g  Y o u r  D i s p l a y

To stop notifications from changing in the display, select Log > Freeze Display. Or, 
right-click in the area near the view title and select Freeze Display in the pop-up 
menu. In the left corner of the view, a box icon appears.

To unfreeze the display, select Log > Freeze Display again or click on the box icon. 
The box icon in the left corner is removed.
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Using Filters
Filters enable you to control the contents of your console, view, or individual 
summaries. You apply a filter to notification attributes, any class, and/or instance. 
For example, you may wish to monitor only critical notifications with high impact 
on your business operations. There is one filter per view or summary. Filter criteria 
are saved if you save your consoles.

This section describes how to filter notifications with the Filter Builder dialog box. 
To apply a topological filter to a summary using the Filter Builder, see Filtering 
Summaries on page 91.

For information about filtering a topology tree, see Filtering Topology on page 61. 
For information about filtering class instances in a map, see Filtering Maps on 
page 83.

Filtering Notif icat ions
You can apply a filter to your Notification Log view. The filter can consist of one 
or more criteria. Only notifications that match all of your criteria are displayed. 
Filter criteria are saved if you save your console.

Use one of the following methods to open the Filter Builder dialog box: 

• Click on a Notification Log view and select Log > Filter. 

• Right-click in the title area of the view and select Filter in the pop-up menu. 

L a y o u t  o f  t h e  F i l t e r  B u i l d e r

Initially, the Filter Builder dialog box opens with a blank Sheet1 tab. At the top, 
the Edit menu enables you to add, copy, or delete a Sheet tab. 

On the left, the green plus sign button enables you to add one filter criterion at a 
time. Pull-down menus for each filter criterion enable you to select a notification 
attribute and a match condition such as a specific value or expression. You can also 
specify wildcard characters in a match condition. Values are case-sensitive. 

A Helper button displays depending on the selected notification attribute. This 
button provides a list of acceptable values, prompts you for a range of values, or 
enables you to define an expression. If you add a wildcard character to an 
expression, the Helper button is disabled. 

The red X button deletes a specific filter criterion.
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At the bottom of the dialog box are the following buttons: OK, Cancel, and 
Refresh. To apply your filter and exit the dialog box, click OK. Click Cancel to 
exit without applying your changes. Refresh resets the Filter Builder dialog box to 
its original or previously applied filter criteria.

For descriptions of notification attributes, see Notification Log Columns on 
page 41. For a list of wildcards, see Wildcard Patterns on page 137.

P a t t e r n  M a t c h i n g

When you create a filter, you can specify as many attribute-value pairs as you 
wish. Each pair is a filter criterion. There is one filter per view. See Figure 10 for 
an example.

To pass a filter, notifications must satisfy all conditions in at least one Sheet tab. 

• In a Sheet tab, criteria are related to each other with a logical operator AND. 
To satisfy a given tab, notifications must satisfy all conditions specified in the 
tab. 

• Individual Sheet tabs are related to each other with a logical operator OR. 
Notifications must satisfy the conditions in at least one tab.

E x a m p l e  o f  a  F i l t e r

For example, if you wish to display only critical notifications for Down events for 
a router or a host that impact your business operations, then specify: a value of 1 
for Severity, Down for Event, a value of "~0" (not zero) for Impact, and any router 
or host. 
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Figure 10: Filter Builder Dialog Box
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4
Examining Topology 
Service Assurance abstracts topological information from CNCC Managers and 
third-party applications. As you monitor your managed domain, you might need to 
examine your topology. The Topology Browser Console displays the topology of 
any attached CNCC Manager.

This chapter explains:

• Alternative methods for accessing topological information

• How topological information is represented

• How to use the Topology Browser Console, including Browse Detail and 
filtering

• Find search tools and the Containment dialog box, available from any 
console, to locate or examine an individual element

For descriptions of console layout and available menus, see Global Console 
Overview on page 4.

Accessing Topology
This section describes alternative methods for accessing topological information.
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Once any console is opened, there are alternative methods for accessing 
topological information:

• Add a Topology Browser view to any existing console. (For information 
about views and adding views, see Customizing Your Console on page 119.) 
Note that the Topology Browser is not available as a viewlet.

• Browse opens the Topology Browser view in a secondary window to access 
topological information. Browse is available as a button in most secondary 
windows and dialog boxes or as an Event menu option for selected 
notifications. For example, the Browse button appears in the Notification 
Properties dialog box and the Find Instance dialog box. (The button is 
activated when you select a row in the table.)

• Browse Detail menu option opens the Topology Browser view with topology 
from an underlying CNCC Manager in a secondary window. 

• The Containment dialog box displays information and components for a 
selected element. (See Using the Containment Dialog Box on page 64.) 

Available Topological Information and Its 
Representation

For most situations, the Topology Browser Console and Map Console provide the 
most complete representations of your topology. 

There are different kinds of topological information. For example:

• Devices, logical groups such as IP networks and VLANs, and other 
infrastructure elements (such as network connections) that compose the 
domains managed by underlying CNCC Managers

• User-defined groups of elements (configured by your administrator)

• Business elements such as application services, service offerings (such as 
Web hosting contracts), and service subscribers (such as customers, business 
units, or corporations). Service information and service classes may not be 
available for your site.

Topology is represented in a tree format as in the map tree and the Topology 
Browser Console or by map icons in a map.

For information about the Map Console, including how maps represent topological 
information, and map color-coding, see Examining Maps on page 67.
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Topology Browser Console or View
The Topology Browser (console, view, or secondary window) presents the 
topology of any CNCC Manager as a topology tree. Operators can view the 
topology of any attached CNCC Manager by selecting it from the Manager pull-
down menu.

Displaying Topology 
To display an expanded topology tree in the left panel, you need to select a CNCC 
Manager from the Manager pull-down menu above the left panel.

Note: A plus (+) sign indicates unexpanded objects. (On some systems, an open circle 
appears instead of a plus sign.)

If you already used the Browse option, the Manager icon is already expanded 
beginning with the class of your selection. 

To navigate the topology tree, perform these steps:

1 Click the plus sign next to a class to view its elements (instances). 

2 Click an element in the topology tree to display tabs of information in the 
right panel.

3 Click the plus sign next to an element to display its relationships. 

4 Click the plus sign next to a relationship to display classes of related 
elements. 

5 Click the plus sign next to a related class to display the related instances.

To refresh the contents of a topology tree, right-click in the background area and 
select Refresh Tree from the pop-up menu. Then, expand the tree.
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For each object you select, a corresponding property sheet with one or more tabs is 
also displayed:

• For a CNCC Manager, the Modules and Threads tabs provide information 
about models, programs, and process threads. For a Domain Manager, the 
Correlation tab also displays and provides correlation information such as the 
correlation interval.

• For classes, the Description and Attributes tabs describe the class and its 
attributes.

• For elements (instances):

• Attributes tab lists the attribute names, data types, values, and 
descriptions of the attributes. 

• Groups tab displays groups if the instances belong to any groups. 

• Global Manager only, the Events tab displays notifications if they are 
generated. The Events tab does not display for a selected element of a 
Domain Manager.

Note: In the Topology Browser, an individual object with a plus (+) sign does not open or 
expand if a class exceeds 1000 instances. Instead, a node displays, reporting that 
there are more than 1000 instances. Select Edit > Find Instances to find an 
individual instance and display related topology. (See Available Topological 
Information and Its Representation on page 58.) 

Also, the tool tip displays the correct number of instances. To activate the tool tip, 
hold the cursor over the object you wish to expand.

Browse Detai l  
The Browse Detail menu option is available:

• In the pop-up menu of the Topology Browser Console, right-click on a 
selected element in the tree and select Browse Detail in the menu.

• In the Event menu or the pop-up menu of the Notification Log Console, right-
click on a selected notification.

• In a map, right-click on a node or on an edge and select Browse Detail in the 
pop-up menu.
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Browse Detail provides a submenu that lists all of the underlying CNCC Managers 
that contain the selected element in their topology. You can select one of the 
underlying sources and display it in a Topology Browser view. Figure 11 shows an 
example.

Figure 11: Browse Detail Example

If the underlying CNCC Manager is not attached to the console, the console 
establishes a connection automatically with your logon ID. If this is not possible, 
you might be prompted to supply another NCM username and password.

If the selected element does not have any underlying sources, Browse Detail is 
disabled. Also, Browse Detail is not available for notifications generated by non-
NCM sources such as third-party adapters.

For hierarchical Service Assurance deployments, you can select Browse Detail as 
many times as necessary to navigate to the desired CNCC Manager. 

Filtering Topology
The topology filter enables you to control which classes and specific instances 
appear in the Topology Browser. You can specify a filter for each attached CNCC 
Manager and create a general filter for attached CNCC Managers that are not 
assigned filters. Filter criteria are saved if you save your consoles.
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To specify filtering criteria, perform these steps:

1 Right-click in the topology tree panel. 

2 In the pop-up menu, select Select to display the Select Tree Contents dialog 
box.

3 In the Select Tree Contents dialog box, you can:

• Select All Attached Domains to apply the filter to all attached CNCC 
Managers

• Select Current to apply the filter to the selected CNCC Manager.

• Display all of the classes including classes without instances. Select the 
check box for Show classes with no instances.

• Display one or more specific classes. Select the class. To select multiple 
classes, press the Ctrl key while making your selections.

• If you select classes that have instances, you can also select specific 
instances.

4 To make your changes take effect, you must click OK.

To undo filter changes, display the Select Tree Contents dialog box again, deselect 
Include Only Selected Classes, and click OK. Then, expand the tree. Or, right-
click and select Select again to make additional changes.

Finding an Instance or Device
If you need to locate an element by name, class, or IP address, use one of the 
following search tools. For example, if the class exceeds 1000 elements and the 
Topology Browser does not expand, you can select the class in the Find Instance 
search tool to list all of its instances. After you receive search results, you can open 
the Topology Browser for topological information about the element, examine 
components of the element with the Containment dialog box, or display a map of it 
using Show Map.

In the consoles, the Edit menu lists the options, Find Instance and Find System. 

• Use Find Instance to locate any topological element including application 
services, service offerings, service subscribers, and systems.

• Use Find System to locate systems or devices like routers and switches.
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F i n d i n g  a n  I n s t a n c e

To search for an instance, select Edit > Find Instance in your console. The Find 
Instance dialog box displays.

Fill in the fields, as described below, and then click Find. The fields are:

• Manager lists the CNCC Managers to search. Select one.

• Class is a list of classes to search. You must select one or more classes. (To 
select multiple classes, press the Ctrl or Shift key while making your 
selections.)

• Instance name is the instance you wish to find. You can specify a complete 
name, a partial name with wildcard characters, or the asterisk (*) wildcard if 
the name is unknown and you wish to search for all instances. For a list of 
wildcards, see Wildcard Patterns on page 137.

Click Find to start the search. The results display in a table.

F i n d i n g  a  S y s t e m

To search for a system, select Edit > Find System in your console. The Find 
System dialog box displays.

Fill in the fields, as described below, and then click Find. The fields are:

• Manager lists the CNCC Managers to search. Select one.

• System name or IP Address is the device or IP address you wish to find. 
Specify the device name (for example, moto-gw), a complete name (for 
example, moto-gw.cisco.com), or an IP address. Wildcard characters are not 
permitted.

Click Find to start the search. The results display in a table.

S e a r c h  R e s u l t s

After the search results display in the table, you can sort them by clicking one of 
the column headings. You can also select one of the table rows and use a button at 
the bottom of the dialog box: 

• Browse to display the Topology Browser for the instance

• Containment to display a Containment dialog box of the instance

• Show Map to display the instance in the Map Console

Click Close to exit the dialog box.
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Using the Containment Dialog Box
The Containment dialog box displays information about an element’s containment 
in tabular format. It provides information and components for a selected element. 
For example, for a selected port or interface, the Network Adapters tab displays its 
status, mode, current utilization, and the name of a peer network adapter. 

Note: Containment is not available for user-defined groups and services.

Several methods exist to display a Containment dialog box. For example, you can 
display containment information in either a dialog box or a view. To do so, you 
can:

• From the map tree, select an instance in the map tree, right-click and select 
Containment in the pop-up menu.

• In a map, right-click on a node and select Containment in the pop-up menu. 
For a green node, double-click on it to display the dialog box.

• From Find Instance or Find System dialog boxes, click Containment.

• In the Event menu or the pop-up menu, right-click on a selected notification 
and select Containment in the menu.

• In the pop-up menu of the Topology Browser Console, right-click on a 
selected element in the tree and select Containment in the menu.

• Add a Containment view using View> Add View.

In the Containment dialog box, information is organized using tabs. Each tab 
consists of a table. Depending upon the type of element and the type of analysis 
being performed by the underlying domain, different information is available.

For example, if InCharge IP Performance Manager is enabled on the underlying 
Domain Manager, tabs for memory, processor, and environment display. If IP 
Performance Manager is not enabled, the tabs do not display or specific columns 
such as CurrentUtilization appear blank. 

The following buttons are available: Refresh, Browse, Save Table, and Close. 
Save Table saves the contents of a selected tab locally as a text file. (For 
information, see Saving Audit Log and Containment Information on page 114.)

C o n t a i n m e n t  D i a l o g  B o x  E x a m p l e

Figure 12 shows an example of a Containment dialog box for router 
moto-gw. 
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Figure 12: Containment Dialog Box
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Examining Maps
A map provides a graphical representation of your topology and, by default, is 
updated continuously. As you monitor your managed domain, you might need to 
examine the elements of your maps and investigate the active events that affect 
them. 

This chapter explains:

• Alternative methods for accessing individual maps, including navigation 
methods

• How maps represent topological information 

• How color-coding in a map represents notifications

• Map types

• How to dynamically change the contents of your console as you work. For 
example, console features for refining the contents of your maps may include 
map layouts, magnify or shrink a map, map backgrounds, and filtering.

For descriptions of console layout and available menus, see Global Console 
Overview on page 4.
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Accessing Maps
This section describes alternative methods for accessing individual maps and how 
to navigate among maps.

In addition to the different methods for opening available consoles (Starting a 
Session on page 29), you can access a map using Show Map from any existing 
console. Show Map opens the Map Console and displays the default map for the 
selected element. Show Map is available as a button in some secondary windows 
and dialog boxes or as a menu option for selected notifications. For example:

• The Show Map button appears in the Find Instance and Find System dialog 
boxes. (The button is activated when you select a row in the table.)

• The Show Map option appears in the Event menu or the pop-up menu if you 
right-click on a selected notification.

• Use the Show Map toolbar button to display a default type of map for a 
selected summary. Show Map is enabled if a topological filter is specified for 
the summary. For information, see Filtering Summaries on page 91.

Opening a Map
When you open a Map Console, you need to select a Global Manager from the 
Manager pull-down menu to display an expanded map tree in the Topology tab of 
the left panel. In a tree, a plus (+) sign indicates that the object or class can be 
expanded. (On some systems, an open circle appears instead of a plus sign.)

The Groups tab in the left panel displays a tree of user-defined groups for 
topological elements if the groups exist. 

Different types of maps are available for the instances in each tab.

If relevant topological information is not available for a selected instance, a 
message appears, stating that a map is not available.

To open a map in either tab, perform these steps:

1 Select a Global Manager from the Manager pull-down menu to display an 
expanded map tree in the Topology tab.

Or, click the plus sign next to a group in the Groups tab. 

• For a class in the Topology tab, you can view its elements (instances). 

• For a group in the Groups tab, you can view its subgroups.

2 For the default type of map, you can click an instance in the map tree. Or, 
right-click on an instance and select the type of map you wish to display from 
the pop-up menu. The map appears in the right panel.
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Also, you can right-click on an icon in the existing map and select another type of 
map from the pop-up menu. 

Note: If a saved map of a given map type exists for the selected element, it is displayed. 
See Saving a Map on page 114 for more information.

To display more than one map concurrently, right-click on a node in an existing 
map. Then, select Map Window from the pop-up menu and, in the submenu, select 
another map. A secondary window displays the additional map. 

Navigating Among Maps
To navigate between multiple maps, the Map Console provides several navigation 
methods:

• The map tree—Previously-discussed. You can select an element in the map 
tree to display the default type of map. Or, you can select an element in the 
tree, right-click, and select another type of map from the pop-up menu.

• A node in a map—You can right-click on a node in an existing map and select 
another map in the submenu. 

• A drop-down history field—It lists the current map (instance and map type) 
and other recently-viewed maps. To re-display a map, select it from the 
history field.

• Previous and Next toolbar buttons—They enable you to move quickly 
between maps.

• Multiple windows of maps—Previously-discussed. Open additional windows 
to concurrently display maps of your selected node. To do so, right-click on a 
selected node in a map, select Map Window, and choose a map type.

Available Topological Information and Its 
Representation

The Map Console is designed especially to display information about a managed 
topology using a variety of map types. For example, the VLAN Connectivity map 
reveals the connections to a VLAN and the VLAN Membership map reveals the 
members of a VLAN.
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You can broaden the scope of the map by expanding nodes and incrementing map 
hops to reveal additional relationships.

Map Scope
For most maps, a map is centered around a selected node (for example, a device, IP 
network, VLAN, or service) and shows connections to the selected entity (one hop 
away). You can change the scope of the elements displayed in the map to see 
additional connected elements by incrementing the number of hops. You can 
expand an entire map, one or more individual devices, or a service one increment 
at a time. A hop is the distance between two nodes that are either physically or 
logically connected.

• For an entire map, the scope of a map is defined by the number of hops from 
the focal object (boxed icon). Each time you select the Increment Hops 
option, a map expands by adding all nodes (and their edges) that are one hop 
away from any existing, expandable node.

• For individual devices, when you select a device and use the Expand Node 
option, a map expands by adding all nodes (and their edges) that are one hop 
away from the selected device. (You can select more than one individual 
device by pressing the Ctrl key while you use the Expand Node option.)

Note: Using the Expand Node option and the Increment (or Decrement) Hops option 
together may result in unexpected behavior. To avoid this, use the Reset Map 
option after the Expand Node option before you use the Increment (or Decrement) 
Hops option.

Note: The options Increment Hops, Decrement Hops, and Expand Node are not available 
for IP Network Membership, VLAN Membership, IP Network Physical 
Connectivity, VLAN Physical Connectivity, and any type of Group map. The 
scope of these maps always includes the set of devices in the selected IP network, 
VLAN, or group.

Applications and Business Services maps support the Expand Node option, but not 
Increment Hops.
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Common Map Attributes
The following attributes, classified by entity, are common to all maps:

• Nodes—A node represents a device, IP network, VLAN instance, service 
subscriber, service offering, an application, or a user-defined group. The icon 
used to depict a node depends on the class of the instance. A severity icon bar 
underneath a node is colored to indicate that its state is normal, affected by 
one or more abnormal conditions, or unknown. A plus sign (+) next to a node 
indicates that it is connected to additional nodes not currently shown in the 
map. A box outlining a node indicates that the node is a map focal node. One 
or more nodes compose a map. You can incrementally expand the scope of 
the map to show the additional nodes connected to devices.

• Edges—An edge represents a relationship or connection between nodes (for 
example, a physical connection such as a cable on a Physical Connectivity 
map), or participation in a logical group (for example, routers participating in 
a VLAN for a VLAN Connectivity map). The representation depends on the 
type of map. An edge that represents a topological instance is colored to 
indicate its status (for example, green for Normal). If an edge represents a 
relationship, it is colored black.

Tool  Tips in Maps
To activate a tool tip, hold the cursor over the object. For example, a tool tip 
provides the following information for these map icons: 

• A device (node). Tool tip lists the device’s name, model, location, contact, 
and description.

• An IP network (node). Tool tip lists the number of devices, by type, that are 
member systems of the IP network.

• A VLAN (node). Tool tip lists the number of devices, by type, that are 
member systems of the VLAN.

• A group (node). Tool tip lists the group’s name, number of individual 
members, and number of subgroups.

• A service (node). 

• Application service. Tool tip lists the application service’s name, the 
device that hosts it, and a description. 

• Application services (cluster). Tool tip lists the application cluster’s 
name, the number of application services, and a description. 
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• Service subscriber. Tool tip lists the service subscriber’s name and 
number of service offerings. 

• Service offering. Tool tip lists the service offering’s name and number of 
service subscribers.

• Edges:

• Physical connectivity or network connection. Tool tip lists interface and 
port endpoint information.

• All other map edges. Tool tip lists the object’s name at each endpoint.

Note: Tool tip information for edges in Group maps is not available.

For example, in a Physical Connectivity map containing routers, switches, and 
their physical connections. The tool tip displays:

• For each router and switch, the device’s name, model, location, contact, and 
description.

• For the physical connections, the interface or port number at each end of the 
connection.

Representing Notifications in Maps 
In a map, the icons (nodes and edges) reflect the collective state of active events on 
an object. 

Understanding Color Coding and Icons
Similar to notifications in the Notification Log Console, the map uses color to 
indicate that elements are affected by one or more abnormal conditions. A color-
coded severity bar indicates the state of the node. 

Note that the color-coded severity bar is not displayed for nodes whose state is 
normal.
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Note: The notification list configured by your administrator determines which 
notifications are reflected in your Map Console. If the notification list does not 
include an event, notifications for the event will not be reflected in the map icons. 
For example, if a notification list excludes all events from a specific router, the 
router always appears with a normal state in the map. If your Map Console does 
not accurately reflect observed conditions, contact your administrator.

Table 19 summarizes the colors that display in a map. 

Table 19: Colors and Meanings

Note: In an IP Network map, the node for an IP network is always normal, even if the 
network is inaccessible. 

By default, the Normal status indicator is not displayed. However, you can change 
the setting that controls this display. See Command Syntax for the -D Option on 
page 121.

To view the icons and other visual indicators used in maps, select Map > Map 
Legend. 

CONDITION
SEVERITY ICON 
(NODES ONLY)

COLOR 
(NODES AND EDGES)

Critical event Red 

Major event Orange 

Minor event Yellow 

Unknown Light blue

Normal/okay Green 

Note: The severity icon does not display for edges. However, the color of an edge is 
meaningful, as follows:
• Edges that represent topology instances are color-coded to reflect status.
• Edges that represent relationships such as VLAN Membership and IP Network 

Membership are colored black. 
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Your administrator can configure custom map icons to represent map elements. 
For information, see Network Connectivity Monitor Service Assurance Manager 
Configuration Guide. 

Displaying Notif icat ion and Topological  Information
To display detailed diagnostic information, you can:

• Double-click on a node or group icon with a severity bar to display the 
Notification Properties dialog box. Or, right-click and select Notification 
Properties in the pop-up menu. For information about the Notification 
Properties dialog box, see Displaying Notification Properties on page 43. 

If more than one notification affects the icon, you are prompted to select one 
(see A Map Consideration on page 47).

Note: Double-clicking on a node with a green severity bar displays the Containment 
dialog box if component information is available. For information, see Using 
the Containment Dialog Box on page 64.

• Right-click on a selected edge (solid line or jagged line) in a Physical 
Connectivity, IP Network Connectivity, or VLAN Connectivity map. The 
pop-up menu lists Notification Properties and the Browse option for the 
Topology Browser.

• Right-click on a selected node, select the Browse option, and view the colored 
events in the Events tab.

Types of Maps
The types of maps that are available depend on your license(s) and user profile. 
The Group maps need to be configured by your administrator and may not be 
available for your session. 

Network Topology Maps
The network topology maps and related classes are available for the IP Availability 
Manager or IP Performance Manager. 
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Network topology maps contain elements such as IP networks, VLANs, routers, 
switches, and hosts, and various types of connections such as cables and trunk 
cables. The maps typically depict connectivity between elements or device 
membership. Network topology maps are described more completely in the 
Network Connectivity Monitor IP Availability Manager User’s Guide and 
InCharge IP Performance Manager User’s Guide.

Types of network topology maps are:

• Physical Connectivity Map

• IP Network Connectivity Map

• IP Network Membership Map

• VLAN Connectivity Map

• VLAN Membership Map

Business  Services  Maps
The Business Services map and related classes are available for the Business 
Impact Manager. 

Business Services maps display service subscribers (organizations, business units, 
lines of business (LOBs), departments, and customers), business processes, service 
offerings (for example, order capture, Router Services, Domain Name Service), 
application services (for example, applications, services), sessions and 
transactions, redundancy groups, and related elements. The Business Services 
maps are available for infrastructure elements in the Topology tab and groups in 
the Groups tab.

Business Services maps are described more completely in the InCharge Service 
Assurance Manager User’s Guide for Business Impact Manager.

Applicat ions Map
The Applications map and related classes are available for the Application 
Services Manager. 

An Applications map displays the topological elements related to the delivery of 
application services. Such elements may include the systems that host 
applications, various types of application services and applications, sessions and 
transactions. 

Applications maps are described more completely in the InCharge Application 
Services Manager User’s Guide.
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Group Maps
A group consists of one or more infrastructure devices, IP networks, VLANs, 
subgroups, and services. Groups are created by your administrator and may not be 
available for your session. For information about creating groups and importing 
data for groups, see the Network Connectivity Monitor Service Assurance Manager 
Configuration Guide. 

A member can be an infrastructure device, IP network, VLAN, application service, 
service subscriber, or service offering. A member cannot be a subgroup.

A group map can display other groups (subgroups/child groups). To display the 
elements belonging to a group, double-click on a selected group node. If the 
elements exceed 100, you are prompted to confirm whether to display them. 

For a high-level group, individual members, not assigned to any subgroups, do not 
display in a map. Members are only displayed for groups which do not have 
subgroups.

The group node is colored to indicate that its state is normal, affected by one or 
more abnormal conditions, or unknown. The color is determined by the highest 
severity condition affecting the elements of the group. For example, if an element 
is experiencing a critical failure, the status bar is colored red. Edges for groups do 
not change colors.

In a Connectivity group map, one solid line edge represents aggregated 
relationships. Elements of one group have one or more connections with elements 
of another group.

Types of group maps are:

• Group Physical Connectivity Map. This map displays physical connectivity 
between group elements. The solid line edges between groups represent one 
or more physical connections between elements of different groups. The 
edges do not change colors to reflect their state. The number of hops cannot 
be changed.

• Group IP Network Connectivity Map. In this map, an edge between two 
groups indicates that there are one or more IP networks common to the two 
groups. The group icon containing the IP network is displayed; an IP network 
icon is not displayed. The number of hops cannot be changed.
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• Group VLAN Connectivity Map. In this map, an edge between two groups 
indicates that there are one or more VLANs common to the two groups. The 
group icon containing the VLAN is displayed; the VLAN icon is not 
displayed. The number of hops cannot be changed.

• Group Membership. This map displays all of the elements of a selected group 
or a subgroup. The edges do not display. The concept of a hop is not 
applicable.

G r o u p  I P N e t w o r k  C o n n e c t i v i t y  M a p  E x a m p l e

To display a Group IPNetwork Connectivity map, perform these steps:

1 Open the Map Console.

2 Select a group in the Groups tab, right-click and select Group IPNetwork 
Connectivity in the pop-up menu. The map displays.

Figure 13 shows a Group IPNetwork Connectivity map for the group USA. Within 
the USA group, the subgroups have devices that share common IP networks. 
Notice that two subgroups, Denver and Boston, are orange, indicating serious 
(major) conditions.
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Figure 13: Group IP Network Connectivity Map

Adjusting the Appearance of a Map
Several methods exist to adjust or fine-tune the appearance of your map. You can:

• Change the layout from circular to hierarchical. Right-click in the map and 
select Hierarchical Layout from the pop-up menu. Objects in your map are 
rearranged and the layout indicator changes, accordingly.

• Change the layout to manual. Right-click in the map and select Manual 
Layout from the pop-up menu. The initial positions of existing nodes are 
retained. (This option is especially useful for large, complex maps.) 
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Any new nodes or edges that appear later due to topology changes, the 
Expand Node option, or Increment Hops, display in the center of the map. 
You can drag them from the center to new positions which will be maintained 
as long as the layout type is manual. 

When elements on a map are removed from the topology, their corresponding 
representation on the map is also removed. When you view the map in 
Manual Layout, the remaining map elements are not repositioned. 

If you change the manual layout to circular or hierarchical, all manual 
positions are lost. If you save a map with manual layout, the positions are 
saved. To return to the map’s default layout or to its layout when last saved, 
select Map > Reset Map. A layout indicator at the top of the right panel 
identifies the layout of a selected map.

• Move or reposition individual nodes in the map by dragging them. (To select 
multiple nodes, press the Ctrl key while making your selections.)

• Enlarge the right panel and hide the map tree. To do so, click on the left 
arrowhead on the panel divider. To display the map tree again, click on the 
right arrowhead.

• Scale the entire map to fit the right panel of the Map Console. 
Right-click in the map and select Fit to Window from the pop-up menu.

• Magnify or shrink a map with Zoom or Overview toolbar buttons. 

• Increase or decrease the scope of your map by one increment at a time. This 
adds new nodes to or subtracts nodes from an existing map. 
Right-click in the map and select Increment Hops or Decrement Hops from 
the pop-up menu.

• Expand a selected node with plus sign to increase the scope for it. Right-click 
on the node and select Expand Node from the pop-up menu. This adds new 
nodes connected to the selected node. (To select multiple nodes, press the 
Ctrl key while making your selections and continue to press the Ctrl key 
when you select Expand Node.)

Note: Using the Expand Node option and the Increment (or Decrement) Hops 
option together may result in unexpected behavior. To avoid this, use the 
Reset Map option after the Expand Node option before you use the Increment 
(or Decrement) Hops option.

• Add and remove classes using a filter. See Filtering Maps on page 83.
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• Color only map objects experiencing root-cause events (IsRoot = Yes). Click 
the Color-by-Root-Cause toolbar button. Map objects without root-cause 
events turn gray. Map objects with root-cause events are colored based only 
on the severity of the root-cause events.

The Color-by-Root-Cause indicator, at the top of the right panel, indicates 
when this option is enabled. This option remains enabled for all maps until 
you click the toolbar button again. 

For example, a router with two events—a non-root event (IsRoot = No) with 
severity 1 and a root-cause event (IsRoot = Yes) with severity 2—is colored 
red. It is colored to reflect the collective state of the active events and, in this 
case, the most critical severity is 1 (red). If you click the Color-by-Root-
Cause toolbar button, the router changes from red to orange, because the lone 
root-cause event has a severity 2.

• Specify a user-defined background. See Customizing Map Backgrounds on 
page 80.

To undo your adjustments, including those made by a filter, and reset the map back 
to its original layout, select Map > Reset Map.

To save your adjustments, see Saving a Map on page 114.

See Navigating Among Maps on page 69 for several navigation methods.

For information about how to create a customized console, see Customizing Your 
Console on page 119.

Customizing Map Backgrounds
You can change the map background color and use custom background images.

Map Background Colors
By default, different kinds of maps are displayed with different color backgrounds. 
Table 20 shows the default map background colors. 

BACKGROUND COLOR TYPE OF MAP

Light blue background Physical Connectivity and Group Physical 
Connectivity maps

Light yellow background IP Connectivity and Group IP Connectivity 
maps
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Table 20: Default Map Background Colors

Note that you can set a parameter, com.smarts.mapBackgroundColor, to customize 
the background color. See Command Syntax for the -D Option on page 121.

Creating Custom Backgrounds
You can create and install custom map backgrounds using your own images. 
Examples may include geographic maps, where map nodes are placed over the 
regions they serve, or organizational charts, where map nodes are placed over the 
organizational departments they serve.

C u s t o m  B a c k g r o u n d  R e q u i r e m e n t s

Ensure that the map background file meets the following requirements:

• Required file format—Must be .gif format. 

• Image size—Must be no larger than 1500 pixels high or 2000 pixels wide. 

• Image file location—Store the graphic file in the following: 
BASEDIR/smarts/local/images/background directory in the host where the 
Global Manager is running. 

A d d i n g  a  C u s t o m  B a c k g r o u n d

To add a custom map background, do the following:

1 Set the Map Console to Manual Layout (as opposed to Hierarchical or 
Circular Layout): Right-click on the map and select Manual Layout from the 
pop-up menu. 

Setting the map to Manual Layout ensures that the position of map elements 
will not change in regard to each other or to their position on the map 
background. In addition, with Manual Layout, the Global Console 
automatically centers the map background within the map window.

2 Right-click on the map and select Set Background from the pop-up menu. 

A dialog box displays that shows thumbnails of the map background images 
available in the BASEDIR/smarts/local/images/background directory. 

Light green background VLAN Connectivity and Group VLAN 
Connectivity maps

Beige background IP Membership, VLAN Membership, and 
Group Membership maps 

Yellow background Business Services maps

Purple background Applications maps
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3 In the Set Map Background dialog box, select an image, adjust the image size 
using the controls at the bottom of the dialog box, and then click OK. You can 
also click Apply to preview the map. 

The Global Console loads the image so that it is centered over the minimum 
rectangular bounding box that includes all of the map nodes.

4 After the map is loaded, you can move the map nodes to the appropriate 
locations on the background image. 

If you repositioned the nodes, right-click on the map and select Fit in Window 
from the pop-up menu.

5 Save the map. When a saved map is opened, map nodes retain their position. 
For information, see Saving a Map on page 114.

R e m o v i n g  a  C u s t o m  B a c k g r o u n d

To remove a custom background and return to the default background, open the Set 
Map Background dialog box, select No Background Image from the pull-down 
menu, and click OK.

Viewing Large Maps: Overview Window
The Overview window displays the entire contents of the map currently being 
viewed in the right panel as in Figure 14. This feature is useful for viewing precise 
areas of a large map. 

To magnify areas in your map, perform these steps:

1 Open the Overview window. Click the Overview toolbar button or select Map 
> Overview.

2 Create a magnification rectangle (yellow) in the Overview window. To do so, 
click and drag the pointer to outline a small rectangular area. This area is then 
magnified and displayed in the right panel. 

To resize the rectangle, click and drag its borders in the Overview window. The 
smaller you make the rectangle, the more magnified the view becomes in the right 
panel. 

You can also move the rectangle to a new area as well, by clicking and dragging it. 
As the rectangle is moved, the view in the right panel changes accordingly. 
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Figure 14: Map Console With Overview Window

Filtering Maps
The map filter enables you to control which classes of instances appear in a 
specific map. You can remove classes of devices (systems) and logical groups and 
add them back again. Filter criteria are saved if you save your maps. See Saving a 
Map on page 114.

You can also filter a map by root-cause. See Adjusting the Appearance of a Map on 
page 78 for more information.
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R e m o v i n g  a  C l a s s

To remove one or more classes, perform these steps:

1 Select Map > Edit Map Filter in the Map Console. The Map Filter dialog box 
displays.

2 Select a class from the Included Classes list and click Remove. The class is 
moved to the Filtered Classes list.

3 To remove another class, repeat Step 2.

4 After the last selection, click OK.

A d d i n g  a  C l a s s

To add one or more classes, perform these steps:

1 Select Map > Edit Map Filter in the Map Console.

2 Select a class from the Filtered Classes list and click Add. The class is moved 
to the Included Classes list.

3 To add another class, repeat Step 2.

4 After the last selection, click OK.
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Examining Summaries
The Summary View Console provides a graphical overview of notifications, 
alarmed elements, and business impact instances. By default, a summary is 
updated continuously. As you monitor your managed domain, you might need 
more information about a specific summary or to investigate the attributes that 
compose it. You may also need to add new summaries or modify existing ones.

This chapter explains:

• Alternative methods for accessing summary information, including 
navigation methods

• How summary information is represented

• How to dynamically change the contents of your console as you work. For 
example, console features for refining the contents of your Summary view 
may include adding or deleting summaries and filtering.

For descriptions of console layout and available menus, see Global Console 
Overview on page 4.

Accessing Summary Information
This section describes another method to access summary information and how to 
navigate between a summary and its notifications or its default map.

In addition to the different methods for opening available consoles (Starting a 
Session on page 29), you can add a Summary view to any existing console to 
access summary information. (For information about views and adding views, see 
Customizing Your Console on page 119.) 
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To navigate between an individual summary and its corresponding Notification 
Log view, perform these steps:

1 Right-click the summary and select Show Notifications in the pop-up menu. 
Or, for the selected summary, click Summary > Show Notifications or the 
Show Notifications toolbar button. 

The Notification Log view for the selected summary displays in a secondary 
window. 

2 To return to the Summary view, click Close in the Notification Log view.

To navigate between an individual summary and its corresponding default map, 
perform these steps:

1 Right-click the summary and select Show Map in the pop-up menu. The 
default type of map for the selected summary displays in a secondary window. 

2 To return to the Summary view, click Close.

Note: Show Map is enabled if a topological filter is specified for the summary. For 
information, see The Topology Filter Dialog Box on page 92.

About Summaries
A summary provides a graphical overview (bar chart or pie chart) of notifications 
from one source, a Global Manager. A Summary view can contain several 
summaries attached to either the same Global Manager or to different Global 
Managers. 

Summaries can represent notifications for infrastructure elements and collection 
objects (ServiceOffering, ServiceSubscriber, or any group created by your 
administrator), organized in some meaningful way. The content is determined by 
summary parameters and, optionally, a filter. For information on summary 
parameters, see Adjusting the Contents of a Summary View on page 88. For 
information about filters, see Filtering Summaries on page 91. 

When you are interpreting summaries, you should be aware of the different 
components of a summary and the information they represent. 
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Summary Components
A summary view is a graphical display of information in either a horizontal bar 
chart or a pie chart. The chart represents the number (horizontal bar chart) or 
percentage (pie chart) of counted items (notifications, alarmed elements, or 
impacts). For example, a chart might show the number of Notifications categorized 
by severity level, or the number of Notifications that have been acknowledged.

A summary includes the summary title, which is the user-configurable display 
name of the summary. The default title of a summary is the name of the group, 
service offering, subscriber, or Notification Log. In addition, the summary 
identifies the Global Manager that is the source of the summary information.

The summary represents the counts by numeric values (labels) and visually by 
horizontal bars or sections of a pie. 

Note: If the criterion is Severity, the colors of the horizontal bars correspond to those in 
the Notification Log legend; otherwise, the colors are not significant. 

In a horizontal bar chart, the labels are displayed as a vertical list along the left side 
of the bars, while the counts for each category are displayed horizontally across the 
bottom. In a pie chart, the sections represent the percentage of each category, with 
a legend indicating the category criteria.

To display the count or the percentage information in a tool tip, hold your cursor 
over a horizontal bar or pie section. 

For instructions about changing the contents of a summary (for example, its title, 
counted elements, or criterion), see Modifying a New Summary or an Existing One 
on page 89.

U n a v a i l a b l e  ( G r a y )  C o n t e n t

Sometimes, the contents of a summary turn gray. This occurs if: 

• The Global Console disconnects from the Global Manager. When the 
connection is re-established, the affected summaries in the Summary view are 
automatically recounted and displayed.

• A collection object specified for a summary’s topological filter is removed 
from the topology.
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Calculat ion Notes
Depending on the summary, when a counted item (an affected element, an event, 
or impact value) matches more than one value of the criterion the sum of the 
detailed counts might exceed the totals. For example, if affected devices are 
counted by instance name such as RouterCore*, Router*, and Switch*, the detailed 
counts might exceed the number of affected devices in the total count because, for 
example, any instance name that matches RouterCore will also match Router, and 
will therefore be counted twice.

H o w  P e r c e n t a g e s  A r e  C a l c u l a t e d

To display percentages or total count, use a tool tip. Hold your cursor over a 
horizontal bar or pie section.

Percentages are calculated as follows:

• For counted elements, the percentage is the number of elements experiencing 
events for a given value of the criterion, divided by the total number of 
elements in the summary.

For example, for elements counted by the criterion, severity, 12 (14%) for the 
value Critical indicates that 12 elements have critical events. This represents 
14% of 83 elements in a summary.

• For counted notifications, the percentage is the number of events for a given 
value of the criterion, divided by the total number of events in the summary. 

• For counted impact, the percentage is the sum of the impacts for all events for 
a given value of the criterion, divided by the sum of the impacts for all events 
in the summary. 

Adjusting the Contents of a Summary View
Several methods exist to adjust the appearance of your Summary view. You can:

• Modify a new or an existing summary in a Summary view

• Rename a summary

• Specify a display update interval for a summary

• Add a new summary to a Summary view

• Delete a summary from a Summary view
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• Rearrange summaries within a Summary view

• Apply a filter to a summary

You can also change the name of a Summary View Console, add different views to 
it, and save the console with customizations. For information, see Customizing 
Your Console on page 119.

Modifying a New Summary or an Exist ing One
When you initially open a Summary View Console (File > New) or add a 
Summary view (View > Add View) to a console, it contains one default summary 
for each attached Global Manager. 

To modify a specific summary, edit its parameters and apply or change its filter. 
For information about filters, see Filtering Summaries on page 91. See Figure 15 
for an example. Changes to a summary are saved when you save the console. 

To edit summary parameters, perform these steps:

1 Click on a summary.

2 Select Summary > Edit Parameters. Or, right-click in the area near the 
summary title and select Edit Summary Parameters in the pop-up menu. The 
Edit Summary Parameters dialog box displays. 

Figure 15: Edit Summary Parameters Dialog Box
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3 In the General tab, you can change the following:

• Chart type—Select Horizontal Bar or Pie in the Chart Type drop-down 
menu.

• Title—Select the button for the empty Title field and type the new name. 
To return to the Default title, select the button for Use Default.

• Update interval—Check the Update Continuously check box, or uncheck 
the check box and specify the time in the Update Every field.

4 Click Apply to see the results in the selected summary, then click OK when 
you are finished. Or, you can select the Attributes tab.

5 In the Attributes tab, you can change the summary parameters, as follows:

• Change the criterion used to organize the counts by selecting an attribute 
in the pull-down menu. For attribute descriptions, see Notification Log 
Columns on page 41.

• Specify values for the criterion in the Attribute Values tab. For some 
attributes like Severity, the values are predefined. For other attributes like 
InstanceName, you can specify exact names or names with wildcard 
characters for pattern matching. Values are case-sensitive. Use the Other 
check box to count events that do not match any of the values. (For a list 
of wildcards, see Wildcard Patterns on page 137.)

6 Click Apply to see the results in the selected summary, then click OK when 
you are finished.

Modifying a Summary’s  Tit le
In the Edit Summary Parameter dialog box, you can also rename a summary. To 
rename a summary, specify a new name in the Title field of the Edit Summary 
Parameter dialog box and click OK. 

Specifying a Display Update Interval  for a  Summary
In the Edit Summary Parameter dialog box, you can also specify an interval for 
scheduled updates. Summaries are constantly being updated in your console by 
default. If you wish to control how often summaries are updated, you can specify 
time intervals for scheduled updates. 
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To specify an interval for scheduled updates, perform the following steps: 

1 Uncheck the check box for Update Continuously and specify the time in the 
Update Every field.

2 Click OK. 

Adding a New Summary to a  Summary View
To add a summary to a Summary view, perform these steps:

1 Click on the view to activate it. The active view has a dark gray border.

2 Select Summary > Add Summary.

Delet ing a Summary From a Summary View
To delete a summary from a Summary view, perform these steps:

1 Click on the summary you wish to delete.

2 Select Summary > Delete Summary.

Rearranging Summaries  in a  Summary View
You can reposition summaries with the arrow toolbar buttons. Clicking the toolbar 
button moves a summary one cell to the left or right. If another summary is next to 
the selected summary, clicking the toolbar button changes the order of the 
summaries.

You can also specify how many summaries appear per row in a Summary view. To 
do so, click on the view and select Summary > Layout. The default value is four. 
Specify a number and click OK.

Filtering Summaries
The Summary view uses the same filtering mechanism as the Notification Log 
view except that there is an additional topological filter and a default filter criterion 
for active events. The default filter criterion for active events ensures that the 
summary represents only active events. There is one filter per summary. Filter 
criteria are saved if you save your console.

To apply a filter to an individual summary, use the Topology Filter dialog box 
which is available from the Filter Builder. A topological filter enables you to limit 
the display of notifications for all of the members of a specified collection object. 
A collection object can be a service offering, service subscriber, or any group 
created by your administrator.
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If a topological filter is not specified, the total count indicates the number of 
affected elements for the entire topology and disables the Show Map toolbar 
button for a given summary.

In addition, you can apply filters from the Filter Builder dialog box that control 
which notifications might appear in the summaries. For information, see Filtering 
Notifications on page 54.

Use one of the following methods to open the Filter Builder dialog box: 

• In the Summary View Console, click on a summary and select 
Summary > Filter. 

• Right-click in the area near the summary title and select Filter in the pop-up 
menu. 

T h e  T o p o l o g y  F i l t e r  D i a l o g  B o x

The Topology Filter button appears only for a selected summary. To specify a 
topological filter, perform these steps:

1 In the Filter Builder dialog box, click Topology Filter.

2 In the Class Name pull-down menu, select a collection object 
(ServiceOffering, ServiceSubscriber, or group). 

The value None allows all of the notifications to display in a summary unless 
you specify other filter criteria.

3 Select a class instance from the Select instance list.

If instances do not display in the Select instance list, click Get instances to 
retrieve a list. Depending upon your network configuration and if the 
collection object has thousands of instances, it might take a few minutes to 
retrieve a list.

Instances appear, by default, in the Select instance list if the collection object 
has fewer than 50 instances. To change the value of 50, see Adjusting Java 
Properties on page 120.

The instance’s name will display as a summary title unless you specified a 
title using the Edit Summary Parameter dialog box. (See Modifying a 
Summary’s Title on page 90.)

4 Click OK after your last selection. This immediately applies the topological 
filter to the selected summary and closes the Topology Filter dialog box. 
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If you wish, you can continue to create or modify filter criteria in the Filter 
Builder dialog box. Filter criteria specified in the Filter Builder affect 
notifications which might affect summaries. Note that if you click Cancel in 
the Filter Builder dialog box, the newly-created topological filter is not 
cancelled.
Network Connectivity Monitor Operator’s Guide 93



Examining Summaries
94 Network Connectivity Monitor Operator’s Guide



7
Examining Status Tables
A Status Table Console provides a high-level graphical overview of the status of 
underlying infrastructure elements as they affect the collection objects 
(ServiceOffering, ServiceSubscriber, or any group created by your administrator) 
specified in the Status Table. For example, in a Status Table view, you can 
determine at a glance which services or applications used by corresponding 
business elements are affected by the health of managed infrastructure elements.

A Status Table view is dynamically updated as the state of elements and 
notifications within the Global Manager’s topology is updated. In addition, the 
Status Table view is updated as elements are added or removed from the topology.

This chapter explains:

• How to access Status Table information

• What a Status Table includes

• How to configure a Status Table

The ability to view and configure a Status Table is associated with your user 
profile. Your administrator can configure Status Table views and then associate 
them with your user profile. As a result, your console may or may not display 
Status Table information.

Accessing Status Table Information
To access the Status Table Console, select File > New > Status Table Console. The 
Status Table Console displays in a secondary window. 
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To refresh the information in a row or column, click the name of an element in the 
row or column.

Another method to access Status Table information is to add the Status Table view 
to your console. Select View > Add View. For more information, see Tailoring Your 
Console With Views on page 123.

About Status Table Information
The Status Table Console displays a grid comprised of the following:

• Primary Class (Y axis)—Selection from a group of collection objects 
(ServiceOffering, ServiceSubscriber, or any group created by your 
administrator) 

• Secondary Class (X axis)—Selection from the group of corresponding 
instances of the Primary Class.

For example, for the class, Customer, a Status Table view can show the instances 
and notification status of the various service offerings available to the Customer 
class.

For each point on the grid where an instance of the Secondary Class is located on a 
Primary Class row, the table displays the severity icon for the corresponding 
infrastructure element with the highest severity status, including the status, 
Normal. If there is no severity icon, there is no instance of that element for that 
class.

From the Status Table, you can obtain detailed information about the element.
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Examining Element Detai ls
To see detailed information about an element, right-click the severity icon for the 
element, and then select one of the following options from the pop-up menu:

Table 21: Status Table Pop-Up Menus

Configuring a Status Table View
To configure a status table view, perform these steps:

1 Click on the status table view to activate it. The active view has a dark gray 
border.

2 Select Status Table > Configure Status Table.

The Configure Status Table dialog box displays.

3 In the Domain field, select a Global Manager.

4 Select a class from the Primary Class drop-down list to configure the 
Y-axis.

Classes are collection objects (ServiceOffering, ServiceSubscriber, or any 
group created by your administrator). 

To limit the display, click the check box for Include only selected instances, 
and then highlight the elements you want to include. To include more than 
one instance, press the Ctrl key as you highlight your selections.

5 Select a class from the Secondary Class drop-down list to configure the X-
axis. 

6 Click OK after your last selection. This immediately applies the parameters 
you selected and closes the Configure Status Table dialog box.

The Status Table Console displays using the parameters you entered.

SELECTION 
CRITERIA

OPTION DESCRIPTION

Right-click on 
the severity icon 
for an instance

Browse Opens the Topology Browser view for the current 
Global Manager that contains the selected element 
in a secondary window

Containment Displays an element’s components

Notification Properties Displays notification properties for that element

Show Map Opens a map with that element as focus
Network Connectivity Monitor Operator’s Guide 97



Examining Status Tables
To save your Status Table console, see Using Save on page 129.

For more information about the Status Table as a viewlet, see the InCharge 
Service Assurance Manager Business Dashboard Configuration Guide. 
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Responding to Notifications
Operators can perform a variety of tasks in response to notifications or to changed 
states of map icons. Operators usually address the notifications based upon their 
severity and perform exploratory or corrective actions. This chapter provides step-
by-step instructions for acting upon notifications and for saving and recording 
information.

Note: Depending upon their user profiles defined by the NCM administrator, operators 
might have access to different types of consoles and console operations. 

Instructions apply to the following consoles: Notification Log, Map, Topology 
Browser, and Summary View, unless noted otherwise.

The Notification Life Cycle
A notification can be in one of five states. If the Event State column in your 
Notification Log view is displayed, you can view the event state. The five event 
states are:

• UNINITIALIZED—The original event state of a notification.

The UNINITIALIZED state is not visible in the console because, like any 
client, the console does not receive uninitialized notifications.

• ACTIVE—The event state of a notification when an event occurs and the 
notification informs (notifies) a client of the event. 
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When a notification is notified, the event state changes from the current value 
to ACTIVE. The notification displays in the Global Console unless an 
administrator set a notification list filter that prevents it from displaying.

• SUSPENDED—The event state of a notification when the Global Manager 
can no longer receive information about an active notification (for example, 
an agent is not responding). 

In this case, the notification remains active although its event state changes to 
SUSPENDED and its severity level changes to Unknown (severity=4).

• WAS_ACTIVE—The event state of a notification when an underlying CNCC 
Manager disconnects from a Global Manager (due to a network outage, for 
example) or a Global Manager is restarted.

In this case, the notification remains active although its event state changes to 
WAS_ACTIVE. If the session connection cannot be re-established, the 
severity level also changes to Unknown (severity=4). 

Once the session connection is re-established and the notification is re-
notified, the WAS_ACTIVE state changes back to ACTIVE. If an underlying 
CNCC Manager fails to re-notify an active notification, the system clears the 
event and state of the notification changes from WAS_ACTIVE to 
INACTIVE. 

• INACTIVE—The event state of a notification when a notification has stopped 
occurring. When a notification is in the INACTIVE state, it is said to be 
cleared.

Table 22 summarizes possible event states of a notification and columns that might 
appear in your console.

Table 22: Summary of Event States

For the graphical severity icons that correspond to the severity levels, see 
Notification Severity on page 39.

EVENT STATE COLUMN ACTIVE COLUMN SEVERITY COLUMN

ACTIVE True Can be severity levels 1-5

SUSPENDED True Severity level 4

WAS_ACTIVE True Severity level 4

INACTIVE False None

Note: The UNINITIALIZED event state is not visible in the console.
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Acknowledgement
Operators usually address the notifications based upon their severity and perform 
exploratory or corrective actions. For a list of actions, see Taking Action on 
page 105.

One of the actions that an operator can take is acknowledgement. After an operator 
completes corrective actions or determines that notifications do not require 
attention, an operator can acknowledge active and inactive notifications. 
Acknowledgement informs fellow operators that they can ignore the specific 
notification. When an operator acknowledges a notification, the notification 
ownership (Owner field) is changed to the operator who acknowledged the 
notification and the value Yes displays in the Acknowledged field. 

Inactive notifications can also be automatically acknowledged by the Global 
Manager. When the Global Manager acknowledges an inactive notification, the 
notification ownership is changed to SYSTEM.

Note: Acknowledgement does not change a notification’s state unless the notification 
attribute ClearOnAcknowledge is set to True for a specific notification. For 
information about the attribute ClearOnAcknowledge, see Methods to Clear Active 
Notifications on page 101.

Methods to Clear Active Notif icat ions
Active notifications may become inactive (cleared) in the following ways:

• When an underlying CNCC Manager determines that an event is no longer 
occurring, the state of its notification is changed to inactive and the changed 
state is recorded in the audit log. The CNCC Manager, the source of the 
notification, clears the event. 

• If the source of the notification is not capable of clearing an event, the event 
can be cleared after an expiration interval provided by the source. 

• When the notification attribute ClearOnAcknowledge is set to True for a 
specific notification, the notification becomes inactive when an operator 
acknowledges it.

• When an underlying CNCC Manager fails to re-notify an active notification 
after a disconnect condition is restored, the state of the notification changes 
from WAS_ACTIVE to INACTIVE. The system clears the event. 
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Notif icat ion Archival
The system archives inactive notifications if: 

• They have been acknowledged. 

• The time interval set for the InactiveAutoArchiveIntervalArchival parameter 
has passed. The parameter is specified in the Service Assurance configuration 
file, ics.conf file. 

Related audit logs are also archived. Unacknowledged notifications cannot be 
archived. See Configuration Parameters Related to Notifications on page 104 for 
information about archival parameters.

Archived notifications are removed from the Global Manager’s memory-resident 
database and are written to an archive file. The notification archive file is named 
global_manager.archive and located in the BASEDIR/smarts/local/logs directory.

After a notification is archived, the Global Manager treats a recurrence of that 
notification as though it were a first occurrence. The values of notification 
attributes start all over again: new First Notify time, Count starts at 1, and so on.

Removal  From Display
Notifications, active or inactive, are removed from the console display if they are:

• Filtered out by notification list filter criteria 

• Filtered out by console filter option

• Archived

Example of  a  Notif icat ion’s  Life  Cycle
Each notification has a unique name. A notification’s name consists of the class 
name and instance name where the event occurred, and the event name. The 
notification naming convention is:

NOTIFICATION-ClassName_InstanceName_EventName

For example, the notification NOTIFICATION-Router_R1_Down identifies the 
event Down, which occurred in instance R1 of the Router class. 

The Notification Log Console will not list more than one notification with this 
name. If the event clears and occurs again before it is archived, the Count field is 
increased accordingly.
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The following notification attributes are related to a notification’s state:

• First Notify—Is the first time a notification occurs

• Last Notify—Is the last time a notification occurs

• Last Clear—Is the last time a notification cleared

• Last Change—Is the last time a notification changed

• Count—Is the number of occurrences of an event starting from First Notify 
until Last Notify.

For information on additional notification attributes, see Notification Log Columns 
on page 41.

Table 23 illustrates the states of the notification NOTIFICATION-
Router_R1_Down.

Table 23: States of NOTIFICATION-Router_R1_Down

Notice at 3:05, the notification is archived and the archive action records the most 
recent values for First Notify, Last Notify, and Last Change. A notification cannot 
be archived until it has been acknowledged. Acknowledgement does not change a 
notification’s state unless that the notification attribute ClearOnAcknowledge is set 
to True for a specific notification.

After a notification is archived, the Global Manager treats a recurrence of that 
notification as though it were a first occurrence. The value of notification attributes 
start all over again: new First Notify time, Count starts at 1, and so on.

TIME USER/SYSTEM 
ACTIONS

NOTIFICATION 
STATE

TIME OF FIRST 
NOTIFY

TIME OF LAST 
NOTIFY

TIME OF LAST 
CHANGE

COUNT

2:00 Notify 2:00 2:00 2:00 1

2:15 Clear 2:00 2:00 2:15 1

2:25 Notify 2:00 2:25 2:25 2

2:35 Clear 2:00 2:25 2:35 2

3:00 Acknowledge 2:00 2:25 3:00

3:05 Archived 2:00 2:25 3:00 2

3:55 Notify 3:55 3:55 3:55 1
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Configuration Parameters  Related to Notif icat ions
Inactive acknowledged notifications can be archived after a time interval, if 
archival parameters are specified in the Service Assurance configuration file, 
ics.conf file. Related audit logs are also archived. Unacknowledged notifications 
cannot be archived. 

The following parameters, set in the ics.conf file, control when notifications are 
archived: 

• AutoAcknowledgementInterval controls when an inactive notification is 
automatically marked as acknowledged by the system and ownership 
becomes SYSTEM. 

• InactiveAutoArchiveInterval controls when an inactive and acknowledged 
notification is archived. 

For more information about archival parameters and the archived files, see the 
Network Connectivity Monitor Service Assurance Manager Configuration Guide.

Durable,  Momentary,  and Stale  Notif icat ions
Some notifications are caused by durable events. A durable event has a measurable 
duration; it is active for a period of time (for example, a link failure). Durable 
events are sent from underlying CNCC Managers.

Other notifications are caused by momentary events. A momentary event occurs 
and is significant for only a specific point in time (for example, an authentication 
failure event for a device). 

Whether an event is durable or momentary is indicated in the Event Type column 
of your Notification Log Console. (For column descriptions and also severities, see 
About Notifications on page 38.)

Note: Sometimes, notifications become outdated (or "stale"). Due to network outages, it 
is possible that the underlying CNCC Managers disconnect from the Global 
Manager. At this point, a Session Disconnected notification displays to inform the 
operator that disconnected sources are detected. The notifications from the 
unavailable sources are not updated in the console. See Responding to 
Disconnected CNCC Managers on page 134 for more information. 
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Taking Action
When an event occurs and Service Assurance generates a notification and displays 
a severity icon, you can respond and perform corrective procedures. 

You can:

• Acknowledge notifications.

• Take and release ownership of notifications while you are working on them

• Invoke tools such as Telnet, Ping, e-mail, pager messages, or open and close 
trouble tickets if they have been configured by your administrator.

Acknowledging Notif icat ions
To inform your fellow operators that they can ignore a notification, you can 
acknowledge the notification if you have completed some corrective action for it or 
determined that it can be disregarded. You can acknowledge active and inactive 
notifications.

To acknowledge one or more notifications, perform these steps:

1 In the Notification Log Console, select a notification. (To select multiple 
notifications, press the Ctrl key while making your selections.) 

2 Select Event > Acknowledge. The value Yes displays in the Acknowledged 
field.

When a notification is acknowledged, an entry is added to its audit log. 
Acknowledged notifications may be archived after some period of time, depending 
on your Service Assurance configuration. By acknowledging a notification, you 
automatically take ownership of it.

Unacknowledging Notif icat ions
If you decide that certain acknowledged notifications do require additional 
attention, you can reset acknowledgement to unacknowledgement.

To unacknowledge notifications, perform these steps:

1 In the Notification Log Console, select a notification. (To select multiple 
notifications, press the Ctrl key while making your selections.)

2 Select Event > Unacknowledge. The value No displays in the Acknowledged 
field.
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When notifications are unacknowledged, entries are added to their audit logs. 
Unacknowledged notifications are not archived. Unacknowledging a notification 
does not change the ownership of it.

Taking Ownership
To inform your fellow operators that you are working on a notification, you can 
insert your user name in the notification’s Owner field. To do so, perform these 
steps:

1 In the Notification Log Console, select the notification. 

2 Select Event > Take Ownership or right-click and select Take Ownership 
from the pop-up menu. 

Your user name is added to the Owner field and it is also recorded as an entry 
in the audit log.

The Owner field is informative; no additional rights are granted to the owner. Also, 
if there is an existing owner listed, you can overwrite it when you take ownership. 

Releasing Ownership
To inform your fellow operators that you are no longer working on a notification, 
you can remove your user name from the Owner field. To do so, perform these 
steps:

1 In the Notification Log Console, select the notification.

2 Select Event > Release Ownership or right-click and select Release 
Ownership from the pop-up menu. 

Your user name is deleted from the Owner field and the deletion is also 
recorded as an entry in the audit log.

About Tools
A tool is a program that you can invoke in response to a notification or for a 
topology element. Such an action might be to ping or to telnet to the affected 
system, or to open a trouble ticket for a specific notification.

The Global Console supports these types of tools:

• Server tools are executed by the Global Manager and are available to any 
console that attaches to the Global Manager. 

In console pop-up menus, the server tools are listed in the Server Tools 
submenu.
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Server actions are also recorded as entries in the audit log.

• Client tools are executed by the Global Console and are available to locally 
installed consoles.

In console pop-up menus, the client tools are listed in the Client Tools 
submenu. 

Your administrator can configure the following tools for server or client execution:

• Ping

• Telnet

• Trouble tickets, opening and closing (server only)

• E-mail 

• Pager message 

In addition, your administrator can modify these sample tool programs, provided 
by Cisco, and rename the menu options that appear in your consoles.

• Sample—Ping, Ping Interface, Ping Device, Ping All

• Sample—Telnet

• Sample—Open Trouble Ticket

• Sample—Close Trouble Ticket

The following sections describe how to use Ping and Telnet, open and close trouble 
tickets, display the Tool Output window, and use E-mail, pager message, and their 
recipients dialog box.

Using Ping and Telnet
The tools Ping and Telnet are available from the Global Console. To invoke either 
tool, perform these steps:

1 Right-click on a selection.

• A notification in the Notification Log Console

• A map icon in the Map Console 

• A managed element in the topology tree of the Topology Browser 
Console 

2 Select a tool from the pop-up menu.

Server tools are listed under the Server Tools submenu. 

Client tools are listed under the Client Tools submenu.
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Note: These submenus only display if the tools are configured and are relevant for 
the selected entity.

Menu option names for these tools may have been modified by your 
administrator.

Opening and Closing Trouble Tickets
Trouble tickets are sometimes used to track notifications while the operators are 
working on them. If the trouble ticket tools (Open and Close programs) are 
configured by your administrator, you can open a trouble ticket (insert a Ticket ID 
number) for a notification or close a trouble ticket.

To open and close a trouble ticket for a notification, use the tools, Open Trouble 
Ticket and Close Trouble Ticket, respectively. 

Note: Menu option names for these tools may have been modified by your administrator.

O p e n i n g  a  T r o u b l e  T i c k e t

To open a trouble ticket, perform these steps:

1 Right-click on a selected notification in the Notification Log Console.

2 In the pop-up menu, select Server Tools > Open Trouble Ticket.

C l o s i n g  a  T r o u b l e  T i c k e t

To close a trouble ticket for a notification, perform these steps:

1 Right-click on a selection.

2 In the pop-up menu, select Server Tools > Close Trouble Ticket.

Using the Tool  Output Window
Viewing tool output depends on the tool’s configuration. Typically, the output 
displays in the Tool Output pop-up window, which opens when the tool is invoked. 

In the Tool Output pop-up window, the buttons are:

Stop—Stops the tool program while it is running. 

Print—Prints the output to your default printer.

Close—Closes the window after the tool program completes processing or is 
stopped; you cannot close the window while the tool is running. 
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If the tool produces an error, a message is displayed in the window. (For server 
tools, an error message is displayed in the window on the host where the console is 
running.)

For example, Figure 16 displays the result for the Ping tool when it is invoked for a 
router notification.

Figure 16: Example of a Tool Output Window

E-Mail ,  Pager Message,  and Their  Recipients  Dialog Box
The tools Mail and Pager are available in the Notification Log Console. 

To invoke either tool, perform these steps:

1 Right-click on a selected notification in the Notification Log Console. (To 
include multiple notifications in your message, press the Ctrl key while 
making your selections.)

You can right-click on the selection regardless of its state (active or inactive): 
a cleared problem can be as important as a problem that has occurred.

2 Select Mail or Pager in the pop-up menu.

 This displays the Mail Action or Pager Action dialog box. 

3 In the dialog box, fill in the fields. The Mail Action and Pager Action dialog 
boxes are the same, except for the Mail Subject field and the resulting action.
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The dialog box fields are:

• Manager—Is the Manager for the recipients listed in the To field. If you 
are attached to multiple CNCC Managers, select one.

• To—Designates a recipient for the action. You must select a recipient. If 
you need to send an action to someone who is not listed, click 
Configuration to display the Recipients Editor dialog box and add the 
person to the list.

• Subject—Identifies the subject of the e-mail message. You can change it 
if you wish.

• Message—Is the body of the e-mail or pager message. The message text 
includes the event and related notification attributes. This is not always 
enough information, however, for the person receiving the message. You 
may wish to add a brief note that provides more information about the 
event.

4 Select the recipient.

If you open a Mail or Pager Action dialog box and the To section does not 
initially list recipients, you need to create a distribution list of recipients. For 
instructions, see Preparing a Distribution List on page 110.

5  Click OK to apply your changes and send the e-mail or pager message.

Note: The mail action uses the industry-standard SMTP for e-mail. In the Recipients 
Editor dialog box, you need to verify the values in the Mail server and Sender e-
mail address section that define the values for the mail services running at your 
site.

The pager action requires a shell script, provided by your systems administrator, to 
access the pager software. Your administrator needs to create a script named 
pager.sh in the BASEDIR/smarts/local/actions directory.

P r e p a r i n g  a  D i s t r i b u t i o n  L i s t

The Recipient Editor dialog box enables you to create a list of people to receive e-
mail or pager actions. To open the Recipients Editor dialog box, select Edit > 
Recipients or click Configuration in an open Mail or Pager Action dialog box.
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The Recipients Editor dialog box is divided into four sections: Manager, Current 
Recipients, Recipient Information, and Mail server and Sender e-mail address.

• Manager section lists the CNCC Manager for the recipients. If you are 
attached to multiple CNCC Managers, select one.

• Current Recipients section lists the recipients for a selected CNCC Manager. 
To delete an entry from the list, select it and click Delete. (To select multiple 
entries, press the Ctrl key while making your selections.) Click OK to apply 
your changes.

• The Recipient Information section is where you add new recipients to the list 
or change existing information. 

• Mail server and Sender e-mail address section. The information in this section 
must be correct in order to successfully send e-mail. You can change the mail 
server name and e-mail address.

• The Mail server field must be set to the host name where the mail 
services are running and should match the value specified in the Service 
Assurance configuration file. The default value is localhost. 

If you specify a mail server name in the Recipients Editor dialog box 
which is different from the configuration value, the value in the dialog 
box temporarily overrides the configuration value. To change the name 
permanently, contact your administrator.

• The Sender e-mail address field identifies the operator who is sending the 
e-mail. By default, it displays your own e-mail information. 

A d d i n g  a  R e c i p i e n t

To add a recipient in Recipients Editor dialog box, perform these steps:

1 From the Manager pull-down menu, select the CNCC Manager where you 
want to save the recipient.

2 Provide the recipient’s name.

3 Add the recipient’s e-mail address or pager number. When you choose an 
action, the appropriate phone number or e-mail address is sent to the pager or 
e-mail software.

4 Supply a password if it is required to send a pager message. The password 
value is passed as a parameter to the pager script.

5 (Optional) Add a description for your records. 
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6 Click Apply or Create. The new recipient appears in the list of Current 
Recipients.

7 Click OK to apply your changes.

Saving and Recording Information
In addition to acting upon notifications or the state of icons in maps, you may need 
to add comments to audit logs, save notification information and maps, and print 
tool output and maps.

Adding Comments to  an Audit  Log
Sometimes for documentation purposes, you may need to add comments to an 
audit log for a specific notification. For example, you may wish to log a summary 
of actions taken to solve a problem or list pending issues for the operators on the 
next shift. The inserted entries cannot be edited or deleted and they are archived as 
part of the audit log. Figure 17 shows an example.

To add comments, perform these steps:

1 In the Notification Log Console, select the notification. 

2 Select Event > Add to Audit Log. The Append new item to Audit Log dialog 
box displays. 

Figure 17: Append New Item to Audit Log Dialog Box
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3 Type your comments for one entry and click OK. For more than one entry, 
click Apply after each entry, then click OK when you are finished.

An alternate method for opening the Append new item to Audit Log dialog box is 
to open the Notification Properties dialog box (select Event > Properties). Select 
the Audit Log tab and click Add to Audit Log. 

For additional information about the Notification Properties dialog box, see 
Displaying Notification Properties on page 43.

Saving Notif icat ion Log Information
You can save the contents of a Notification Log view. The information is stored 
locally as an ASCII file. Each row of information is saved as a separate line of text 
in the file. The resulting file can be imported into other applications such as a 
spreadsheet program or printed.

To save notification information, in a Notification Log Console, select Log > Save 
Log Contents to File or right-click on the view title and select Save Log Contents 
to File from the pop-up menu. 

In the Save log contents to file dialog, you can choose format settings and a 
location for the file. 

The Save log contents to file dialog box is divided into four sections and a Save 
Location field: 

• Field delimiter—Separates each field within a line using a tab character or a 
user-specified character such as vertical bar (|). To specify a custom delimiter, 
click the Use custom delimiter option and specify the character; tab is the 
default.

• Column headers—Includes column headers as the first line. To exclude the 
headers, uncheck the Include column headers check box.

• Columns to include—Includes columns that are visible, which is the default, 
or all columns. 

• Notifications to include—Includes all notification rows, which is the default, 
or only selected rows.

• Save location—Specify a directory path and file name, including the file 
extension (.txt). If you do not specify a path, the file is saved locally to the 
BASEDIR/smarts/local/logs directory by default. Or, you can click Browse 
and choose a location in the Select filename dialog box.

Click OK or Apply to create the text file. If the file already exists, its contents are 
overwritten.
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Saving Audit  Log and Containment Information
You can save the contents of an audit log and a selected table of the Containment 
dialog box. The information is stored locally as an ASCII file. Each row of 
information is saved as a separate line of text in the file. The resulting file can be 
imported into other applications such as a spreadsheet program or printed.

To save the information, you can:

• In the Audit Log tab of the Notification Properties dialog box, click Save 
table to file. 

• For a selected tab in the Containment dialog box, click Save Table. 

In the Save table to file dialog box, you can choose format settings and a location 
for the file. 

The Save table to file dialog box is divided into two sections and a Save Location 
field. 

• Field delimiter—Separates each field within a line using a tab character or a 
user-specified character such as vertical bar (|). To specify a custom delimiter, 
click the Use custom delimiter option and specify the character; tab is the 
default.

• Column headers—Includes column headers as the first line. To exclude the 
headers, uncheck the Include column headers check box.

• Save location—Specify a directory path and file name, including the file 
extension (.txt). If you do not specify a path, the file is saved locally to the 
BASEDIR/smarts/local/logs directory by default. Or, you can click Browse 
and choose a location in the Select filename dialog box.

Click OK or Apply to create the text file. If the file already exists, its contents are 
overwritten.

Saving a Map
You can save a map of each map type for each instance in the map tree. The 
purpose of saving a map is to override the default map of the selected type (for 
example, Group Membership or VLAN Connection) for a specific device, IP 
network, VLAN, group, service, or application. 

To save a map, in the Map Console, select Map > Save Map. Click OK to 
acknowledge the pop-up message which displays the location of the saved map. 
The map is saved in the BASEDIR/smarts/consoles/userid directory on the host 
where the Global Manager is running. 
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Some changes you make to the map before saving are also saved. These changes 
can include:

• Adjusted scope (for example, expanded nodes)

• Node positions

• Layout type (circular, hierarchical, or manual)

• Filtered classes

• User-defined backgrounds 

• Zoom level

If you use the Color-by-Root-cause toolbar button to color a map, the map 
coloring is not saved.

If the topology changes after a map is saved, the saved map is updated accordingly.

If you save a map that already exists in your userid directory for a specific element 
and map type, it is replaced. 

When you click on a managed element in the map tree, the Global Console queries 
the Global Manager for a saved map in the following order:

1 The Global Manager checks your remote directory, the 
BASEDIR/smarts/local/consoles/userid directory, for any saved maps for 
that element. If a saved map exists, it displays. 

2 If there is no saved map in your user directory, it then checks for a shared, 
saved map in the BASEDIR/smarts/local/consoles directory on the host 
where the Global Manager is running. 

3 If a saved map exists in the /consoles directory for the selected element, it 
displays. If no map exists, then the Global Console uses the default map for 
the selected element.

Sharing a Saved Map
To share a map saved in your directory with other users, from a Windows 
command line or in a UNIX shell, copy the saved map file from your 
BASEDIR/smarts/local/consoles/userid directory to the 
BASEDIR/smarts/local/consoles directory on the host where the Global Manager 
is running. The map file naming convention is described below.

Note: Write permission to the remote host directory is required for the copy operation.
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M a p  F i l e  N a m i n g  C o n v e n t i o n

Maps are automatically assigned file names by the Global Manager when they are 
saved. The file name given is a combination of the Global Manager name, the 
instance name, and the map type represented by a number. The suffix of the file 
name is icsvm. Table 24 lists the numeric representation for each map.

For example, an NCM-SA Global Manager Physical Connectivity map of router 
moto-gw is assigned the file name: 

NCM-SAmoto-gw1.icsvm

Table 24: Map Identification Numbers

Printing a Map
To print a map, in the Map Console, select Map > Print Map. The Print dialog box 
for your default printer displays. Check your settings for paper orientation and 
resolution if necessary. Click OK. 

You can format your map for printing as follows:

• To scale the map view, use the Zoom In and Zoom Out buttons.

• To print the whole map with all nodes, select Print Setup > Print Entire 
Graph.

NUMERIC REPRESENTATION MAP TYPE

1 Physical Connectivity

2 Physical Connectivity—VLAN

3 Physical Connectivity—IP network

4 IP Network Connectivity 

5 IP Network Membership

6 VLAN Connectivity 

7 VLAN Membership

8 Group Membership

9 Group Physical Connectivity

10 Group VLAN Connectivity

11 Group IP Network Connectivity

12 Business Services

13 Applications 
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• To print the portion of the map that appears in the Map window, select Print 
Setup > Print Window.

• To print selected elements that you have selected in the map, select Print 
Setup > Print Selected.

• To title the print, type the name in the Caption box, ensure that the Print 
Caption check box is checked. You can format the title using the Font button 
and the Position drop-down menu.

Also, you can format the print using the Margins, Multipage Printing and 
Other options.

Printing Tool  Output
When you invoke a tool such as Ping or Open Trouble Ticket from the Global 
Console, the output usually displays in the Tool Output pop-up window. 

To print the output, perform these steps:

1 Click Print. The Print dialog box for your default printer displays. 

2 Check your settings for paper orientation and resolution if necessary. 

3 Click OK.

For more information about tool output, see Using the Tool Output Window on 
page 108.
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Customizing Your Console
The Global Console can be customized according to an operator’s preferences. 
This chapter describes how to change the appearance of your console, customize it 
with views, and save the customized console. Two examples of consoles illustrate 
these customization options.

For information about customizations that control the contents of your console, see 
Adjusting the Contents of a Notification Log View on page 50, Filtering Topology 
on page 61, Adjusting the Appearance of a Map on page 78, and Adjusting the 
Contents of a Summary View on page 88.

Changing the Console Appearance
This section describes how to control the display of the toolbar buttons and status 
bar, the layout of multiple views, and how to revise the text in a console title bar.

Hiding the Toolbar and Status Bar
In a Global Console, toolbar buttons are located below the menus and the status bar 
is located at the bottom of the console. You can control the display of the toolbar 
and status bar. For example, if you prefer to work without toolbar buttons, you can 
hide them.

To hide the toolbar, select View > Toolbar to uncheck the Toolbar option.

To hide the status bar, select View > Status to uncheck the Status option.

To re-display the hidden bar, select the appropriate option in the View menu.
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Changing the Console  Layout of  Views
If your console consists of multiple views, you can change the console layout by 
rearranging the views. To change the layout of a console, perform the following 
steps: 

1 Select File > Layout to display the Console Layout dialog box. In the Console 
Panel Layout section of the dialog box, two pull-down menus appear:

• Panel determines which panel the Tile operation affects.

• Tile controls how multiple views in a panel are displayed. Right To Left 
places the views in a row. Top To Bottom stacks them one on top of the 
next.

2 Click OK.

Note: You can also change the console layout while you are adding or copying views to a 
current console. In the Add View or Copy View dialog boxes, use the Console 
Panel pull-down menus. See Adding a View on page 123 or Copying a View in a 
Current Console on page 124.

Changing the Tit le  of  a  Console
If you wish, you can revise or replace the console title. To change the text in the 
title bar of a console, perform the following steps: 

1 Select File > Layout to display the Console Layout dialog box. 

2 In Title field, type the new console name and click OK. 

Adjusting Java Properties
The -D option for the sm_gui command enables you to adjust specific Java 
properties that affect the Global Console. For example, you can control the display 
of text for toolbar buttons, maps, and the font that displays throughout the console. 
You can also redefine the Java log file location and specify the connection timeout 
for the console.
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Command Syntax for the -D Option
You can specify the sm_gui command with the option from the UNIX command 
line or specify the option in the Service Assurance shortcut for Windows. (In the 
shortcut, open the Properties dialog box and specify the option in the Target field 
of the Shortcut tab.) You can also use sm_edit to add the option in the 
BASEDIR/smarts/conf/console/properties.conf.

The -D option for the sm_gui command is:

sm_gui -D property1=value1-D property2=value2-D ...-D 
propertyn=valuen  

Note: The command must be entered on one line.

Specify the -D option for each property/value pair, including one space after -D. 
For example, to change the font to Arial and set the font to 20 points, specify:

sm_gui -D com.smarts.font=Arial-D com.smarts.fontSize=20

Properties and their acceptable values are listed in Table 25.

PROPERTY
ACCEPTABLE 
VALUE

DESCRIPTION

com.smarts.
connectionTimeout

integer
(in seconds)

This property indicates the maximum amount of time that the console will 
wait for the CNCC Manager pulse check (the upTime attribute) to 
respond. If there is no response within the specified time, the console 
disconnects from the CNCC Manager. 
The default is 300 seconds (5 minutes).
Any integer between 1 - 89 is changed to a minimum value of 90.
Zero (0) or any integer below disables the timeout.

com.smarts.font string Enables a user-specified font to display throughout the Global Console. 
The font must be a Java-supported font appropriate for the operating 
system or it is ignored. The font should reside in the directory location as 
described by Java documentation.

com.smarts.fontSize integer Enables a user-specified font size to display throughout the Global 
Console. The font size must be compatible with the com.smarts.font 
property or it is ignored.

com.smarts.java.log fully qualified 
file name

If specified, the java log contents are saved to the specified file. (The 
default is no file specified.)

com.smarts.map.
showAllBusiness

 true or false True—Shows all nodes and edges in a Business Services map, including 
those that are not part of paths that originate from or terminate at the map 
central node. (This is the default.)
False—Shows the nodes and edges in a Business Services map that either 
originate from or terminate at the map central node.
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Table 25: Properties and Their Values 

com.smarts.map.
showNormalBanner

true or false True—Shows map nodes with the status of Normal with a green color bar 
underneath the icon.
False—Shows map nodes with the status of Normal without a green color 
bar underneath the icon. (This is the default.)

com.smarts.
mapBackgroundColor

string Enables you to specify a single background color for all maps. This 
parameter overrides the default color for all map types. Note that if the 
setting you enter is invalid, the background color for all maps will be 
white.
Use a six-character string, RRGGBB, where RR is a hexadecimal value 
between 00 and ff (= 0 to 255), specifying the red component; GG 
specifies the green component; and BB specifies the blue component. For 
example, to specify the beige color called “antique white” in Netscape, the 
string is: 
com.smarts.mapBackgroundColor=FAEBD7

For default background colors, see Map Background Colors on 
page 80. 

com.smarts.
maxFilterInstances

integer Enables you to change the maximum number of instances that will 
automatically display in the Topological Filter tab. 50 is the default. If a 
class has more instances than the maximum number, you need to click Get 
instances to retrieve a list.

smarts.maps.
maxGroupMembers

a positive 
integer

A positive integer. This is the maximum number of members of a leaf 
group which will display for a Group Membership map without a prompt 
dialog box. The dialog box prompts the operator when there is a large 
number of members to display.
100 is the default.

com.smarts.
maxTopoInstances

integer Enables you to change the maximum number of instances that display for 
a class or relationship in the Topology Browser. 
The default is 1000. we recommend not changing the default unless it is 
necessary because it affects performance and usability.

com.smarts.viewer.
hideToolbarText

 true or false True—Hides the display text for the toolbar buttons. (This is the default.)
False—Shows the text for the toolbar buttons.

com.smarts.viewer.
map.disableMaps

true or false True—Disables the display of maps.
False—Does not disable maps. (This is the default.)

user.timezone timezone 
name

Causes the console to format all times and timestamps according to the 
specified time zone. 
Examples of acceptable values are: PST for U.S. Pacific Standard Time 
and GMT for Greenwich Mean Time.
The default is the time zone where the console is running.
For information, see Class TimeZone at the Java web site 
http://java.sun.com/j2se/1.3/docs/api/ .

PROPERTY
ACCEPTABLE 
VALUE

DESCRIPTION
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Tailoring Your Console With Views
The Global Console is usually defined by one default view, console-specific 
toolbar buttons, and menus. However, the Global Console can consist of multiple 
views. The following console views are available: Notification Log, Map, 
Topology Browser, Summary, Status Table, Notification Properties, and 
Containment. 

You can customize a console to display multiple views. For example, you can add 
a Topology Browser view to your Notification Log Console. Or, you can add three 
Notification Log views to a console; each view using a filter for specific 
notifications. Or, you can customize a Notification Log view and copy it in order to 
provide a consistent display and minimize your customization effort.

Note: The following types of views, Notification Log, Topology Browser, Summary, 
Status Table, Notification Properties, and Containment, can be added, copied, or 
deleted in consoles. In the Map Console, the default Map view cannot be added, 
copied, or deleted.

For information about which views are available through the Global Console, Web 
Console, Business Dashboard, and third-party Web Portal products, see 
Availability of Viewlets on page 6.

Adding a View
To add a view, perform the following steps: 

1 Select View > Add View. This displays the Add View dialog box.

2 Click the View Type pull-down menu to list the available views. Select the 
view you want to add to the console. (A custom view is one that has been 
developed by a programmer to work with the Notification Log Console.)

3 Use the Console Panel pull-down menus to arrange views within the console. 

• The Panel pull-down menu determines where the view appears within the 
console.

• The Tile pull-down menu determines how multiple views within the 
same panel are arranged. Views that are oriented horizontally, such as 
Notification Log, usually display better when they are tiled Top To 
Bottom.

4 Click OK. To add multiple views without reopening the Add View dialog 
box, click Apply.
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Copying a View in a Current  Console
To copy a view in the current console, perform the following steps: 

1 Click on the view you want to copy to activate it. The active view has a dark 
gray border.

2 Select View > Copy View > Copy View. This displays the Copy View dialog 
box.

3 Use the Console Panel pull-down menus to arrange views within the console. 

• The Panel pull-down menu determines where the view appears within the 
console.

• The Tile pull-down menu determines how multiple views within the 
same panel are arranged. Views that are oriented horizontally, such as 
Notification Log, usually display better when they are tiled Top To 
Bottom.

4 Click OK. 

Note that this option is not available for the Map view.

Copying a View to a New Console
You can copy the following views to a new console: Notification Log, Topology 
Browser, and Summary. 

To copy a view to a new console, perform the following steps: 

1 Click on the view you want to copy to activate it. The active view has a dark 
gray border.

2 Select View > Copy View > Copy View as New Console. 

The new console displays over the existing console.

Note that this option is not available for Status Table, Notification Properties, 
Containment, or Map.
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Deleting a View
To delete a view from the console:

1 Click on the view you want to delete to activate it. The active view has a dark 
gray border.

2 Select View > Delete View. 

Saving a View as a  Viewlet
To save a view as a viewlet, perform the following steps:

1 Select View > Save View As Viewlet.

The configure Save View as Console Viewlet dialog box displays.

2 Select the CNCC Manager from the pull-down list.

3 Click either Save for User or Save for Profile, and then select an option from 
the pull-down list.

4 Select or type a name in the View Name field.

5 Click OK after your last selection. This immediately applies the parameters 
to the view and closes the dialog box.

For more information, see InCharge Service Assurance Manager Business 
Dashboard Configuration Guide.

Changing the Tit le  of  a  Notif icat ion Log View 
To change the title of a Notification Log view, perform the following steps: 

1 Select Log > Log Properties to display the Log Properties dialog box. 

2 In Title field, type the new view name and click OK. 

This is useful when you have multiple Notification Log views with different 
filtering criteria.

Context  Sharing Concepts
You can set up context sharing so that a selected entity in one view determines the 
content that is displayed in one or more other views. For example, you can set up 
context sharing so that each time you select a notification in a Notification Log, a 
Map view displays a map for that notification. In this example, the Notification 
Log acts as a source, while the Map view acts as a listener. Without context 
sharing, you have to select a notification in the Notification Log, right-click, and 
select Show Map to display a map for each notification.
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Views can participate in context sharing as sources, listeners, or both. To enable 
context sharing, you need to configure listening views as described in Setting up 
Context Sharing on page 127. Source and listening views can also exist in separate 
consoles.

Table 26 shows the views that can act as sources and indicates which entities you 
can select to change the content in listening views:

Table 26: Source Views and Elements for Context Sharing

The following views can act as listeners: Notification Properties (listen only), 
Notification Log, Summary, Map, and Containment (listen only).

VIEWS THAT CAN ACT AS SOURCES ENTITY TO SELECT

Notification Log view Notification

Summary view Summary
Note that, when you select a summary as a 
source, the Notification Log configured as a 
listener displays the set of notifications 
associated with that summary.

Map view Node or edge

Status Table view (source only) One of the following classes on the Y-axis:
• ServiceOffering and subclasses
• ServiceSubscriber and subclasses
• HierarchicalGroup
• SelectiveGroup
• ApplicationGroup
Any instance on the X-axis.

Topology view (source only) Topology instance
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Table 27 describes the context sharing roles, and shows the icons that display when 
context sharing is implemented.

Table 27: Context Sharing Roles and Icons

Context sharing is disabled for a Notification Log view if the Freeze Display 
option is enabled. To enable context sharing, first unfreeze the display by clicking 
the box icon in the title area. For more information, see Freezing Your Display on 
page 53.

Sett ing up Context  Sharing
To configure a view as a listener, perform the following steps:

1 Select the view to make it active, and then select View > Listen to Context or 
click the Listen to Context toolbar button. 

The Select Context(s) To Listen To dialog box displays with the options that 
are appropriate for that view.

ROLE DESCRIPTION ICON

Source User selection in a source view changes the content in a 
listening view.

Listener The content changes based upon user selection in a 
source view. Any filters set for the listening view will 
continue to control the display.

In the title area, this icon indicates that a view is 
configured as a listener. The tool tip for the icon indicates 
which entities the view is configured to listen to.

In the title area, this icon indicates that a view is actively 
listening (a user selection in a source view is affecting 
the view).
When a Notification Log is configured as a listener, you 
can click on this icon to display the original notifications 
again.
The tool tip for the icon indicates the entity the view is 
currently listening to.
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2 Select one of the following options:

• Listen to ALL—Select all options that this view can listen to

• Collection Entity

• Instance 

• Summary

• Notification

3 Click OK after your last selection. This immediately applies the parameter to 
the view and closes the dialog box.

Removing Context  Sharing
To remove context sharing from a view, perform the following steps:

1 Select the view to make it active, then select View > Listen to Context or click 
the Listen to Context toolbar button. 

The Select Context(s) To Listen To dialog box displays.

2 Select Listen to NONE or any one of the available options that you do not 
want to listen to.

3 Click OK. The Listening to Context icons are removed from the listener view 
(if the view is no longer listening to any option).

Saving a Console
After you customize your console, you can save your console locally on the host 
where the Global Console is running or remotely on the host where the Global 
Manager is running. Table 28 summarizes the customizations and information that 
is saved for your console.
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Table 28: Summary of Saved Customizations 

C o n s o l e  F i l e  N a m i n g  C o n v e n t i o n s

In order for a console to be saved, you must follow these file naming conventions:

• File names must consist of letters, numbers, underscores, dashes or any 
combination thereof. 

• File names must not contain spaces.

Examples of recommended file names are: Console_SA, SA-Map, or Notification-
Log3Views.

Using Save 
To save a console, select File > Save or click the Save toolbar button. 

The Specify save destination dialog box appears if you are saving the console for 
the first time. Click the Local button or the Remote button in the dialog box and 
perform the steps described below, starting with Step 2.

If you have previously saved the console, your customizations are saved 
accordingly and the Specify save destination dialog box does not appear.

Saving a Console  Local ly
To save a console locally, perform these steps:

1 Select File > Save As > Save Local As. This displays the Save Console dialog 
box.

2 Type a name for the console in the File Name field. For a previously saved 
console, the name displays in the field. You can also specify another name 
with the extension .iccon.

WHAT’S SAVED WHAT’S NOT SAVED

Console customizations (hidden bars, layout, 
titles, views)

Topology

Content customizations (filters and 
selections in the Column Sort Order dialog 
box, except for Click Sort)

Click Sort selections

The names of the Global Managers you 
attached to

The actual notifications or maps

Note: To save maps, you must save them separately (See Saving a Map on page 114).
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3 Choose where you want to save the console or note the default location, 
BASEDIR/smarts/local/consoles.

4 Click Save.

5 In the Select Domains to Reattach dialog box, select one or more CNCC 
Managers that the saved console will automatically attach to when the 
console is opened. (To select multiple managers, press the Ctrl or Shift key 
while making your selections.)

This command saves the console settings to a local file. Whenever you start a 
session, to use the local console, you must open it from a running console (File > 
Open > Open Local).

Saving a Console  Remotely
To save a console remotely, perform these steps:

1 Select File > Save As > Save Remote As. This displays the Save Remote 
Console dialog box, as shown in Figure 18.

Figure 18: Save Remote Console Dialog Box

2 Select a location to save the console. Choose a CNCC Manager. 

3 The Save as field lists the names of existing remote consoles. For a previously 
saved console, the name displays in the field. You can also specify another 
name without the extension .iccon.

If a remote console name appears in the field, the existing console might be 
part of your user profile. Contact your administrator to see if you should 
overwrite the existing console.

4 In the Select Domains to Reattach dialog box, select one or more CNCC 
Managers that the saved console will automatically attach to when the 
console is opened. (To select multiple managers, press the Ctrl or Shift key 
while making your selections.)
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5 Click OK. To use the customized console, you must open it from a running 
console (File > Open > Open Remote).

6 (Optional) To share the console with other users, from a Windows command 
line or in a UNIX shell, copy the console file from the 
BASEDIR/smarts/local/consoles/userid directory or the 
BASEDIR/smarts/local/consoles/user_profile directory to the 
BASEDIR/smarts/local/consoles directory on the remote host.

Note: Write permission to the remote host directory is required for the copy 
operation.
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10
Troubleshooting
This chapter contains resolutions to common issues experienced by operators who 
are using the Global Console. 

Checking CNCC Manager Status
If you do not know the operational status of your CNCC Manager, use the 
brcontrol command or the Browse button in the Attach Manager dialog box to list 
the CNCC Managers and their status. The status listed for your CNCC Manager 
should be Running. If your CNCC Manager is not running, contact your 
administrator or consult the Network Connectivity Monitor System Administration 
Guide for instructions on how to start the CNCC Manager.

For the brcontrol command, type one of the command lines shown below.

Table 29: The brcontrol Command

OPERATING SYSTEM EXAMPLE

WINDOWS (MS-DOS PROMPT) BASEDIR\smarts\bin\brcontrol

UNIX BASEDIR/smarts/bin/brcontrol
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Identifying a Port Number
If you do not know the port number of a CNCC Manager, use the brcontrol 
command or the Browse button in the Attach Manager dialog box to display the 
port number. 

Refreshing the Console
If your console does not display properly, you can force the console to redisplay. 
For example, if fragments of menus or fields from dialog boxes linger after the 
menus or dialog boxes close, you can redisplay the console.

To refresh a console, select View > Refresh.

Reattaching to a CNCC Manager
Initially, when you log on to start a session, you specify the CNCC Manager to 
which you wish to attach. Ordinarily, you do not have to attach again during your 
session.

If the machine running Service Assurance becomes unavailable, the Global 
Console polls the broker every 30 seconds and reattaches when the CNCC 
Manager is operational. If you are running the console as a Java applet, you must 
manually reattach to the CNCC Manager. For instructions on how to reattach, see 
Attaching to a CNCC Manager on page 35.

Responding to Disconnected CNCC Managers
When underlying CNCC Managers disconnect from the Global Manager (due to a 
network outage, for example), the notifications from the unavailable sources are 
not updated in the console. The affected notifications, maps, and summaries no 
longer reflect the current conditions. 

If a disconnect situation occurs, a Session Disconnected notification informs you 
that a specific CNCC Manager is disconnected and a similar entry is added to the 
audit log.
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When the CNCC Manager reconnects, the Session Disconnected notification 
clears, and it is recorded in the audit log.

If you receive a Session Disconnected notification, your administrator should 
investigate it to check for a network connection failure or an operational problem. 
The CNCC Manager may need to be restarted.

Accessing Console Message Logs
The Global Console has two logs which are useful for troubleshooting:

• The Java console is the first tool to use for console debugging. It shows store 
exceptions, errors reading attributes, and stack traces. 

• The message log shows everything the CNCC Manager sends to the console 
while the log window is activated (opened or minimized). 

To access the logs, select View > Java Console or View > Message Log.

In the Java console, the following warning is benign:

Warning: Could not get the full set of system properties.
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Wildcard Patterns     

A wildcard pattern is a series of characters that are matched against incoming 
character strings. You can use these patterns when you define pattern matching 
criteria.

Matching is done strictly from left to right, one character or basic wildcard pattern 
at a time. Basic wildcard patterns are defined in Table 30. Characters that are not 
part of match constructs match themselves. The pattern and the incoming string 
must match completely. For example, the pattern abcd does not match the input 
abcde or abc. 

A compound wildcard pattern consists of one or more basic wildcard patterns 
separated by ampersand (&) or tilde (~) characters. A compound wildcard pattern 
is matched by attempting to match each of its component basic wildcard patterns 
against the entire input string. For compound wildcard patterns, see Table 31.

If the first character of a compound wildcard pattern is an ampersand (&) or tilde 
(~) character, the compound is interpreted as if an asterisk (*) appeared at the 
beginning of the pattern. For example, the pattern ~*[0-9]* matches any string not 
containing any digits. A trailing instance of an ampersand character (&) can only 
match the empty string. A trailing instance of a tilde character (~) can be read as 
“except for the empty string.” 

Note: Spaces are interpreted as characters and are subject to matching even if they are 
adjacent to operators like "&".

CHARACTER DESCRIPTION

Note: Spaces specified before or after wildcard operators are interpreted as characters and are 
subject to matching.
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Table 30: Basic Wildcard Patterns

Special characters for compound wildcard patterns are summarized below. 

? Matches any single character. 
For example, server?.cisco.com matches server3.cisco.com and serverB.cisco.com, 
but not server10.cisco.com.

* Matches an arbitrary string of characters. The string can be empty. 
For example, server*.cisco.com matches server-ny.cisco.com and server.cisco.com 
(an empty match).

[set] Matches any single character that appears within [set]; or, if the first character of 
[set] is (^), any single character that is not in the set. A hyphen (-) within [set] 
indicates a range, so that [a-d] is equivalent to [abcd]. The character before the 
hyphen (-) must precede the character after it or the range will be empty. The 
character (^) in any position except the first, or a hyphen (-) at the first or last 
position, has no special meaning. 
Example, server[789-].cisco.com matches server7.cisco.com through 
server9.cisco.com, but not server6.cisco.com. It also matches 
server-.cisco.com.
Example: server[^12].cisco.com does not match server1.cisco.com or 
server2.cisco.com, but will match server8.cisco.com.

<n1-n2> Matches numbers in a given range. Both n1 and n2 must be strings of digits, which 
represent non-negative integer values. The matching characters are a non-empty 
string of digits whose value, as a non-negative integer, is greater than or equal to n1 
and less than or equal to n2. If either end of the range is omitted, no limitation is 
placed on the accepted number.
For example, 98.49.<1-100>.10 matches a range of IP addresses from 98.49.1.10 
through 98.49.100.10. 
Example of an omitted high end of the range: <50-> matches any string of digits 
with a value greater than or equal to 50. 
Example of an omitted low end of the range: <-150> matches any value between 
zero and 150.
A more subtle example: The pattern <1-10>* matches 1, 2, up through 10, with * 
matching no characters. Similarly, it matches strings like 9x, with * matching the 
trailing x. However, it does not match 11, because <1-10> always extracts the 
longest possible string of digits (11) and then matches only if the number it 
represents is in range.

| Matches alternatives. For example,”ab|bc|cd” without spaces matches exactly the 
three following strings:  “ab”, “bc”, and “cd”. A | as the first or last character of a 
pattern accepts an empty string as a match.
Example with spaces “ab | bc” matches the strings “ab “ and “ bc”.

\ Removes the special status, if any, of the following character. Backslash (\) has no 
special meaning within a set ([set]) or range (<n1-n2>) construct.

CHARACTER DESCRIPTION
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CHARACTER DESCRIPTION

& “And Also” for a compound wildcard pattern. If a component basic wildcard pattern 
is preceded by & (or is the first basic wildcard pattern in the compound wildcard 
pattern), it must successfully match.  
Example: *NY*&*Router* matches all strings which contain NY and also contain 
Router. 
Example: <1-100>&*[02468] matches even numbers between 1 and 100 inclusive. 
The <1-100> component only passes numbers in the correct range and the *[02468] 
component only passes numbers that end in an even digit. 
Example: *A*|*B*&*C* matches strings that contain either an A or a B, and also 
contain a C.

~ “Except” for a compound wildcard pattern (opposite function of &).If a component 
basic wildcard pattern is preceded by ~, it must not match. 
Example: 10.20.30.*~10.20.30.50 matches all devices on network 10.20.30 except 
10.20.30.50.
Example: *Router*~*Cisco*&*10.20.30.*~10.20.30.<10-20>* matches a Router, 
except a Cisco router, with an address on network 10.20.30, except not 10.20.30.10 
through 10.20.30.20.
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Network Connectivity Monitor Operator’s Guide 145



Index
Service 58
Service offering 87
Session Disconnected notification 3, 100, 104, 134
Severity Indicator 40
Severity indicator

Color-coded icon 39
Pop-up menu 27

Shortcut key
Menu options 6

sm_gui command 30
The -D option 121

Sort order
Click sort 52
Column Sort Order dialog box 52
Of notifications 51

Source
Context sharing view 126
Software component 41

Status bar
Console information 5
Controlling display 119

Status Table 95
Accessing 95
Classes 96
Components 96
Element details 97
Severity indicators 96
Update 95

Status Table Console 97
Overview discussion 4

Subscriber 87
Summary 23

Access 86
Add a new one 91
Adjust contents 88
Color-coding 87
Components 87
Delete one 91
Display name 87
Edit parameters 89
Filter 91
Navigation 86
Notification attribute role 90
Renaming 90
Specify counts and criterion 89
Title 87
Tool tip 87, 88
Update interval 90, 91

Summary View Console
Access 86

Add a summary 91
Adjust contents 88
Continuous update 90, 91
Delete a summary 91
Edit Summary Parameters dialog box 89
Filter 91
Layout 23
Menu options 8, 24
Navigation 86
Opening

From another console 31
Overview discussion 4, 23
Summary components 87
Toolbar buttons 11, 25, 28
View 23, 123

Rearranging summaries 91
Summaries per row 91

Symptomatic event 45

T
Telnet 107

Invoking 107
Threshold value 46
Timeout

Connection 121
Timezone

Changing 122
Title

Console 120
Notification Log view 125
Summary 90

Tool
Client 106
Output window 108, 117
Printing output 108, 117
Sample programs 107
Server 106
Submenu 11, 17

Tool tip 5, 60
In map 71
Percentages in a summary 87, 88

Toolbar buttons
Controlling display 119

Of text 122
Map Console 19
Notification Log Console 11
Summary View Console 11, 25, 28
Topology Browser Console 11

Topology 20
146 Network Connectivity Monitor Operator’s Guide



Business elements 58
Class 59
Collection object 86, 91
Containment 64, 114
Filter 61
Infrastructure 58
Logical group 58
Navigation 59
Relationship 59

Map 71
Search 62

Topology Browser Console
Attributes tab 20, 60
Closing 34
Customizing 119
Description tab 20, 60
Events tab 20, 60
Exiting 34
Filter 61
Groups tab 20, 60
Invoking tools 107
Layout 20

Changing 120
Log on 30
Maximum instances 122
Menu options 8
Modules tab 20, 60
Navigation 59
Opening 58

From another console 31
Local 32
Remote 32
UNIX 30
Windows 30

Overview discussion 4, 20
Pop-up menu 22
Property sheet 20, 60
Saving 128

Local 129
Remote 130

Threads tab 20, 60
Toolbar buttons 11, 25, 28
View 20, 123

Topology Builder Console
Overview discussion 4

Trouble ticket 42, 107
Invoking tool 108
Printing output 117

Troubleshooting 133
Gray line in attribute value 46

U
User name 31
User profile 2, 5, 95, 99
User-defined field 42

V
View

Adding 123
Affected by console layout 120
Context sharing 126
Copying

In current console 124
To new console 124

Customizing console 123
Deleting 125
Listening 126
Map 12
Notification Log 7
Source 126
Summaries per row 91
Summary 23
Title 7
Topology Browser 20

Viewlet 6
Availability 6
Saving view as 125

VLAN 12, 58
Connectivity map 75
Membership map 75

W
Web browser 29
Web Console

Opening 32
Overview discussion 4

Wildcard 137
Chart of operators 138
Find instance 63
Notification filter 54
Summary 90

Z
Zoom

Map toolbar button 79
Overview window 82
Network Connectivity Monitor Operator’s Guide 147



Index
148 Network Connectivity Monitor Operator’s Guide


	Contents
	Preface
	Intended Audience
	Prerequisites
	Document Organization
	Documentation Conventions
	NCM Installation Directory
	Additional Resources
	Commands
	Documentation
	Network Connectivity Monitor Documentation
	Network Connectivity Monitor Service Assurance Management Documentation


	Obtaining Documentation
	Cisco.com
	Ordering Documentation

	Documentation Feedback
	Obtaining Technical Assistance
	Cisco Technical Support Website
	Submitting a Service Request
	Definitions of Service Request Severity

	Obtaining Additional Publications and Information

	Introduction
	Notification Concepts
	Service Assurance Notifications
	Types of Managers

	Global Console Overview
	View Concepts
	Availability of Viewlets
	Layout of a Notification Log Console
	Notification Log Menus and Pop-up Menus
	Notification Log Console Toolbar Buttons

	Layout of a Map Console
	Left Panel
	Right Panel
	Map Menus and Pop-up Menus
	Map Console Toolbar Buttons

	Layout of a Topology Browser Console
	Topology Browser Pop-up Menus

	Layout of a Summary View Console
	Summary View Menu and Pop-up Menus
	Summary View Console Toolbar Buttons

	Layout of a Status Table Console
	Status Table Menu and Pop-up Menus
	Status Table Console Toolbar Buttons



	Starting a Session
	Opening the Global Console
	Opening a Global Console in a Windows Environment
	Opening a Global Console in a UNIX Environment
	Logging on and Attaching to a Manager

	Opening an Additional Global Console
	Opening a New Console
	Opening a Locally Saved Console
	Opening a Remotely Saved Console

	Opening a Web Console
	Using Java Web Start (Optional)

	Closing a Console and Ending a Session
	Closing a Console
	Ending a Session

	Attaching to Different or Multiple CNCC Managers
	Detaching From a CNCC Manager
	Attaching to a CNCC Manager


	Examining Notifications
	Accessing Notifications
	About Notifications
	Notification Naming Convention
	Notification Severity
	Notification Log Columns

	Displaying Notification Properties
	General Tab
	Audit Log Tab
	Codebook Tab
	Impact Tab
	Details Tab
	Caused By Tab
	Aggregates Tab
	A Map Consideration
	Notification Properties Tab Examples

	Adjusting the Contents of a Notification Log View
	Changing the Contents of a Notification Log View
	Adjusting the Appearance of a Notification Log Console or View
	Controlling the Column Display
	Adjusting the Column Width
	Rearranging the Order of Columns

	Sorting Notifications
	Click Sort Method
	Column Sort Order Dialog Box

	Updating and Freezing Notifications
	Specifying Display Updates for Notifications
	Freezing Your Display


	Using Filters
	Filtering Notifications
	Layout of the Filter Builder
	Pattern Matching
	Example of a Filter



	Examining Topology
	Accessing Topology
	Available Topological Information and Its Representation
	Topology Browser Console or View
	Displaying Topology
	Browse Detail
	Filtering Topology

	Finding an Instance or Device
	Finding an Instance
	Finding a System
	Search Results

	Using the Containment Dialog Box
	Containment Dialog Box Example


	Examining Maps
	Accessing Maps
	Opening a Map
	Navigating Among Maps

	Available Topological Information and Its Representation
	Map Scope
	Common Map Attributes
	Tool Tips in Maps

	Representing Notifications in Maps
	Understanding Color Coding and Icons
	Displaying Notification and Topological Information

	Types of Maps
	Network Topology Maps
	Business Services Maps
	Applications Map
	Group Maps
	Group IPNetwork Connectivity Map Example


	Adjusting the Appearance of a Map
	Customizing Map Backgrounds
	Map Background Colors
	Creating Custom Backgrounds
	Custom Background Requirements
	Adding a Custom Background
	Removing a Custom Background


	Viewing Large Maps: Overview Window
	Filtering Maps
	Removing a Class
	Adding a Class


	Examining Summaries
	Accessing Summary Information
	About Summaries
	Summary Components
	Unavailable (Gray) Content

	Calculation Notes
	How Percentages Are Calculated


	Adjusting the Contents of a Summary View
	Modifying a New Summary or an Existing One
	Modifying a Summary’s Title
	Specifying a Display Update Interval for a Summary
	Adding a New Summary to a Summary View
	Deleting a Summary From a Summary View
	Rearranging Summaries in a Summary View
	Filtering Summaries
	The Topology Filter Dialog Box



	Examining Status Tables
	Accessing Status Table Information
	About Status Table Information
	Examining Element Details

	Configuring a Status Table View

	Responding to Notifications
	The Notification Life Cycle
	Acknowledgement
	Methods to Clear Active Notifications
	Notification Archival
	Removal From Display
	Example of a Notification’s Life Cycle
	Configuration Parameters Related to Notifications
	Durable, Momentary, and Stale Notifications

	Taking Action
	Acknowledging Notifications
	Unacknowledging Notifications
	Taking Ownership
	Releasing Ownership
	About Tools
	Using Ping and Telnet
	Opening and Closing Trouble Tickets
	Opening a Trouble Ticket
	Closing a Trouble Ticket

	Using the Tool Output Window
	E-Mail, Pager Message, and Their Recipients Dialog Box
	Preparing a Distribution List
	Adding a Recipient


	Saving and Recording Information
	Adding Comments to an Audit Log
	Saving Notification Log Information
	Saving Audit Log and Containment Information
	Saving a Map
	Sharing a Saved Map
	Map File Naming Convention

	Printing a Map
	Printing Tool Output


	Customizing Your Console
	Changing the Console Appearance
	Hiding the Toolbar and Status Bar
	Changing the Console Layout of Views
	Changing the Title of a Console

	Adjusting Java Properties
	Command Syntax for the -D Option

	Tailoring Your Console With Views
	Adding a View
	Copying a View in a Current Console
	Copying a View to a New Console
	Deleting a View
	Saving a View as a Viewlet
	Changing the Title of a Notification Log View
	Context Sharing Concepts
	Setting up Context Sharing
	Removing Context Sharing

	Saving a Console
	Console File Naming Conventions
	Using Save
	Saving a Console Locally
	Saving a Console Remotely


	Troubleshooting
	Checking CNCC Manager Status
	Identifying a Port Number
	Refreshing the Console
	Reattaching to a CNCC Manager
	Responding to Disconnected CNCC Managers
	Accessing Console Message Logs

	Wildcard Patterns
	Index

